summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-16 13:07:24 +0100
commit0c100b7dd2b30e75b799d806df4ef899fd98e1ea (patch)
tree464c922e949c7e4d5d891fb2cdda5daee5612537 /net-im/telegram-desktop/files
parente68d405c5d712af4387159df07e226217bdda049 (diff)
gentoo resync : 16.04.2022
Diffstat (limited to 'net-im/telegram-desktop/files')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch31
-rw-r--r--net-im/telegram-desktop/files/tdesktop-3.6.1-fix-kwayland-5.93.patch55
2 files changed, 55 insertions, 31 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch b/net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch
deleted file mode 100644
index e99cd2e4bf91..000000000000
--- a/net-im/telegram-desktop/files/tdesktop-3.4.8-jemalloc-only-telegram.patch
+++ /dev/null
@@ -1,31 +0,0 @@
-Only link jemalloc for the Telegram binary
-
-Some combination of factors is making the different codegen tools hang when
-jemalloc is linked for those, and they're ran under portage's sandbox. Since
-this is only used during build-time, and jemalloc is merely necessary to
-improve runtime memory use, it's unnecessary to use it for anything else.
-
---- tdesktop-3.4.8-full.orig/Telegram/CMakeLists.txt
-+++ tdesktop-3.4.8-full/Telegram/CMakeLists.txt
-@@ -1331,6 +1331,11 @@
- endif()
- endif()
- else()
-+ target_link_libraries(Telegram
-+ PRIVATE
-+ desktop-app::external_jemalloc
-+ )
-+
- if (NOT DESKTOP_APP_DISABLE_DBUS_INTEGRATION)
- target_link_libraries(Telegram
- PRIVATE
---- tdesktop-3.4.8-full.orig/cmake/options_linux.cmake
-+++ tdesktop-3.4.8-full/cmake/options_linux.cmake
-@@ -65,7 +65,6 @@
-
- target_link_libraries(common_options
- INTERFACE
-- desktop-app::external_jemalloc
- ${CMAKE_DL_LIBS}
- )
-
diff --git a/net-im/telegram-desktop/files/tdesktop-3.6.1-fix-kwayland-5.93.patch b/net-im/telegram-desktop/files/tdesktop-3.6.1-fix-kwayland-5.93.patch
new file mode 100644
index 000000000000..e818ffe46456
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-3.6.1-fix-kwayland-5.93.patch
@@ -0,0 +1,55 @@
+Fix compatibility with kwayland-5.93.0
+
+The header files were moved, the include directory wasn't being added correctly.
+
+https://bugs.gentoo.org/837569
+
+--- tdesktop-3.6.1-full.orig/Telegram/SourceFiles/platform/linux/linux_wayland_integration.cpp
++++ tdesktop-3.6.1-full/Telegram/SourceFiles/platform/linux/linux_wayland_integration.cpp
+@@ -9,10 +9,10 @@
+
+ #include "base/platform/base_platform_info.h"
+
+-#include <connection_thread.h>
+-#include <registry.h>
+-#include <surface.h>
+-#include <plasmashell.h>
++#include <KWayland/Client/connection_thread.h>
++#include <KWayland/Client/registry.h>
++#include <KWayland/Client/surface.h>
++#include <KWayland/Client/plasmashell.h>
+
+ using namespace KWayland::Client;
+
+--- tdesktop-3.6.1-full.orig/Telegram/lib_base/base/platform/linux/base_linux_wayland_integration.cpp
++++ tdesktop-3.6.1-full/Telegram/lib_base/base/platform/linux/base_linux_wayland_integration.cpp
+@@ -13,11 +13,11 @@
+ #include <QtCore/QPointer>
+ #include <QtGui/QWindow>
+
+-#include <connection_thread.h>
+-#include <registry.h>
+-#include <surface.h>
+-#include <xdgforeign.h>
+-#include <idleinhibit.h>
++#include <KWayland/Client/connection_thread.h>
++#include <KWayland/Client/registry.h>
++#include <KWayland/Client/surface.h>
++#include <KWayland/Client/xdgforeign.h>
++#include <KWayland/Client/idleinhibit.h>
+
+ using namespace KWayland::Client;
+
+--- tdesktop-3.6.1-full.orig/Telegram/lib_ui/ui/platform/linux/ui_linux_wayland_integration.cpp
++++ tdesktop-3.6.1-full/Telegram/lib_ui/ui/platform/linux/ui_linux_wayland_integration.cpp
+@@ -24,8 +24,8 @@
+ #include <private/qwaylandwindow_p.h>
+ #include <private/qwaylandshellsurface_p.h>
+
+-#include <connection_thread.h>
+-#include <registry.h>
++#include <KWayland/Client/connection_thread.h>
++#include <KWayland/Client/registry.h>
+
+ Q_DECLARE_METATYPE(QMargins);
+