summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-08-14 10:30:13 +0100
commit616579b5d773c50af31ee56f00105d96ce641ca2 (patch)
tree2ad4d3ba1429bd93a36ab99a2f5ec3490412115e /net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch
parent068424b26532f3551a81421a9be67ed206e5c11a (diff)
gentoo resync : 14.08.2021
Diffstat (limited to 'net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch')
-rw-r--r--net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch b/net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch
new file mode 100644
index 000000000000..f90270fccee3
--- /dev/null
+++ b/net-im/telegram-desktop/files/tdesktop-2.9.3-jemalloc-only-telegram.patch
@@ -0,0 +1,31 @@
+Only link jemalloc for the Telegram binary
+
+Some combination of factors is making the different codegen tools hang when
+jemalloc is linked for those, and they're ran under portage's sandbox. Since
+this is only used during build-time, and jemalloc is merely necessary to
+improve runtime memory use, it's unnecessary to use it for anything else.
+
+--- tdesktop-2.9.3-full.orig/Telegram/CMakeLists.txt
++++ tdesktop-2.9.3-full/Telegram/CMakeLists.txt
+@@ -1264,6 +1264,7 @@
+ PRIVATE
+ desktop-app::external_glibmm
+ desktop-app::external_glib
++ desktop-app::external_jemalloc
+ )
+
+ if (NOT DESKTOP_APP_DISABLE_DBUS_INTEGRATION)
+--- tdesktop-2.9.3-full.orig/cmake/options_linux.cmake
++++ tdesktop-2.9.3-full/cmake/options_linux.cmake
+@@ -45,11 +45,6 @@
+ endif()
+ endif()
+
+-target_link_libraries(common_options
+-INTERFACE
+- desktop-app::external_jemalloc
+-)
+-
+ if (DESKTOP_APP_USE_ALLOCATION_TRACER)
+ target_link_options(common_options
+ INTERFACE