summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop-bin/telegram-desktop-bin-2.2.0.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-09-02 14:09:07 +0100
commitb17a3ef12038de50228bade1f05502c74e135321 (patch)
tree9026dffec53f92cba48ca9a500a4f778e6304380 /net-im/telegram-desktop-bin/telegram-desktop-bin-2.2.0.ebuild
parent3cf7c3ef441822c889356fd1812ebf2944a59851 (diff)
gentoo resync : 02.09.2020
Diffstat (limited to 'net-im/telegram-desktop-bin/telegram-desktop-bin-2.2.0.ebuild')
-rw-r--r--net-im/telegram-desktop-bin/telegram-desktop-bin-2.2.0.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-im/telegram-desktop-bin/telegram-desktop-bin-2.2.0.ebuild b/net-im/telegram-desktop-bin/telegram-desktop-bin-2.2.0.ebuild
new file mode 100644
index 000000000000..1da038a5f934
--- /dev/null
+++ b/net-im/telegram-desktop-bin/telegram-desktop-bin-2.2.0.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit desktop eutils xdg
+
+DESCRIPTION="Official desktop client for Telegram (binary package)"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="
+ https://github.com/telegramdesktop/tdesktop/archive/v${PV}.tar.gz -> tdesktop-${PV}.tar.gz
+ amd64? ( https://updates.tdesktop.com/tlinux/tsetup.${PV}.tar.xz )
+ x86? ( https://updates.tdesktop.com/tlinux32/tsetup32.${PV}.tar.xz )
+"
+
+LICENSE="GPL-3-with-openssl-exception"
+SLOT="0"
+KEYWORDS="-* ~amd64 ~x86"
+
+QA_PREBUILT="usr/lib/${PN}/Telegram"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ >=media-libs/fontconfig-2.13
+ media-libs/freetype:2
+ media-libs/libglvnd[X]
+ >=sys-apps/dbus-1.4.2[X]
+ sys-libs/zlib
+ x11-libs/libSM
+ x11-libs/libdrm
+ x11-libs/libICE
+ x11-libs/libSM
+ x11-libs/libX11
+ >=x11-libs/libxcb-1.10[xkb]
+"
+
+S="${WORKDIR}/Telegram"
+
+src_install() {
+ exeinto /usr/lib/${PN}
+ doexe "Telegram"
+ newbin "${FILESDIR}"/${PN} "telegram-desktop"
+
+ local icon_size
+ for icon_size in 16 32 48 64 128 256 512; do
+ newicon -s "${icon_size}" \
+ "${WORKDIR}/tdesktop-${PV}/Telegram/Resources/art/icon${icon_size}.png" \
+ telegram.png
+ done
+
+ domenu "${WORKDIR}/tdesktop-${PV}"/lib/xdg/telegramdesktop.desktop
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ optfeature "spell checker support" app-text/enchant
+}