summaryrefslogtreecommitdiff
path: root/net-im/telegram-desktop-bin/telegram-desktop-bin-1.2.6.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-01-03 19:17:21 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-01-03 19:17:21 +0000
commit81e4fbcb846ed1cabdad699c0029b166dd7273b7 (patch)
tree16f1236b7a386949c02a6e3c13d0fcd8298fa133 /net-im/telegram-desktop-bin/telegram-desktop-bin-1.2.6.ebuild
parenta70f42c65202d88c203c40910fef8f96f333d1ee (diff)
gentoo resync : 03.01.2018
Diffstat (limited to 'net-im/telegram-desktop-bin/telegram-desktop-bin-1.2.6.ebuild')
-rw-r--r--net-im/telegram-desktop-bin/telegram-desktop-bin-1.2.6.ebuild58
1 files changed, 58 insertions, 0 deletions
diff --git a/net-im/telegram-desktop-bin/telegram-desktop-bin-1.2.6.ebuild b/net-im/telegram-desktop-bin/telegram-desktop-bin-1.2.6.ebuild
new file mode 100644
index 000000000000..2de83b92ec61
--- /dev/null
+++ b/net-im/telegram-desktop-bin/telegram-desktop-bin-1.2.6.ebuild
@@ -0,0 +1,58 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit eutils gnome2-utils xdg
+
+DESCRIPTION="Official desktop client for Telegram (binary package)"
+HOMEPAGE="https://desktop.telegram.org"
+SRC_URI="
+ https://github.com/telegramdesktop/tdesktop/archive/v${PV}.tar.gz -> tdesktop-${PV}.tar.gz
+ amd64? ( https://updates.tdesktop.com/tlinux/tsetup.${PV}.tar.xz )
+ x86? ( https://updates.tdesktop.com/tlinux32/tsetup32.${PV}.tar.xz )
+"
+
+LICENSE="telegram"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+QA_PREBUILT="usr/bin/telegram-desktop"
+
+RDEPEND="
+ dev-libs/glib:2
+ dev-libs/gobject-introspection
+ >=sys-apps/dbus-1.4.20
+ x11-libs/libX11
+ >=x11-libs/libxcb-1.10[xkb]
+"
+DEPEND=""
+
+S="${WORKDIR}/Telegram"
+
+src_install() {
+ newbin "${S}/Telegram" telegram-desktop
+
+ local icon_size
+ for icon_size in 16 32 48 64 128 256 512; do
+ newicon -s "${icon_size}" \
+ "${WORKDIR}/tdesktop-${PV}/Telegram/Resources/art/icon${icon_size}.png" \
+ telegram-desktop.png
+ done
+
+ domenu "${WORKDIR}/tdesktop-${PV}"/lib/xdg/telegramdesktop.desktop
+}
+
+pkg_preinst() {
+ xdg_pkg_preinst
+}
+
+pkg_postinst() {
+ xdg_pkg_postinst
+ gnome2_icon_cache_update
+}
+
+pkg_postrm() {
+ xdg_pkg_postrm
+ gnome2_icon_cache_update
+}