summaryrefslogtreecommitdiff
path: root/net-im/synapse
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-09 15:43:36 +0100
commit2719f73b6813d11d13a9650cdd2ab8ec6e69385d (patch)
tree8c816148bcbd22757d892089c989ae614eae4f5a /net-im/synapse
parent0f558761aa2dee1017b4751e4017205e015a9560 (diff)
gentoo resync : 09.07.2022
Diffstat (limited to 'net-im/synapse')
-rw-r--r--net-im/synapse/Manifest4
-rw-r--r--net-im/synapse/files/synapse.initd10
-rw-r--r--net-im/synapse/metadata.xml15
-rw-r--r--net-im/synapse/synapse-1.62.0.ebuild101
4 files changed, 130 insertions, 0 deletions
diff --git a/net-im/synapse/Manifest b/net-im/synapse/Manifest
new file mode 100644
index 000000000000..a7d37496aa08
--- /dev/null
+++ b/net-im/synapse/Manifest
@@ -0,0 +1,4 @@
+AUX synapse.initd 365 BLAKE2B 064dce5e10596316509f321de9819edab15fc91551e5fc9747c3a2bf28326d9db764046831689cc425ffb7bfedde9607132ebd412ad0ac0becd9d79990c0fc80 SHA512 ec87c250b9d72d3c937ec57fcd6a487c92ef341b3b46ac53fdd7b1371d71ed518c5f94e7ec63e5c859736c73b7762143e113fed9b2dfffbf070e14525b25a840
+DIST synapse-1.62.0.gh.tar.gz 7841903 BLAKE2B f3002798a3fccd1b7fc4a1a302d12dd0940727ce8e89bcab0fdda04d498dbc9e469d21e7815db75b3593fcdfa01557e6828a39e874e946ce1b43d51cfe459ee6 SHA512 2bf9264f08fab29e8707317b69c52a4234bb25443c342ba43a27e06c506bcca1a9bdb211a99802abbca551e4f4288f68775d4629493b39d58dfcc8d8d1ca8ab8
+EBUILD synapse-1.62.0.ebuild 3004 BLAKE2B 159e0a344c64f2768abdf21267088ab22b6b69ad364685244cb200b4580863ac0c8d66c50d230b8633d9d6fbaf45a21723be1500d1c1d8679f4d04138b0e4c82 SHA512 49089f7ecdb33ed7207eaf1a06b1910ee89f49bff05ce5917d514c112b755bea6875c8e8d96ceab757202b295782ccd5ab04f5470cc69809bf467e11dd008617
+MISC metadata.xml 474 BLAKE2B 1e990bd0b3e6234f15e2e036ca6c9157b6bb27c36542e24d5e80a5f2a8dc04a592ee267869869d79bee00177ac8c11ddb630483d802c3d6be49317d41ea41cdb SHA512 6447082bda7509c395fc60bd23fb506d1d61cc0d6b89aca7d68c263270bb7d941f3ea95b18f428c301b0f0cd536688856b85ea264b0facea7cb5d51bd5909c46
diff --git a/net-im/synapse/files/synapse.initd b/net-im/synapse/files/synapse.initd
new file mode 100644
index 000000000000..e8e494c722c0
--- /dev/null
+++ b/net-im/synapse/files/synapse.initd
@@ -0,0 +1,10 @@
+#!/sbin/openrc-run
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+name="Matrix synapse daemon"
+description=""
+command=/usr/bin/synapse_homeserver
+command_args="--daemonize --config-path /etc/synapse/homeserver.yaml"
+pidfile=/var/lib/synapse/homeserver.pid
+start_stop_daemon_args="--user synapse --group synapse"
diff --git a/net-im/synapse/metadata.xml b/net-im/synapse/metadata.xml
new file mode 100644
index 000000000000..8ce7426a7984
--- /dev/null
+++ b/net-im/synapse/metadata.xml
@@ -0,0 +1,15 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "https://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person" proxied="yes">
+ <email>arkamar@atlas.cz</email>
+ <name>Petr Vaněk</name>
+ </maintainer>
+ <maintainer type="project" proxied="proxy">
+ <email>proxy-maint@gentoo.org</email>
+ <name>Proxy Maintainers</name>
+ </maintainer>
+ <upstream>
+ <remote-id type="github">matrix-org/synapse</remote-id>
+ </upstream>
+</pkgmetadata>
diff --git a/net-im/synapse/synapse-1.62.0.ebuild b/net-im/synapse/synapse-1.62.0.ebuild
new file mode 100644
index 000000000000..d3b5db281ed0
--- /dev/null
+++ b/net-im/synapse/synapse-1.62.0.ebuild
@@ -0,0 +1,101 @@
+# Copyright 2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{9..10} )
+DISTUTILS_SINGLE_IMPL=1
+DISTUTILS_USE_PEP517=poetry
+
+inherit distutils-r1 optfeature
+
+DESCRIPTION="Reference implementation of Matrix homeserver"
+HOMEPAGE="
+ https://matrix.org/
+ https://github.com/matrix-org/synapse/
+"
+
+if [[ ${PV} == 9999 ]]; then
+ inherit git-r3
+ EGIT_REPO_URI="https://github.com/matrix-org/${PN}.git"
+else
+ MY_PV="${PV/_rc/rc}"
+ SRC_URI="https://github.com/matrix-org/${PN}/archive/v${MY_PV}.tar.gz -> ${P}.gh.tar.gz"
+ S="${WORKDIR}/${PN}-${MY_PV}"
+ KEYWORDS="~amd64"
+fi
+
+LICENSE="Apache-2.0"
+SLOT="0"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ acct-user/synapse
+ acct-group/synapse
+"
+RDEPEND="${DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/attrs[${PYTHON_USEDEP}]
+ dev-python/bcrypt[${PYTHON_USEDEP}]
+ dev-python/bleach[${PYTHON_USEDEP}]
+ dev-python/canonicaljson[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ dev-python/frozendict[${PYTHON_USEDEP}]
+ dev-python/ijson[${PYTHON_USEDEP}]
+ >=dev-python/jinja-3.0[${PYTHON_USEDEP}]
+ dev-python/jsonschema[${PYTHON_USEDEP}]
+ >=dev-python/matrix-common-1.2.1[${PYTHON_USEDEP}]
+ dev-python/msgpack[${PYTHON_USEDEP}]
+ dev-python/netaddr[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ dev-python/phonenumbers[${PYTHON_USEDEP}]
+ dev-python/pillow[${PYTHON_USEDEP},webp]
+ dev-python/prometheus_client[${PYTHON_USEDEP}]
+ dev-python/pyasn1-modules[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pymacaroons[${PYTHON_USEDEP}]
+ dev-python/pyopenssl[${PYTHON_USEDEP}]
+ dev-python/pyyaml[${PYTHON_USEDEP}]
+ dev-python/service_identity[${PYTHON_USEDEP}]
+ dev-python/signedjson[${PYTHON_USEDEP}]
+ dev-python/sortedcontainers[${PYTHON_USEDEP}]
+ dev-python/treq[${PYTHON_USEDEP}]
+ dev-python/twisted[${PYTHON_USEDEP}]
+ dev-python/typing-extensions[${PYTHON_USEDEP}]
+ dev-python/unpaddedbase64[${PYTHON_USEDEP}]
+ ')
+"
+BDEPEND="
+ test? ( $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_USEDEP}]
+ dev-python/parameterized[${PYTHON_USEDEP}]
+ ') )
+"
+
+python_test() {
+ "${EPYTHON}" -m twisted.trial tests || die "Tests failed with ${EPYTHON}"
+}
+
+python_install() {
+ distutils-r1_python_install
+ keepdir /var/{lib,log}/synapse /etc/synapse
+ fowners synapse:synapse /var/{lib,log}/synapse /etc/synapse
+ fperms 0750 /var/{lib,log}/synapse /etc/synapse
+ newinitd "${FILESDIR}/${PN}.initd" "${PN}"
+}
+
+pkg_postinst() {
+ optfeature "VoIP relaying on your homeserver with turn" net-im/coturn
+
+ einfo "In order to generate initial configuration run:"
+ einfo "sudo -u synapse synapse_homeserver \\"
+ einfo " --server-name matrix.domain.tld \\"
+ einfo " --config-path /etc/synapse/homeserver.yaml \\"
+ einfo " --generate-config \\"
+ einfo " --data-directory /var/lib/synapse \\"
+ einfo " --report-stats=no"
+ einfo
+ einfo "See also upgrade notes:"
+ einfo "https://github.com/matrix-org/synapse/blob/develop/docs/upgrade.md"
+}