summaryrefslogtreecommitdiff
path: root/net-im/spectrum2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /net-im/spectrum2/files
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'net-im/spectrum2/files')
-rw-r--r--net-im/spectrum2/files/spectrum2-2.0.9-remove_debug_cflags.patch13
-rw-r--r--net-im/spectrum2/files/spectrum2-2.0.9-use_qt5_libcommuni.patch54
-rw-r--r--net-im/spectrum2/files/spectrum2.initd47
-rw-r--r--net-im/spectrum2/files/spectrum2.service12
-rw-r--r--net-im/spectrum2/files/spectrum2.tmpfiles1
5 files changed, 127 insertions, 0 deletions
diff --git a/net-im/spectrum2/files/spectrum2-2.0.9-remove_debug_cflags.patch b/net-im/spectrum2/files/spectrum2-2.0.9-remove_debug_cflags.patch
new file mode 100644
index 000000000000..19e3b83d2300
--- /dev/null
+++ b/net-im/spectrum2/files/spectrum2-2.0.9-remove_debug_cflags.patch
@@ -0,0 +1,13 @@
+--- a/CMakeLists.txt 2018-09-17 09:46:40.000000000 +0200
++++ b/CMakeLists.txt 2018-09-20 21:04:29.000000000 +0200
+@@ -384,10 +384,6 @@
+ endif()
+
+ if(CMAKE_BUILD_TYPE MATCHES Debug)
+- if (CMAKE_COMPILER_IS_GNUCXX)
+- ADD_DEFINITIONS(-O0)
+- ADD_DEFINITIONS(-ggdb)
+- endif()
+ ADD_DEFINITIONS(-DDEBUG)
+ message("Debug : yes")
+ else(CMAKE_BUILD_TYPE MATCHES Debug)
diff --git a/net-im/spectrum2/files/spectrum2-2.0.9-use_qt5_libcommuni.patch b/net-im/spectrum2/files/spectrum2-2.0.9-use_qt5_libcommuni.patch
new file mode 100644
index 000000000000..27e23db44848
--- /dev/null
+++ b/net-im/spectrum2/files/spectrum2-2.0.9-use_qt5_libcommuni.patch
@@ -0,0 +1,54 @@
+--- a/CMakeLists.txt 2018-09-17 09:46:40.000000000 +0200
++++ b/CMakeLists.txt 2018-09-20 20:57:35.000000000 +0200
+@@ -182,8 +182,7 @@
+ if(ENABLE_IRC)
+ find_package(Communi)
+
+- INCLUDE(FindQt4)
+- FIND_PACKAGE(Qt4 COMPONENTS QtCore QtNetwork)
++ FIND_PACKAGE(Qt5 COMPONENTS Core Network)
+ # ADD_DEFINITIONS(${SWIFTEN_CFLAGS})
+ ADD_DEFINITIONS(-DSUPPORT_LEGACY_CAPS)
+ # ADD_DEFINITIONS(-DBOOST_FILESYSTEM_VERSION=2)
+@@ -321,7 +320,6 @@
+ message("IRC plugin : yes")
+ include_directories(${QT_QTNETWORK_INCLUDE_DIR})
+ include_directories(${IRC_INCLUDE_DIR})
+- include(${QT_USE_FILE})
+ else()
+ if(ENABLE_IRC)
+ message("IRC plugin : no (install libCommuni and libprotobuf-dev)")
+--- a/backends/libcommuni/CMakeLists.txt 2018-09-17 09:46:40.000000000 +0200
++++ b/backends/libcommuni/CMakeLists.txt 2018-09-20 20:59:31.000000000 +0200
+@@ -1,14 +1,14 @@
+ cmake_minimum_required(VERSION 2.6)
+ FILE(GLOB SRC *.cpp)
+ FILE(GLOB HEADERS *.h)
+-QT4_WRAP_CPP(SRC ${HEADERS} OPTIONS -DBOOST_TT_HAS_OPERATOR_HPP_INCLUDED)
+-add_definitions(-DQT_NO_KEYWORDS)
++QT5_WRAP_CPP(SRC ${HEADERS} OPTIONS -DBOOST_TT_HAS_OPERATOR_HPP_INCLUDED)
+ ADD_EXECUTABLE(spectrum2_libcommuni_backend ${SRC})
++include_directories(${Qt5Core_INCLUDE_DIRS} ${Qt5Network_INCLUDE_DIRS})
+
+ if (NOT WIN32)
+- target_link_libraries(spectrum2_libcommuni_backend ${IRC_LIBRARY} Qt4::QtNetwork Qt4::QtCore transport pthread)
++ target_link_libraries(spectrum2_libcommuni_backend ${IRC_LIBRARY} Qt5::Network Qt5::Core transport pthread)
+ else ()
+- target_link_libraries(spectrum2_libcommuni_backend ${IRC_LIBRARY} Qt4::QtNetwork Qt4::QtCore transport)
++ target_link_libraries(spectrum2_libcommuni_backend ${IRC_LIBRARY} Qt5::Network Qt5::Core transport)
+ endif()
+ INSTALL(TARGETS spectrum2_libcommuni_backend RUNTIME DESTINATION bin)
+
+--- a/cmake_modules/FindCommuni.cmake 2018-09-17 09:46:40.000000000 +0200
++++ b/cmake_modules/FindCommuni.cmake 2018-09-20 21:00:04.000000000 +0200
+@@ -1,8 +1,7 @@
+-find_package(Qt4)
+-include( ${QT_USE_FILE} )
++find_package(Qt5Network)
+
+ FIND_LIBRARY(IRC_LIBRARY NAMES IrcCore PATHS ${QT_LIBRARY_DIR})
+-FIND_PATH(IRC_INCLUDE_DIR NAMES "IrcCore/ircglobal.h" PATHS ${QT_INCLUDE_DIR} PATH_SUFFIXES Communi)
++FIND_PATH(IRC_INCLUDE_DIR NAMES "IrcCore/ircglobal.h" PATHS ${Qt5Core_INCLUDE_DIRS} ${Qt5Core_INCLUDE_DIRS}"/.." PATH_SUFFIXES Communi)
+
+ # message( STATUS ${IRC_LIBRARY})
+ if( IRC_LIBRARY AND IRC_INCLUDE_DIR )
diff --git a/net-im/spectrum2/files/spectrum2.initd b/net-im/spectrum2/files/spectrum2.initd
new file mode 100644
index 000000000000..8a35dbe75bc9
--- /dev/null
+++ b/net-im/spectrum2/files/spectrum2.initd
@@ -0,0 +1,47 @@
+#!/sbin/openrc-run
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+command="/usr/bin/spectrum2_manager"
+command_group="spectrum"
+command_user="spectrum"
+name="Spectrum2 Transport"
+shell="/bin/sh"
+su="/bin/su"
+
+depend() {
+ need net
+}
+
+start() {
+ ebegin "Starting ${name}"
+ "${su}" "${command_user}" -c "${command} start" -s "${shell}"
+ eend $?
+}
+
+start_pre() {
+ # Ensure /run/spectrum2 dir is owned by spectrum user.
+ # spectrum2_manager stores pidfiles of individual services here.
+ # See security related comment at the bottom.
+ checkpath -d -o "${command_user}:${command_group}" -q "/run/spectrum2"
+}
+
+status() {
+ ebegin "Status ${name}"
+ "${su}" "${command_user}" -c "${command} status" -s "${shell}"
+ eend $?
+}
+
+stop() {
+ ebegin "Stopping ${name}"
+ "${su}" "${command_user}" -c "${command} stop" -s "${shell}"
+ eend $?
+}
+
+# Andrey Utkin <andrey_utkin@gentoo.org> (24 Nov 2018)
+# Conrad Kostecki <conrad@kostecki.com> (24 Nov 2018)
+# We are aware of many security issues caused by careless chowning, see
+# http://michael.orlitzky.com/articles/end_root_chowning_now_(make_etc-init.d_great_again).xhtml
+# We believe none of these issues apply.
+# These pidfiles are not read by any privileged process.
+# checkpath here chowns only the dir itself and doesn't act recursively.
diff --git a/net-im/spectrum2/files/spectrum2.service b/net-im/spectrum2/files/spectrum2.service
new file mode 100644
index 000000000000..9d5b72315ef5
--- /dev/null
+++ b/net-im/spectrum2/files/spectrum2.service
@@ -0,0 +1,12 @@
+[Unit]
+Description=Spectrum2 Transport
+After=network.target
+
+[Service]
+ExecStart=/usr/bin/spectrum2_manager start
+ExecStop=/usr/bin/spectrum2_manager stop
+User=spectrum
+Group=spectrum
+
+[Install]
+WantedBy=multi-user.target
diff --git a/net-im/spectrum2/files/spectrum2.tmpfiles b/net-im/spectrum2/files/spectrum2.tmpfiles
new file mode 100644
index 000000000000..4ce6f1c3ca75
--- /dev/null
+++ b/net-im/spectrum2/files/spectrum2.tmpfiles
@@ -0,0 +1 @@
+d /run/spectrum2 0700 specturm spectrum - -