summaryrefslogtreecommitdiff
path: root/net-im/spectrum2/files
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
committerV3n3RiX <venerix@koprulu.sector>2021-12-05 02:47:11 +0000
commit2771f79232c273bc2a57d23bf335dd81ccf6af28 (patch)
treec8af0fd04194aed03cf067d44e53c7edd3e9ab84 /net-im/spectrum2/files
parente9d044d4b9b71200a96adfa280848858c0f468c9 (diff)
gentoo resync : 05.12.2021
Diffstat (limited to 'net-im/spectrum2/files')
-rw-r--r--net-im/spectrum2/files/spectrum2-2.0.13-libpqxx-7-compatibility.patch79
-rw-r--r--net-im/spectrum2/files/spectrum2-2.0.13-musl-compatibility.patch95
2 files changed, 0 insertions, 174 deletions
diff --git a/net-im/spectrum2/files/spectrum2-2.0.13-libpqxx-7-compatibility.patch b/net-im/spectrum2/files/spectrum2-2.0.13-libpqxx-7-compatibility.patch
deleted file mode 100644
index 48a1f0a333a0..000000000000
--- a/net-im/spectrum2/files/spectrum2-2.0.13-libpqxx-7-compatibility.patch
+++ /dev/null
@@ -1,79 +0,0 @@
-diff --git a/cmake_modules/Findpqxx.cmake b/cmake_modules/Findpqxx.cmake
-index 9c53550..691ec0e 100644
---- a/cmake_modules/Findpqxx.cmake
-+++ b/cmake_modules/Findpqxx.cmake
-@@ -1,16 +1,33 @@
--FIND_PATH(PQXX_INCLUDE_DIR pqxx/pqxx PATHS)
--MARK_AS_ADVANCED(PQXX_INCLUDE_DIR)
-+if (NOT WIN32)
-+ find_package(PkgConfig)
-+ if (PKG_CONFIG_FOUND)
-+ pkg_check_modules(PQXX libpqxx)
-+ if (PQXX_FOUND)
-+ if (PQXX_VERSION STRGREATER "7")
-+ message(STATUS "libpqxx version ${PQXX_VERSION}, requesting c++17")
-+ set (CMAKE_CXX_STANDARD 17)
-+ endif()
-+ endif()
-+ endif()
-+else()
-
--FIND_LIBRARY(PQXX_LIBRARY pqxx )
--MARK_AS_ADVANCED(PQXX_LIBRARY)
-+ FIND_PATH(PQXX_INCLUDE_DIR pqxx/pqxx PATHS)
-+ MARK_AS_ADVANCED(PQXX_INCLUDE_DIR)
-
--FIND_LIBRARY(PQ_LIBRARY pq )
--MARK_AS_ADVANCED(PQ_LIBRARY)
-+ FIND_LIBRARY(PQXX_LIBRARIES pqxx )
-+ MARK_AS_ADVANCED(PQXX_LIBRARIES)
-
--if(PQXX_LIBRARY AND PQ_LIBRARY AND PQXX_INCLUDE_DIR)
-- set( PQXX_FOUND 1 )
-- message( STATUS "Found pqxx: ${PQXX_LIBRARY}, ${PQ_LIBRARY}, ${PQXX_INCLUDE_DIR}")
--else()
-- message(STATUS "Could NOT find pqxx and pq library")
--endif()
-+ FIND_LIBRARY(PQ_LIBRARY pq )
-+ MARK_AS_ADVANCED(PQ_LIBRARY)
-
-+ if(PQXX_LIBRARY AND PQ_LIBRARY AND PQXX_INCLUDE_DIR)
-+ set( PQXX_FOUND 1 )
-+ message( STATUS "Found pqxx: ${PQXX_LIBRARIES}, ${PQ_LIBRARY}, ${PQXX_INCLUDE_DIR}")
-+ if (PQXX_VERSION STRGREATER "7")
-+ message(STATUS "libpqxx version ${PQXX_VERSION}, requesting c++17")
-+ set (CMAKE_CXX_STANDARD 17)
-+ endif()
-+ else()
-+ message(STATUS "Could NOT find pqxx and pq library")
-+ endif()
-+endif()
-diff --git a/libtransport/CMakeLists.txt b/libtransport/CMakeLists.txt
-index 8892241..2b5a0f9 100644
---- a/libtransport/CMakeLists.txt
-+++ b/libtransport/CMakeLists.txt
-@@ -48,9 +48,9 @@ find_package(CURL)
-
- if(WIN32)
- include_directories("${CMAKE_SOURCE_DIR}/msvc-deps/sqlite3")
-- target_link_libraries(transport transport-plugin ${PQXX_LIBRARY} ${CURL_LIBRARIES} ${PQ_LIBRARY} ${MYSQL_LIBRARIES} ${SWIFTEN_LIBRARY} ${LOG4CXX_LIBRARIES} ${PROTOBUF_LIBRARY} ${JSONCPP_LIBRARY} psapi.lib bcrypt.lib)
-+ target_link_libraries(transport transport-plugin ${PQXX_LIBRARIES} ${CURL_LIBRARIES} ${PQ_LIBRARY} ${MYSQL_LIBRARIES} ${SWIFTEN_LIBRARY} ${LOG4CXX_LIBRARIES} ${PROTOBUF_LIBRARY} ${JSONCPP_LIBRARY} psapi.lib bcrypt.lib)
- else()
-- target_link_libraries(transport transport-plugin ${PQXX_LIBRARY} ${CURL_LIBRARIES} ${PQ_LIBRARY} ${SQLITE3_LIBRARIES} ${MYSQL_LIBRARIES} ${SWIFTEN_LIBRARY} ${LOG4CXX_LIBRARIES} ${POPT_LIBRARY} ${PROTOBUF_LIBRARY} ${JSONCPP_LIBRARY})
-+ target_link_libraries(transport transport-plugin ${PQXX_LIBRARIES} ${CURL_LIBRARIES} ${PQ_LIBRARY} ${SQLITE3_LIBRARIES} ${MYSQL_LIBRARIES} ${SWIFTEN_LIBRARY} ${LOG4CXX_LIBRARIES} ${POPT_LIBRARY} ${PROTOBUF_LIBRARY} ${JSONCPP_LIBRARY})
- endif()
-
- set_target_properties(transport PROPERTIES
-diff --git a/libtransport/NetworkPluginServer.cpp b/libtransport/NetworkPluginServer.cpp
-index 31cce95..f5305aa 100644
---- a/libtransport/NetworkPluginServer.cpp
-+++ b/libtransport/NetworkPluginServer.cpp
-@@ -1904,7 +1904,7 @@ NetworkPluginServer::wrapIncomingMedia(SWIFTEN_SHRPTR_NAMESPACE::shared_ptr<Swif
- //Doesn't handle: unquoted src, escaped "'>s, quotes in quotes ("quote: 'text' end quote")
- static boost::regex image_expr("<img\\s+[^>]*src\\s*=\\s*[\"']([^\"']+)[\"'][^>]*>");
-
-- bool matchCount = 0;
-+ int matchCount = 0;
- std::string firstUrl;
-
- std::string::const_iterator xhtml_pos = xhtml.begin();
diff --git a/net-im/spectrum2/files/spectrum2-2.0.13-musl-compatibility.patch b/net-im/spectrum2/files/spectrum2-2.0.13-musl-compatibility.patch
deleted file mode 100644
index 07bde50b832d..000000000000
--- a/net-im/spectrum2/files/spectrum2-2.0.13-musl-compatibility.patch
+++ /dev/null
@@ -1,95 +0,0 @@
-From 19b10896fa3426b2bd9e4e75a63ca52322373d33 Mon Sep 17 00:00:00 2001
-From: Vitaly Takmazov <vitalyster@gmail.com>
-Date: Fri, 24 Jul 2020 15:09:28 +0300
-Subject: [PATCH] musl compatibility
-
----
- backends/libpurple/main.cpp | 6 +++---
- backends/swiften/main.cpp | 2 ++
- libtransport/UserManager.cpp | 2 ++
- spectrum/src/main.cpp | 2 ++
- 4 files changed, 9 insertions(+), 3 deletions(-)
-
-diff --git a/backends/libpurple/main.cpp b/backends/libpurple/main.cpp
-index 54c618e0..4555edbc 100644
---- a/backends/libpurple/main.cpp
-+++ b/backends/libpurple/main.cpp
-@@ -528,7 +528,7 @@ class SpectrumNetworkPlugin : public NetworkPlugin {
-
- purple_accounts_delete_wrapped(account);
- #ifndef WIN32
--#if !defined(__FreeBSD__) && !defined(__APPLE__)
-+#if !defined(__FreeBSD__) && !defined(__APPLE__) && defined (__GLIBC__)
- malloc_trim(0);
- #endif
- #endif
-@@ -2287,7 +2287,7 @@ static void signed_on(PurpleConnection *gc, gpointer unused) {
- PurpleAccount *account = purple_connection_get_account_wrapped(gc);
- np->handleConnected(np->m_accounts[account]);
- #ifndef WIN32
--#if !defined(__FreeBSD__) && !defined(__APPLE__)
-+#if !defined(__FreeBSD__) && !defined(__APPLE__) && defined (__GLIBC__)
- // force returning of memory chunks allocated by libxml2 to kernel
- malloc_trim(0);
- #endif
-@@ -2516,7 +2516,7 @@ int main(int argc, char **argv) {
- boost::locale::generator gen;
- std::locale::global(gen(""));
- #ifndef WIN32
--#if !defined(__FreeBSD__) && !defined(__APPLE__)
-+#if !defined(__FreeBSD__) && !defined(__APPLE__) && defined (__GLIBC__)
- mallopt(M_CHECK_ACTION, 2);
- mallopt(M_PERTURB, 0xb);
- #endif
-diff --git a/backends/swiften/main.cpp b/backends/swiften/main.cpp
-index f0acdb6d..6c111464 100644
---- a/backends/swiften/main.cpp
-+++ b/backends/swiften/main.cpp
-@@ -227,10 +227,12 @@ class SwiftenPlugin : public NetworkPlugin, Swift::XMPPParserClient {
- #ifndef WIN32
- #ifndef __FreeBSD__
- #ifndef __MACH__
-+#if defined (__GLIBC__)
- // force returning of memory chunks allocated by libxml2 to kernel
- malloc_trim(0);
- #endif
- #endif
-+#endif
- #endif
- }
-
-diff --git a/libtransport/UserManager.cpp b/libtransport/UserManager.cpp
-index 73fcdae9..a622754f 100644
---- a/libtransport/UserManager.cpp
-+++ b/libtransport/UserManager.cpp
-@@ -125,10 +125,12 @@ void UserManager::removeUser(User *user, bool onUserBehalf) {
- #ifndef WIN32
- #ifndef __FreeBSD__
- #ifndef __MACH__
-+#if defined (__GLIBC__)
- malloc_trim(0);
- #endif
- #endif
- #endif
-+#endif
- // VALGRIND_DO_LEAK_CHECK;
- }
-
-diff --git a/spectrum/src/main.cpp b/spectrum/src/main.cpp
-index 0f5985a2..89e5b9a1 100644
---- a/spectrum/src/main.cpp
-+++ b/spectrum/src/main.cpp
-@@ -320,11 +320,13 @@ int main(int argc, char **argv)
- #ifndef WIN32
- #ifndef __FreeBSD__
- #ifndef __MACH__
-+#if defined (__GLIBC__)
- mallopt(M_CHECK_ACTION, 2);
- mallopt(M_PERTURB, 0xb);
- #endif
- #endif
- #endif
-+#endif
-
- #ifndef WIN32
- if (signal(SIGINT, spectrum_sigint_handler) == SIG_ERR) {