summaryrefslogtreecommitdiff
path: root/net-im/skypeforlinux
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-02-13 21:41:11 +0000
commitc8d60dada2ec8eb48b2d2b290cd6683ccec40e39 (patch)
treec44943ee0563a3fa957716de909fed683117fcb9 /net-im/skypeforlinux
parent69051588e2f955485fe5d45d45e616bc60a2de57 (diff)
gentoo (valentine's day) resync : 14.02.2021
Diffstat (limited to 'net-im/skypeforlinux')
-rw-r--r--net-im/skypeforlinux/Manifest2
-rw-r--r--net-im/skypeforlinux/skypeforlinux-8.68.0.100.ebuild98
2 files changed, 100 insertions, 0 deletions
diff --git a/net-im/skypeforlinux/Manifest b/net-im/skypeforlinux/Manifest
index 6baa47655ede..43856b29cbe4 100644
--- a/net-im/skypeforlinux/Manifest
+++ b/net-im/skypeforlinux/Manifest
@@ -1,3 +1,5 @@
DIST skypeforlinux_8.67.0.96-1.x86_64.rpm 113616838 BLAKE2B aecf6d8f24836d2d6ef23b80b79796cbe5e309af862eac5e8caa0436e6cc8f10de5fd6337901c70a4b5b5c6cc3d7d15f6b0225b86187db800c8374762adf0313 SHA512 8d1c35026bbe90a2492f3ac88cc8fb2f098258050cf263121a06b9c9e048bda18774582d669d9a9177d8cfcaaa66a615b206587e74b371ef80b089dfecbb9a2e
+DIST skypeforlinux_8.68.0.100-1.x86_64.rpm 113061038 BLAKE2B f8d04c1d1727e6e90527d3ca820f411f6358b152f15960f1673d07da9e20cd784c230084a539bc3cf6d96b025c6a34bedc814dc9af94826d51746f13e6a56a64 SHA512 457f2ff3a904776b3b03ea06004e81576d1394aa5adae80bd3fb6c46e319188c5733d7da820b5eead987e5530caba9c75090ce7ca8f108ad19786b76affd3cb8
EBUILD skypeforlinux-8.67.0.96.ebuild 3117 BLAKE2B 48471cba3133ede445212d7bf290e0abb92d825a7057988242b9f8e23b9a1488c5f3098d9b6af60b5d7deb5d89084ff0bf09d6b2469ae6b2b83199cc398c2f63 SHA512 052d8e790e22a9e5117c35c1992a32f3dd2a58dab77185a3807d0222e2cef0f357ae75e9c48ed74834e489edba551327f2465954e5424bdb3020bbc14574c2b0
+EBUILD skypeforlinux-8.68.0.100.ebuild 3117 BLAKE2B f86fd9f5d06faf193363c05a558970bee5204162d426491f2a1ef3690fc5267f7c9d91e0bca1124af40e3c3b84c33da9333847077b00b4a7a9066942c22572b2 SHA512 fba2e33a98ad2f56d6997a814918709f3215793eadb1a7b2d37398d738ab4684e3434724db17ba0ee139b174038436abe15d14c5273f82d5e6e1155b758d132c
MISC metadata.xml 460 BLAKE2B 136f61594a68e6efed725d448cd9fcd0e0c72f884cd64ef5f8c3adbc39fd4322a4ed8ef692fa500bb00488e616520efdec943be7c4d0381345247776a8258d42 SHA512 d82b35cfa2dc12b2629f7084f071d3d3cd83e2d6246cb4c2544883f28becde6677a1739f7c028e69352267561441419d135774daa1177a803d485d38880191a8
diff --git a/net-im/skypeforlinux/skypeforlinux-8.68.0.100.ebuild b/net-im/skypeforlinux/skypeforlinux-8.68.0.100.ebuild
new file mode 100644
index 000000000000..01550d2ccb08
--- /dev/null
+++ b/net-im/skypeforlinux/skypeforlinux-8.68.0.100.ebuild
@@ -0,0 +1,98 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+MULTILIB_COMPAT=( abi_x86_64 )
+
+inherit chromium-2 desktop pax-utils rpm multilib-build xdg
+
+DESCRIPTION="Instant messaging client, with support for audio and video"
+HOMEPAGE="https://www.skype.com/"
+SRC_URI="https://repo.skype.com/rpm/stable/${PN}_${PV}-1.x86_64.rpm"
+
+LICENSE="Skype-TOS MIT MIT-with-advertising BSD-1 BSD-2 BSD Apache-2.0 Boost-1.0 ISC CC-BY-SA-3.0 CC0-1.0 openssl ZLIB APSL-2 icu Artistic-2 LGPL-2.1"
+SLOT="0"
+KEYWORDS="-* ~amd64"
+
+S="${WORKDIR}"
+QA_PREBUILT="*"
+RESTRICT="mirror bindist strip" #299368
+
+RDEPEND="
+ app-crypt/libsecret[${MULTILIB_USEDEP}]
+ dev-libs/atk[${MULTILIB_USEDEP}]
+ dev-libs/expat[${MULTILIB_USEDEP}]
+ dev-libs/glib:2[${MULTILIB_USEDEP}]
+ dev-libs/nspr[${MULTILIB_USEDEP}]
+ dev-libs/nss[${MULTILIB_USEDEP}]
+ media-libs/alsa-lib[${MULTILIB_USEDEP}]
+ media-libs/fontconfig:1.0[${MULTILIB_USEDEP}]
+ media-libs/freetype:2[${MULTILIB_USEDEP}]
+ media-libs/libv4l[${MULTILIB_USEDEP}]
+ net-print/cups[${MULTILIB_USEDEP}]
+ sys-apps/dbus[${MULTILIB_USEDEP}]
+ sys-devel/gcc[cxx]
+ virtual/ttf-fonts
+ x11-libs/cairo[${MULTILIB_USEDEP}]
+ x11-libs/gdk-pixbuf:2[${MULTILIB_USEDEP}]
+ x11-libs/gtk+:3[${MULTILIB_USEDEP}]
+ x11-libs/libX11[${MULTILIB_USEDEP}]
+ x11-libs/libXScrnSaver[${MULTILIB_USEDEP}]
+ x11-libs/libXcomposite[${MULTILIB_USEDEP}]
+ x11-libs/libXcursor[${MULTILIB_USEDEP}]
+ x11-libs/libXdamage[${MULTILIB_USEDEP}]
+ x11-libs/libXext[${MULTILIB_USEDEP}]
+ x11-libs/libXfixes[${MULTILIB_USEDEP}]
+ x11-libs/libXi[${MULTILIB_USEDEP}]
+ x11-libs/libXrandr[${MULTILIB_USEDEP}]
+ x11-libs/libXrender[${MULTILIB_USEDEP}]
+ x11-libs/libXtst[${MULTILIB_USEDEP}]
+ x11-libs/libxcb[${MULTILIB_USEDEP}]
+ x11-libs/libxkbfile[${MULTILIB_USEDEP}]
+ x11-libs/pango[${MULTILIB_USEDEP}]"
+
+pkg_setup() {
+ chromium_suid_sandbox_check_kernel_config
+}
+
+src_unpack() {
+ rpm_src_unpack ${A}
+}
+
+src_prepare() {
+ default
+ sed -e "s!^SKYPE_PATH=.*!SKYPE_PATH=${EPREFIX}/opt/skypeforlinux/skypeforlinux!" \
+ -i usr/bin/skypeforlinux || die
+ sed -e "s!^Categories=.*!Categories=Network;InstantMessaging;Telephony;!" \
+ -e "/^OnlyShowIn=/d" \
+ -i usr/share/applications/skypeforlinux.desktop || die
+}
+
+src_install() {
+ dodir /opt
+ cp -a usr/share/skypeforlinux "${ED}"/opt || die
+
+ # remove chrome-sandbox binary, users should use kernel namespaces
+ # https://bugs.gentoo.org/692692#c18
+ rm "${ED}"/opt/skypeforlinux/chrome-sandbox || die
+
+ dobin usr/bin/skypeforlinux
+
+ dodoc usr/share/skypeforlinux/*.html
+ dodoc -r usr/share/doc/skypeforlinux/.
+ # symlink required for the "Help->3rd Party Notes" menu entry (otherwise frozen skype -> xdg-open)
+ dosym ${PF} usr/share/doc/skypeforlinux
+
+ doicon usr/share/pixmaps/skypeforlinux.png
+
+ local res
+ for res in 16 32 256 512; do
+ newicon -s ${res} usr/share/icons/hicolor/${res}x${res}/apps/skypeforlinux.png skypeforlinux.png
+ done
+
+ domenu usr/share/applications/skypeforlinux.desktop
+
+ pax-mark -m "${ED}"/opt/skypeforlinux/skypeforlinux
+ pax-mark -m "${ED}"/opt/skypeforlinux/resources/app.asar.unpacked/node_modules/slimcore/bin/slimcore.node
+}