summaryrefslogtreecommitdiff
path: root/net-im/qtox/qtox-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-im/qtox/qtox-9999.ebuild
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-im/qtox/qtox-9999.ebuild')
-rw-r--r--net-im/qtox/qtox-9999.ebuild30
1 files changed, 13 insertions, 17 deletions
diff --git a/net-im/qtox/qtox-9999.ebuild b/net-im/qtox/qtox-9999.ebuild
index c635dfc405d4..3ad3165b1bc9 100644
--- a/net-im/qtox/qtox-9999.ebuild
+++ b/net-im/qtox/qtox-9999.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
EAPI=6
@@ -13,11 +13,11 @@ EGIT_REPO_URI="https://github.com/qTox/qTox.git"
LICENSE="GPL-3+"
SLOT="0"
KEYWORDS=""
-IUSE="gtk test X"
+IUSE="notification test X"
RDEPEND="
dev-db/sqlcipher
- dev-libs/libsodium
+ dev-libs/libsodium:=
dev-qt/qtconcurrent:5
dev-qt/qtcore:5
dev-qt/qtgui:5[gif,jpeg,png,xcb]
@@ -27,17 +27,11 @@ RDEPEND="
dev-qt/qtsvg:5
dev-qt/qtwidgets:5
dev-qt/qtxml:5
- media-gfx/qrencode
- media-libs/libexif
+ media-gfx/qrencode:=
media-libs/openal
- >=media-video/ffmpeg-2.6.3[webp,v4l]
- gtk? ( dev-libs/atk
- dev-libs/glib:2
- x11-libs/gdk-pixbuf[X]
- x11-libs/gtk+:2
- x11-libs/cairo[X]
- x11-libs/pango[X] )
- net-libs/tox:0/0.1[av]
+ >=media-video/ffmpeg-2.6.3:=[webp,v4l]
+ net-libs/tox:0/0.2[av]
+ notification? ( x11-libs/gtk+:2 )
X? ( x11-libs/libX11
x11-libs/libXScrnSaver )
"
@@ -52,15 +46,17 @@ src_prepare() {
# bug 628574
if ! use test; then
- sed -i CMakeLists.txt -e "/include(Testing)/s/^/#/" || die
- sed -i cmake/Dependencies.cmake -e "/find_package(Qt5Test/s/^/#/" || die
+ sed -i CMakeLists.txt -e "/include(Testing)/d" || die
+ sed -i cmake/Dependencies.cmake -e "/find_package(Qt5Test/d" || die
fi
}
src_configure() {
local mycmakeargs=(
- -DENABLE_STATUSNOTIFIER=$(usex gtk)
- -DENABLE_GTK_SYSTRAY=$(usex gtk)
+ -DENABLE_STATUSNOTIFIER=$(usex notification)
+ -DENABLE_GTK_SYSTRAY=$(usex notification)
+ -DPLATFORM_EXTENSIONS=$(usex X)
+ -DUSE_FILTERAUDIO=OFF
)
cmake-utils_src_configure