summaryrefslogtreecommitdiff
path: root/net-im/prosody
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2025-01-01 06:30:58 +0000
committerV3n3RiX <venerix@koprulu.sector>2025-01-01 06:30:58 +0000
commitc4d4d544a37efc45bd5482e62e1fcdbe7d5993d3 (patch)
treee97ec8b6356535412a838039bf7874aef3129f50 /net-im/prosody
parent2e36bcecf24a3f583ae8f27b71ba13b3cfd39778 (diff)
gentoo auto-resync : 01:01:2025 - 06:30:57
Diffstat (limited to 'net-im/prosody')
-rw-r--r--net-im/prosody/Manifest2
-rw-r--r--net-im/prosody/prosody-0.12.5.ebuild164
2 files changed, 166 insertions, 0 deletions
diff --git a/net-im/prosody/Manifest b/net-im/prosody/Manifest
index faa112979057..0d93e95602c5 100644
--- a/net-im/prosody/Manifest
+++ b/net-im/prosody/Manifest
@@ -3,5 +3,7 @@ AUX prosody.initd-r6 1114 BLAKE2B a988b584eb49d21261776fa0a651dc01d3943a5a75c9bf
AUX prosody.service-r3 439 BLAKE2B abd128f236f2c28f54542388a38aaa3d0e5030510dddc16240273de90c13ddee62d01d26d7c9e1be0635dc59ad9ca5e93a30f2b5fa42106489a95d26a037314a SHA512 b540e5d4389439cdd2886f9ccaf189d20ffcaf29a982a26e4ed296b0c529df95aade88751d22919cb36b27db94530dade754044d50cee2e5244d37983b933517
AUX prosody.tmpfilesd-r2 39 BLAKE2B 1e004bf2bf1495d219c12bea1973206fae135fb4a5b453c6692f0143413626ec83889bb84b5086a6e507d3b8af14877b3820f3d9560df17e1ca49e2cbee85e0b SHA512 81b855c6bf496f0e6f20c41b8be5538c4edd1fbc6e4f2ca6e9a2d0a06bd5237223a4d42bcbdb75746cb01e46ff0eb36dac6952d9c076c6a72d1bbd733aca07eb
DIST prosody-0.12.4.tar.gz 616043 BLAKE2B 6bbe779424a6de6b5d266c3f6301282e010b96c9baca79d8dff46ab91365e6c5fdaa1b52c3caaaf33dad0990fa2c298f0447d37fcc018067f6efcc23d633b4fc SHA512 e035ec9af3831c596ababbc0320f352b7253d3ee968c9937998ffc255839173c9278912a0897fa9f0a0665bc43603f8570b5e15dfd1cba4571599e86a98d8cf4
+DIST prosody-0.12.5.tar.gz 617833 BLAKE2B 71f8681e9a976919281be2afe47aa59e8ebd3b7a6e947e85757e18db3110749fa64ae75e3db2a5e55b2116cb213f0caa404fecade2d817623d36ae497f6ed1f6 SHA512 05b15204849ec285c465784ae43e3b748c4a3cda434b53f700121b518af59e14faea22af4b6bbc0d45f3633ddcaf762f00072fd713744a60d2e9ea8b3b10a7ed
EBUILD prosody-0.12.4.ebuild 5129 BLAKE2B 8a754c72fc2e94af39ca165d78f7e7761129304a6d5eacd947a6586399e9394cfed51128df79a956a9b6566bc603554d1a2b4306c7d2db9b19ac22654bc4e13f SHA512 f49c9737f09b1ecd254aad907d467903ae4a70879a528bfd883b5f0c975d50843ea7f77b31929b6301f0c8c8ed1fcbb25da5e1b193277432a8e0f8ffed74cbc3
+EBUILD prosody-0.12.5.ebuild 5131 BLAKE2B 03c16ecbee8a5ff3129aeed2df180bca2e45294713bd178d130ce049657c808e3c804192c2e5a00ef669323a3f571f6efd017e6c2ba9e001c50c2b1e9368df5f SHA512 88431672e581fa184727d39a41c6a5fbf53b0fc5f5eddcd4c8fd7cee56e760e89c6145b4291e6f7e27cffd66919b0e2e8cb4b11dbf4d959b290caa3f6b5663c0
MISC metadata.xml 670 BLAKE2B 448bf5ede2b6f09940c51fdff4642e18be22d9c3dac637271c7c8bcfde1b4af0853e2623c55c00efcd8757ef863ac37fdb895606e572911a62a1c9d5f32cc693 SHA512 6177b8e3d2ed1aeeae2f369dc693283a3f811953f71be0e004eea402aa421d89973dbefe79c8fd198e9f9f82e4b345552dc3a2c3597c05927dc1a518cacbaf1d
diff --git a/net-im/prosody/prosody-0.12.5.ebuild b/net-im/prosody/prosody-0.12.5.ebuild
new file mode 100644
index 000000000000..e966218f3101
--- /dev/null
+++ b/net-im/prosody/prosody-0.12.5.ebuild
@@ -0,0 +1,164 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+LUA_REQ_USE="deprecated(+)"
+
+inherit lua-single systemd tmpfiles toolchain-funcs
+
+DESCRIPTION="Prosody is a modern XMPP communication server"
+HOMEPAGE="https://prosody.im/"
+SRC_URI="https://prosody.im/downloads/source/${P}.tar.gz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86"
+IUSE="icu +idn +libevent ldap mysql postgres selinux +sqlite +ssl test +zlib"
+REQUIRED_USE="
+ ^^ ( icu idn )
+ ${LUA_REQUIRED_USE}
+"
+RESTRICT="!test? ( test )"
+
+DEPEND="
+ acct-group/prosody
+ acct-user/prosody
+ $(lua_gen_cond_dep 'dev-lua/luaexpat[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/luafilesystem[${LUA_USEDEP}]')
+ dev-lua/luarocks[${LUA_SINGLE_USEDEP}]
+ $(lua_gen_cond_dep 'dev-lua/luasocket[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/lua-unbound[${LUA_USEDEP}]')
+ $(lua_gen_cond_dep 'dev-lua/readline[${LUA_USEDEP}]')
+ icu? ( dev-libs/icu:= )
+ idn? ( net-dns/libidn:= )
+ ldap? ( $(lua_gen_cond_dep 'dev-lua/lualdap[${LUA_USEDEP}]') )
+ libevent? ( $(lua_gen_cond_dep 'dev-lua/luaevent[${LUA_USEDEP}]') )
+ dev-libs/openssl:0=
+ lua_single_target_lua5-1? ( $(lua_gen_cond_dep 'dev-lua/lua-bit32[lua_targets_lua5-1(-)]') )
+ mysql? ( $(lua_gen_cond_dep 'dev-lua/luadbi[mysql,${LUA_USEDEP}]') )
+ postgres? ( $(lua_gen_cond_dep 'dev-lua/luadbi[postgres,${LUA_USEDEP}]') )
+ sqlite? ( $(lua_gen_cond_dep 'dev-lua/luadbi[sqlite,${LUA_USEDEP}]') )
+ ssl? ( $(lua_gen_cond_dep 'dev-lua/luasec[${LUA_USEDEP}]') )
+ zlib? ( $(lua_gen_cond_dep 'dev-lua/lua-zlib[${LUA_USEDEP}]') )
+ ${LUA_DEPS}
+"
+
+RDEPEND="
+ ${DEPEND}
+ selinux? ( sec-policy/selinux-jabber )
+"
+
+BDEPEND="
+ virtual/pkgconfig
+ test? ( $(lua_gen_cond_dep 'dev-lua/busted[${LUA_USEDEP}]') )
+"
+
+PATCHES=( "${FILESDIR}/${PN}-0.12.0-gentoo.patch" )
+
+src_prepare() {
+ default
+
+ # Set correct plugin path for optional net-im/prosody-modules package
+ sed -e "s/GENTOO_LIBDIR/$(get_libdir)/g" -i prosody.cfg.lua.dist || die
+}
+
+src_configure() {
+ local myeconfargs=(
+ --add-cflags="${CFLAGS}"
+ --add-ldflags="${LDFLAGS}"
+ --c-compiler="$(tc-getCC)"
+ --datadir="${EPREFIX}/var/lib/prosody"
+ --idn-library="$(usex idn 'idn' 'icu')"
+ --libdir="${EPREFIX}/usr/$(get_libdir)"
+ --linker="$(tc-getCC)"
+ --lua-version="$(usex lua_single_target_luajit '5.1' $(ver_cut 1-2 $(lua_get_version)))"
+ --no-example-certs
+ --ostype="linux"
+ --prefix="${EPREFIX}/usr"
+ --runwith="${ELUA}"
+ --sysconfdir="${EPREFIX}/etc/prosody"
+ --with-lua-include="${EPREFIX}/$(lua_get_include_dir)"
+ --with-lua-lib="${EPREFIX}/$(lua_get_cmod_dir)"
+ )
+
+ # Since the configure script is handcrafted,
+ # and yells at unknown options, do not use 'econf'.
+ ./configure "${myeconfargs[@]}" || die
+
+ rm makefile || die
+ mv GNUmakefile Makefile || die
+}
+
+src_install() {
+ default
+
+ keepdir /var/lib/prosody
+
+ newinitd "${FILESDIR}"/prosody.initd-r6 prosody
+ systemd_newunit "${FILESDIR}"/prosody.service-r3 prosody.service
+
+ newtmpfiles "${FILESDIR}"/prosody.tmpfilesd-r2 prosody.conf
+}
+
+pkg_postinst() {
+ local migrate_to_prosody_user="false"
+ tmpfiles_process prosody.conf
+
+ if [[ ${REPLACING_VERSIONS} ]]; then
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 0.12.0; then
+ migrate_to_prosody_user="true"
+ break
+ fi
+ done
+ fi
+
+ # Sarting with >=0.12.0, the prosody configuration is now in
+ # /etc/prosody and no longer in /etc/jabber.
+ # See if we need to migrate the configuration. Furthermore,
+ # prosody no longer runs under the, shared via net-im/jabber-base,
+ # 'jabber' use, but under its own user.
+ # This increase isolation and hence robustness and security.
+ if ${migrate_to_prosody_user}; then
+ local -A dirs_to_migrate=(
+ [/etc/jabber]=/etc/prosody
+ [/var/log/jabber]=/var/log/prosody
+ [/var/spool/jabber]=/var/lib/prosody
+ )
+
+ for src_dir in "${!dirs_to_migrate[@]}"; do
+ local eroot_src_dir="${EROOT}/${src_dir}"
+ local eroot_dst_dir="${EROOT}/${dirs_to_migrate[${src_dir}]}"
+
+ cp -r "${eroot_src_dir}"/. "${eroot_dst_dir}" || die "Could not copy ${eroot_src_dir} to ${eroot_dst_dir}"
+
+ if [[ -f "${eroot_dst_dir}"/.keep_net-im_jabber-base-0 ]]; then
+ rm "${eroot_dst_dir}"/.keep_net-im_jabber-base-0 || die
+ fi
+
+ if ! use prefix; then
+ chown --recursive prosody:prosody "${eroot_dst_dir}" || die
+ fi
+ done
+
+ # Update configuration file to match new pathes and permissions
+ local mysedargs=(
+ -e "'s#/etc/jabber#/etc/prosody#g'"
+ -e "'s#/run/jabber#/run/prosody#g'"
+ -e "'s#/var/log/jabber#/var/log/prosody#g'"
+ -e "'s/prosody_user.*/prosody_user = \"prosody\";/g'"
+ -e "'s/prosody_group.*/prosody_group = \"prosody\";/g'"
+ -i /etc/prosody/prosody.cfg.lua
+ )
+
+ eval sed "${mysedargs[@]}" || die
+
+ ewarn "Newer versions of the prosody (Gentoo) package use ${EROOT}/etc/prosody"
+ ewarn "(just as upstream) and *not* anymore ${EROOT}/etc/jabber."
+ ewarn "The files from ${EROOT}/etc/jabber where copied to ${EROOT}/etc/prosody."
+ ewarn "Also prosody's spool directory became ${EROOT}/var/lib/prosody (was ${EROOT}/var/spool/jabbber)."
+ ewarn "Please check your configuration."
+ fi
+}