summaryrefslogtreecommitdiff
path: root/net-im/profanity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-08-17 15:32:39 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-08-17 15:32:39 +0100
commitc74abf990d32765245eeb94b36ad4af642cae8c0 (patch)
treeb700660e782342b531312e3855b949f5b2fbbc60 /net-im/profanity
parent5a21cec0c36dba03507dcbd5e8ab6698d00b39bf (diff)
gentoo auto-resync : 17:08:2023 - 15:32:39
Diffstat (limited to 'net-im/profanity')
-rw-r--r--net-im/profanity/Manifest4
-rw-r--r--net-im/profanity/metadata.xml1
-rw-r--r--net-im/profanity/profanity-0.14.0.ebuild71
3 files changed, 75 insertions, 1 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index 1c79a9960b6c..08cc93194944 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1,3 +1,5 @@
DIST profanity-0.13.1.tar.xz 621836 BLAKE2B e038fa01272150cb7974b03f88f64335bf1690115dbbb1c6fe04c79acb69db18c556edf41316af1d363f9715cd2e7aeb3f3bd867836704b620d9a87976b64fa9 SHA512 6d7d3c96c65e26c15cac1157bd296c1dbd3e2471aec959d6c319c68b70ec21cef0c40d7b4eed40c30c377a766db9f13a774ccb4880c227ee368e4dd607d9c267
+DIST profanity-0.14.0.tar.gz 936272 BLAKE2B ec2ae625950a838ee50d6d3a87910bec76f28777bd662e909f394f18c277662694611a59d3be6c7f66821c2800a94b08f94b27a68d82e4de33b7d2f7b14ddf18 SHA512 25afd2f3146e6ed9f573f0e073cad0f06f7f8a21441c3c2c61641442d1aa5b9a7a817cdccc17354b32045ab9a965a95495a30c49088577a5060e8969725ea86e
EBUILD profanity-0.13.1.ebuild 1432 BLAKE2B d82eda77c79054e906e97999c74aacd97a799890880a2329a2824570a518b3b694fde9cf9508e8fc76746ea70f09be0c5940d18e408d30ae14f3e135e292c303 SHA512 eeca616896f0552070e0530cf7a5f352daf6f305e7f98aa473070343be69ca3bc20596cf17245fe96a7f05659283b0d5f2fd3ca215a7f16936c181e111a3443b
-MISC metadata.xml 836 BLAKE2B de63ac5ccbc1f4ec4a9fc76234e59162d650dc2703608f054747da34227e7878da7af48f1f70dbaf03a4275fd247d33b6de55e476bbda46f59d184d734f54ae9 SHA512 968c142c0af685f8a4ced1563c70139b47b1da04fe42ae6bc0a7953605e58e85db319d2732649ae405f79470acac2936eb04e7035bcc37c5c2714a4f14dba76b
+EBUILD profanity-0.14.0.ebuild 1483 BLAKE2B 2031ef9c2f1fb2a7e0902c542790fd5fb15ce7c26873a03f78623e7b7e370ffa2154c2a3ab5dc50f259a648177b33121a6ce2a621a4ef4668e61601468c9a659 SHA512 1f7af3c0acfec07adabbbaf1a6bd6e52fb58544b8592ea744fc5df0b03dc059d237789eaf1aca63421fa28c759297890254d3d7976ae9a176caf5c61e0322d51
+MISC metadata.xml 919 BLAKE2B 22eda39b3887ce0861568b5ffd158ae55c35d72db4a8fb87ff51e35f768b76b718a8fcb0db6f2444b20dc831bc136bcd3c92ae14064e77055160a3628f1ce52e SHA512 0919abb48af2d22077e3ee6edca9a6f4458044f86182dd5e3a4021668e42eaddfc3d631044293d5d548280c1042123fda707335f33dbaaccb590fb3e4ef20960
diff --git a/net-im/profanity/metadata.xml b/net-im/profanity/metadata.xml
index 619a19eb9612..615f8cd4c2ef 100644
--- a/net-im/profanity/metadata.xml
+++ b/net-im/profanity/metadata.xml
@@ -16,6 +16,7 @@
<use>
<flag name="gpg">Enable OpenPGP encryption</flag>
<flag name="omemo">Enable OMEMO encryption</flag>
+ <flag name="omemo-qrcode">Enable exchanging OMEMO information via QR code</flag>
<flag name="otr">Enable encrypted conversations using Off-The-Records messaging</flag>
</use>
<upstream>
diff --git a/net-im/profanity/profanity-0.14.0.ebuild b/net-im/profanity/profanity-0.14.0.ebuild
new file mode 100644
index 000000000000..f9b478c96344
--- /dev/null
+++ b/net-im/profanity/profanity-0.14.0.ebuild
@@ -0,0 +1,71 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="https://profanity-im.github.io"
+SRC_URI="https://github.com/profanity-im/profanity/releases/download/${PV}/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64"
+IUSE="libnotify omemo omemo-qrcode otr gpg test xscreensaver"
+RESTRICT="!test? ( test )"
+REQUIRED_USE="omemo-qrcode? ( omemo )"
+
+RDEPEND="
+ >=app-accessibility/at-spi2-core-2.46.0
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ >=dev-libs/libstrophe-0.12.3:=
+ media-libs/harfbuzz:=
+ net-misc/curl
+ sys-libs/ncurses:=[unicode(+)]
+ sys-libs/readline:=
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ x11-misc/shared-mime-info
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ omemo? (
+ dev-libs/libgcrypt:=
+ net-libs/libsignal-protocol-c
+ )
+ omemo-qrcode? ( media-gfx/qrencode:= )
+ otr? ( net-libs/libotr )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ test? ( dev-util/cmocka )
+"
+
+src_configure() {
+ local myeconfargs=(
+ --enable-gdk-pixbuf
+ $(use_enable libnotify notifications)
+ $(use_enable omemo)
+ $(use_enable omemo-qrcode)
+ $(use_enable otr)
+ $(use_enable gpg pgp)
+ $(use_with xscreensaver)
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ emake CFLAGS="${CFLAGS}"
+}
+
+src_install() {
+ default
+
+ find "${ED}" -type f -name '*.la' -delete || die
+}