summaryrefslogtreecommitdiff
path: root/net-im/profanity
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-09-25 20:21:45 +0100
commitc719fdcee603a5a706a45d10cb598762d56a727d (patch)
tree620cbf137661399a3fb1eff92914204f9a970713 /net-im/profanity
parentcc4618c9ba3d974948ebf340b542d8cb01db2f55 (diff)
gentoo resync : 25.09.2021
Diffstat (limited to 'net-im/profanity')
-rw-r--r--net-im/profanity/Manifest2
-rw-r--r--net-im/profanity/profanity-0.11.0-r1.ebuild50
2 files changed, 52 insertions, 0 deletions
diff --git a/net-im/profanity/Manifest b/net-im/profanity/Manifest
index a241857959f3..e9ead3d73002 100644
--- a/net-im/profanity/Manifest
+++ b/net-im/profanity/Manifest
@@ -1,3 +1,5 @@
+DIST profanity-0.11.0.tar.gz 887566 BLAKE2B 373b49670d00aa741e1957a8d3ca0282f6e7215c53c6c89088268d92fa6bd8f396e6c8e69f17aeb65f9183f620376613672c7f71c879ece31b97382df5d7a781 SHA512 14164921e151a9201728afc3835e08649036702d1fcdef6e37f83de6da4b9bd9c5e9ba54db69e3a9e16fb7e360369b4e92b6b771bc5e005e343a9a526738a268
DIST profanity-0.9.5.tar.gz 830966 BLAKE2B fc1b755b1a92dbde62aacb31cb5d9190cea951e98501a5b48495dbd31266f343cf436de1fa0f69caec34324cd1f781d0bd4f5f7ebdd984324c5d1d6edb91452a SHA512 79305ee488d3a9b87bb422d6525bfaae62c4969d466b968c86941ed5bf0c0080e349758f2e1ead144693513b5d19a635372e73aa1fe9e362836b9245e1d2b898
+EBUILD profanity-0.11.0-r1.ebuild 1056 BLAKE2B 2c09a9a88b89a3b0e335583fbea06a5798ab395af529a3dac98bc38999b46e2945ab7311fcef1f2728d0136ddde3c3e98505f5c2627b530daf84b0a786bf0947 SHA512 f6b9643f0fe819d8e082c5c2b51ae6d61806ad39a884a3cacee776ead18cc083e1a7af17406defd5136d6d154d2b047753006ac18fe78d60cd807b8703ab20ba
EBUILD profanity-0.9.5-r1.ebuild 1035 BLAKE2B 94078ea301009255f2b9b57b0835558ebc797ad3c0c75393be2c95c4b368832dabc0be1d596e45c2b421e3c2e58ea099d0238c55dc9a9ceaf0ccc3519b4c96ce SHA512 c21319345910123603041d916f0712c4eac3851bb71efee3906d8e2423e2aef3032139bb663ce3a4d2bcf13254456c03948a10511ef8dc2d72f214f023db19ed
MISC metadata.xml 693 BLAKE2B e95d3933a403ac601c8a6e286dab57a592543dde78e6d04ef8ada15c12ae0f4625a6706e8c7c58831140214ad6ed76dc2aaf82d1a707808b4d4cbb91d438a47a SHA512 ea6745842648608bc79ac809648827c15630a8d0e2429c907f8a6816b0644838f49eb2e6da81d1f29ef9450c532c1ef7e214dd39c63da88e0862d49743b70a89
diff --git a/net-im/profanity/profanity-0.11.0-r1.ebuild b/net-im/profanity/profanity-0.11.0-r1.ebuild
new file mode 100644
index 000000000000..1ca09eb39937
--- /dev/null
+++ b/net-im/profanity/profanity-0.11.0-r1.ebuild
@@ -0,0 +1,50 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A console based XMPP client inspired by Irssi"
+HOMEPAGE="https://profanity-im.github.io"
+SRC_URI="https://profanity-im.github.io/${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+IUSE="libnotify omemo otr gpg test xscreensaver"
+RESTRICT="!test? ( test )"
+
+COMMON_DEPEND="
+ dev-db/sqlite
+ dev-libs/expat
+ dev-libs/glib
+ dev-libs/libstrophe:=
+ dev-libs/openssl:0=
+ net-misc/curl
+ sys-apps/util-linux
+ sys-libs/ncurses:=[unicode(+)]
+ virtual/libcrypt:=
+ gpg? ( app-crypt/gpgme:= )
+ libnotify? ( x11-libs/libnotify )
+ omemo? (
+ net-libs/libsignal-protocol-c
+ dev-libs/libgcrypt
+ )
+ otr? ( net-libs/libotr )
+ xscreensaver? (
+ x11-libs/libXScrnSaver
+ x11-libs/libX11 )
+ "
+DEPEND="${COMMON_DEPEND}
+ test? ( dev-util/cmocka )
+"
+RDEPEND="${COMMON_DEPEND}"
+
+src_configure() {
+ econf \
+ $(use_enable libnotify notifications) \
+ $(use_enable omemo) \
+ $(use_enable otr) \
+ $(use_enable gpg pgp) \
+ $(use_with xscreensaver)
+}