summaryrefslogtreecommitdiff
path: root/net-im/openmittsu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-im/openmittsu
reinit the tree, so we can have metadata
Diffstat (limited to 'net-im/openmittsu')
-rw-r--r--net-im/openmittsu/Manifest3
-rw-r--r--net-im/openmittsu/metadata.xml7
-rw-r--r--net-im/openmittsu/openmittsu-0.9.2.109.ebuild48
3 files changed, 58 insertions, 0 deletions
diff --git a/net-im/openmittsu/Manifest b/net-im/openmittsu/Manifest
new file mode 100644
index 000000000000..83aeb065cdda
--- /dev/null
+++ b/net-im/openmittsu/Manifest
@@ -0,0 +1,3 @@
+DIST openmittsu-0.9.2.109.tar.xz 1314888 SHA256 cf012e36ce157023082c8efa04ce6d4521ac16044334647c860a07b2ff94ea35 SHA512 ad70ff7c3ceedcf1d6711468152199742533b8f42abbae5ce52f3e29882ae6aea566e8a39258a3d3676a91774e144a70d91967b31e4634f23d527f14325d0a5b WHIRLPOOL f0843eaa35507374a69977c0e023c060f47448d72ea77c3f640b2b5e1ddd87dff756c31c3827c043107af798b5abb58287b07dba8c841be57167d1e8787b1a24
+EBUILD openmittsu-0.9.2.109.ebuild 1340 SHA256 1900bc66f6da828ea977709fcb0e306fdd22705849c8c21a36c2bbae624d6a4c SHA512 9d5feaeb148e279fd373cff6e5957055e91aea5b1cfb0b426afcdf6dfd391514a17711e58cd90ed3105f9bbd9203be5c32f93dfc77ff28149ee8ca660b9d7751 WHIRLPOOL da41c88027d2065babba6446f43cb9b3e5d8a04ea71a99e397a35a2dca18c714ef13cf8e5679462ab4f16a1daaa13a939a091a756e8d15c7829eca9d96da1256
+MISC metadata.xml 212 SHA256 de74121c61a32da4efe984edecb71e0d5d947d179dd8228f60eb7c8bd94d6b8c SHA512 3919b8b096abf61c7edaa6a76898603b6ca2e206e2eccd27c671957a9d085bc2591a2fb4839a85ef2a51dcbf887bb2c752d4b38e82ea19c48dfd6d99b67954fa WHIRLPOOL f203947dfb1f7a9ab97fd689bd02229e4e48ad74e0f246d810d85d6f49f9802e4be4e7cf75d214a0428fd80dec6d953f5186c7856c266882eab60e712a732da2
diff --git a/net-im/openmittsu/metadata.xml b/net-im/openmittsu/metadata.xml
new file mode 100644
index 000000000000..c665e48637be
--- /dev/null
+++ b/net-im/openmittsu/metadata.xml
@@ -0,0 +1,7 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+<maintainer type="person">
+ <email>ulm@gentoo.org</email>
+</maintainer>
+</pkgmetadata>
diff --git a/net-im/openmittsu/openmittsu-0.9.2.109.ebuild b/net-im/openmittsu/openmittsu-0.9.2.109.ebuild
new file mode 100644
index 000000000000..aa52b268de9a
--- /dev/null
+++ b/net-im/openmittsu/openmittsu-0.9.2.109.ebuild
@@ -0,0 +1,48 @@
+# Copyright 1999-2017 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit cmake-utils eutils
+
+DESCRIPTION="An open source chat client for Threema-style end-to-end encrypted chat networks"
+HOMEPAGE="https://www.openmittsu.de/"
+# git-archive-all.sh snapshot of https://github.com/blizzard4591/openMittsu.git
+SRC_URI="https://dev.gentoo.org/~ulm/distfiles/${P}.tar.xz"
+
+LICENSE="GPL-2+ BitstreamVera OFL-1.1 Apache-2.0 CC0-1.0 MIT BSD-2 Boost-1.0"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND=">=dev-libs/libsodium-1.0.11:=
+ >=dev-qt/qtcore-5.7.1:5=
+ >=dev-qt/qtgui-5.7.1:5=
+ >=dev-qt/qtmultimedia-5.7.1:5=
+ >=dev-qt/qtnetwork-5.7.1:5=[ssl]
+ >=dev-qt/qtsql-5.7.1:5=[sqlite]
+ >=dev-qt/qtwidgets-5.7.1:5=
+ >=media-gfx/qrencode-3.4.4-r1:="
+RDEPEND="${DEPEND}"
+
+DOCS=(
+ README.md
+ Example-client-configuration-file.ini
+ Example-contacts-file.txt
+)
+
+src_configure() {
+ local mycmakeargs=(
+ # set version manually, since autodetection works only with git
+ "-DOPENMITTSU_CUSTOM_VERSION_STRING=${PV%.*}-${PV##*.}-00000000"
+ "-DOPENMITTSU_DISABLE_VERSION_UPDATE_CHECK=ON"
+ )
+ cmake-utils_src_configure
+}
+
+src_install() {
+ local my_pn="openMittsu"
+ cmake-utils_src_install
+ newicon resources/icon.png ${my_pn}.png
+ make_desktop_entry ${my_pn} ${my_pn} ${my_pn}
+ rm "${ED}"/usr/bin/${my_pn}VersionInfo || die
+}