summaryrefslogtreecommitdiff
path: root/net-im/gajim
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-05-19 16:15:42 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-05-19 16:15:42 +0100
commitac616584d4bcb8e2a2defb591e3b0643054fda5d (patch)
tree2a1c72220398765d90183db696285fa3262ecdad /net-im/gajim
parent1b76d39d04711631f8d9c7961d19e993e718e53c (diff)
gentoo auto-resync : 19:05:2023 - 16:15:42
Diffstat (limited to 'net-im/gajim')
-rw-r--r--net-im/gajim/Manifest1
-rw-r--r--net-im/gajim/gajim-1.7.3-r1.ebuild102
2 files changed, 103 insertions, 0 deletions
diff --git a/net-im/gajim/Manifest b/net-im/gajim/Manifest
index 49f880c2f6a8..8056f325a432 100644
--- a/net-im/gajim/Manifest
+++ b/net-im/gajim/Manifest
@@ -1,5 +1,6 @@
DIST gajim-1.4.7.tar.gz 7184866 BLAKE2B 9be0ae485a372683623eff1f9ed1d209800c3088bf01c134bb5c6f1770e8ded1ebe6c2b301ad648c6cfb1793e2be43aade1410a701f7d0490f2ab1b0a4c3fdd5 SHA512 5988f6b7aa46166208b1693b9e1a5fe982cea2987f3f4170bcb14e4bb9be1154b1c6ceed020a949131a498db43d2dffee30bd3167cd56889c1cbb5641ed960f4
DIST gajim-1.7.3.tar.gz 3753831 BLAKE2B c7b8b1dc47b1faf9f1c0803e7931cb00bfbf31075fe481d557ec0f308c79e7580d0054d224781a67eaeea24dba40e40de5faf55d633d71f759022a1ac113f6e4 SHA512 66135e88784350bab79b61debc1b65144a82f8eee2c1841d21e4f511b3792361e57b60304d2478654e563687e8302426d76063e748236f4e1c959511c7c28665
EBUILD gajim-1.4.7-r2.ebuild 2686 BLAKE2B 6bfa971349e0e4c3331a975a378382cb5bd362c03b14265c8371a69875580cef0f7cfbcb417f4c0358a378974706fec188fb052a1cb540db5f63b6ce308bdad0 SHA512 b24310ca16ee32e186f42a5619390ff331f152ef8f2ed804bd9af95286d2d2c66832a4438ddbc87b20ba12ee4ff4a7cc4e488689e48def931e3580864cd4da94
+EBUILD gajim-1.7.3-r1.ebuild 2821 BLAKE2B ade28a8c7c12ad997bf1e19156596dc4ef59051f2ce5f5655825c0a4fd10b7a9a79c287d90dc91f2ec80e4cbf16a2ff4c4cf370e1e0e94d1ec3fd61d3ca648cb SHA512 fd98199c0a1290d8d909d74488f83c0f4bdff44299c7625c2f93aed2de82c3b08e29bf247a5535de8dae6c2ac574905ea601420e6ac149ad3979b4661004cdb6
EBUILD gajim-1.7.3.ebuild 2609 BLAKE2B 3ca58a71c4b3e51fb605d031e55a6caa104d5e53e8d1e0e382a3b1bacc38859d0bb2598ce119b005f36b6ef0c67388ee2b7e4e03bfabfe257cd5c65c74e97d8a SHA512 49e1fcdd326c29f480d672bec91b941c3aa7a3d014a226ec8f87de7bf675a8909e5ab2af8afa788193f4c6bf378bc442951c6720e817887e810bd43d91d3d2c7
MISC metadata.xml 867 BLAKE2B b7dcc46c99a2c04f9382cd7eeb34b416a422baae8e8123369bb9809c89204413cc9a93c51979fd50f542aed29caff5e6bb18e3ea3a077814f89826972d778837 SHA512 e56580db1a6734f1e219eeb61176ba60e5c85895e0cf7699643f82c928d7f083d519cf3d490b0750b0cbe875cf1428e67e35961ad006c38f62829f04090af134
diff --git a/net-im/gajim/gajim-1.7.3-r1.ebuild b/net-im/gajim/gajim-1.7.3-r1.ebuild
new file mode 100644
index 000000000000..9d3183fcf836
--- /dev/null
+++ b/net-im/gajim/gajim-1.7.3-r1.ebuild
@@ -0,0 +1,102 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+PYTHON_REQ_USE="sqlite,xml(+)"
+DISTUTILS_USE_PEP517=standalone
+DISTUTILS_SINGLE_IMPL=1
+
+inherit distutils-r1 xdg-utils
+
+DESCRIPTION="Jabber client written in PyGTK"
+HOMEPAGE="https://gajim.org/"
+SRC_URI="https://gajim.org/downloads/$(ver_cut 1-2)/${P/_p/-}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~arm64 ~riscv ~x86"
+IUSE="+crypt geolocation jingle omemo remote rst +spell upnp +webp"
+
+COMMON_DEPEND="
+ dev-libs/gobject-introspection[cairo(+)]
+ >=x11-libs/gtk+-3.22:3[introspection]
+ x11-libs/gtksourceview:4[introspection]"
+DEPEND="${COMMON_DEPEND}
+ app-arch/unzip
+ virtual/pkgconfig
+ >=sys-devel/gettext-0.17-r1"
+RDEPEND="${COMMON_DEPEND}
+ $(python_gen_cond_dep '
+ dev-python/idna[${PYTHON_USEDEP}]
+ >=dev-python/nbxmpp-4.2.2[${PYTHON_USEDEP}]
+ <dev-python/nbxmpp-5.0.0[${PYTHON_USEDEP}]
+ dev-python/precis-i18n[${PYTHON_USEDEP}]
+ dev-python/pyasn1[${PYTHON_USEDEP}]
+ dev-python/pycairo[${PYTHON_USEDEP}]
+ dev-python/pycurl[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[cairo,${PYTHON_USEDEP}]
+ x11-libs/libXScrnSaver
+ app-crypt/libsecret[crypt,introspection]
+ dev-python/keyring[${PYTHON_USEDEP}]
+ >=dev-python/secretstorage-3.1.1[${PYTHON_USEDEP}]
+ dev-python/css-parser[${PYTHON_USEDEP}]
+ dev-python/packaging[${PYTHON_USEDEP}]
+ net-libs/libsoup:3.0[introspection]
+ media-libs/gsound[introspection]
+ dev-python/pillow[${PYTHON_USEDEP}]
+ crypt? (
+ dev-python/pycryptodome[${PYTHON_USEDEP}]
+ >=dev-python/python-gnupg-0.4.0[${PYTHON_USEDEP}] )
+ geolocation? ( app-misc/geoclue[introspection] )
+ jingle? (
+ net-libs/farstream:0.2[introspection]
+ media-libs/gstreamer:1.0[introspection]
+ media-libs/gst-plugins-base:1.0[introspection]
+ media-libs/gst-plugins-ugly:1.0
+ media-plugins/gst-plugins-gtk
+ )
+ omemo? (
+ dev-python/jaraco-classes[${PYTHON_USEDEP}]
+ dev-python/python-axolotl[${PYTHON_USEDEP}]
+ dev-python/qrcode[${PYTHON_USEDEP}]
+ dev-python/cryptography[${PYTHON_USEDEP}]
+ )
+ remote? (
+ >=dev-python/dbus-python-1.2.0[${PYTHON_USEDEP}]
+ sys-apps/dbus[X]
+ )
+ rst? ( dev-python/docutils[${PYTHON_USEDEP}] )
+ spell? (
+ app-text/gspell[introspection]
+ app-text/hunspell
+ )
+ upnp? ( net-libs/gupnp-igd:0[introspection] )
+ ')"
+
+python_compile() {
+ distutils-r1_python_compile
+ ./pep517build/build_metadata.py -o dist/metadata
+}
+
+python_install() {
+ distutils-r1_python_install
+ ./pep517build/install_metadata.py dist/metadata --prefix="${D}/usr"
+
+ rm "${D}"/usr/share/man/man1/*.gz
+ doman data/*.1
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ xdg_desktop_database_update
+}
+
+# Tests are unfortunately regularly broken
+RESTRICT="test"