summaryrefslogtreecommitdiff
path: root/net-im/dino
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-im/dino
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-im/dino')
-rw-r--r--net-im/dino/Manifest2
-rw-r--r--net-im/dino/dino-9999.ebuild80
-rw-r--r--net-im/dino/metadata.xml17
3 files changed, 99 insertions, 0 deletions
diff --git a/net-im/dino/Manifest b/net-im/dino/Manifest
new file mode 100644
index 000000000000..3056bbc4fbd8
--- /dev/null
+++ b/net-im/dino/Manifest
@@ -0,0 +1,2 @@
+EBUILD dino-9999.ebuild 1448 BLAKE2B efd97fa84a72985bc62e7cf97b43fa48233e33380cd9a0cb7ac74c1ffd3b47ab58fac50dd7a42f2b06be7b3ae09f834ee3f5c33f63aac66d7934ccffa9edc49e SHA512 1b757fd6c337de2f2e364d99305afe9df027d4332a51078df5d73f4afd377dd9d31e8d5b256c3ecb13c8ceb886b07ae90208c6e496aefd34a50d11d354863028
+MISC metadata.xml 575 BLAKE2B df85897e138ef2e19f9d4a700fe6b56b4aac9ac680ba68d9248465fd9ebfa0bb989591a9a47b91ad46009322c47a726bf773e86eda3697140629092e3d767650 SHA512 a5b5690198b7462f4abbfaacd2ff51e284dcaf1f721d92993cd42ce2bc4ccd543893cbeaa1af591cf676ccd68722ab18190fae0e3615d4defb272dfaec98c525
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
new file mode 100644
index 000000000000..9b578c608889
--- /dev/null
+++ b/net-im/dino/dino-9999.ebuild
@@ -0,0 +1,80 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+CMAKE_MAKEFILE_GENERATOR="ninja"
+VALA_MIN_API_VERSION="0.34"
+inherit cmake-utils gnome2-utils vala
+
+DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
+HOMEPAGE="https://dino.im"
+LICENSE="GPL-3"
+SLOT="0"
+IUSE="+gnupg +http +omemo"
+
+MY_REPO_URI="https://github.com/dino/dino"
+if [[ ${PV} == "9999" ]]; then
+ EGIT_REPO_URI="${MY_REPO_URI}.git"
+ inherit git-r3
+else
+ KEYWORDS="~amd64"
+ SRC_URI="${MY_REPO_URI}/archive/${PV}.tar.gz"
+fi
+
+RDEPEND="
+ dev-db/sqlite:3
+ dev-libs/glib:2
+ dev-libs/libgee:0.8
+ net-libs/glib-networking
+ x11-libs/cairo
+ x11-libs/gdk-pixbuf:2
+ x11-libs/gtk+:3
+ x11-libs/pango
+ gnupg? ( app-crypt/gpgme:1 )
+ http? ( net-libs/libsoup:2.4 )
+ omemo? ( dev-libs/libgcrypt:0 )
+"
+DEPEND="
+ $(vala_depend)
+ ${RDEPEND}
+ sys-devel/gettext
+"
+
+src_prepare() {
+ cmake-utils_src_prepare
+}
+
+src_configure() {
+ local disabled_plugins=(
+ $(usex gnupg "" "openpgp")
+ $(usex omemo "" "omemo")
+ $(usex http "" "http-files")
+ )
+ local mycmakeargs+=(
+ "-DDISABLED_PLUGINS=$(local IFS=";"; echo "${disabled_plugins[*]}")"
+ )
+
+ if has test ${FEATURES}; then
+ mycmakeargs+=("-DBUILD_TESTS=yes")
+ fi
+
+ cmake-utils_src_configure
+}
+
+src_test() {
+ "${BUILD_DIR}"/xmpp-vala-test || die
+}
+
+update_caches() {
+ gnome2_icon_cache_update
+ xdg_desktop_database_update
+}
+
+pkg_postinst() {
+ update_caches
+}
+
+pkg_postrm() {
+ update_caches
+}
diff --git a/net-im/dino/metadata.xml b/net-im/dino/metadata.xml
new file mode 100644
index 000000000000..c488bca606f2
--- /dev/null
+++ b/net-im/dino/metadata.xml
@@ -0,0 +1,17 @@
+<?xml version="1.0" encoding="UTF-8"?>
+<!DOCTYPE pkgmetadata SYSTEM "http://www.gentoo.org/dtd/metadata.dtd">
+<pkgmetadata>
+ <maintainer type="person">
+ <email>andrey_utkin@gentoo.org</email>
+ <name>Andrey Utkin</name>
+ </maintainer>
+ <upstream>
+ <bugs-to>https://github.com/dino/dino/issues</bugs-to>
+ <remote-id type="github">dino/dino</remote-id>
+ </upstream>
+ <use>
+ <flag name="gnupg">Enable OpenPGP encryption plugin</flag>
+ <flag name="http">Enable HTTP file upload plugin</flag>
+ <flag name="omemo">Enable OMEMO encryption plugin</flag>
+ </use>
+</pkgmetadata>