summaryrefslogtreecommitdiff
path: root/net-im/dino/dino-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-01-01 20:22:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-01-01 20:22:33 +0000
commit5b7c114c09d07eecd00e6f7fb829563aae3597b9 (patch)
treedb84e97d92f22634a22ce461f4ca00a294a21b24 /net-im/dino/dino-9999.ebuild
parentad1d34add08caaf8d68c79e40f0a61c733fd68b8 (diff)
gentoo auto-resync : 01:01:2023 - 20:22:32
Diffstat (limited to 'net-im/dino/dino-9999.ebuild')
-rw-r--r--net-im/dino/dino-9999.ebuild19
1 files changed, 8 insertions, 11 deletions
diff --git a/net-im/dino/dino-9999.ebuild b/net-im/dino/dino-9999.ebuild
index dcefefcd1c83..5362d42a0864 100644
--- a/net-im/dino/dino-9999.ebuild
+++ b/net-im/dino/dino-9999.ebuild
@@ -1,10 +1,8 @@
-# Copyright 1999-2022 Gentoo Authors
+# Copyright 1999-2023 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=7
+EAPI=8
-CMAKE_MAKEFILE_GENERATOR="ninja"
-VALA_MIN_API_VERSION="0.34"
inherit cmake vala xdg readme.gentoo-r1
DESCRIPTION="Modern Jabber/XMPP Client using GTK+/Vala"
@@ -47,19 +45,18 @@ RDEPEND="
notification-sound? ( media-libs/libcanberra:0[sound] )
"
DEPEND="
- $(vala_depend)
${RDEPEND}
media-libs/gst-plugins-base
media-libs/gstreamer
+"
+BDEPEND="
sys-devel/gettext
+ $(vala_depend)
"
-src_prepare() {
- cmake_src_prepare
- vala_src_prepare
-}
-
src_configure() {
+ vala_setup
+
local disabled_plugins=(
$(usex gpg "" "openpgp")
$(usex omemo "" "omemo")
@@ -87,7 +84,7 @@ src_install() {
readme.gentoo_create_doc
}
-src_postinst() {
+pkg_postinst() {
xdg_pkg_postinst
readme.gentoo_print_elog
}