summaryrefslogtreecommitdiff
path: root/net-im/bitlbee/bitlbee-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-05-14 11:09:11 +0100
commitdeba8115d2c2af26df42966b91ef04ff4dd79cde (patch)
tree9a48f42594e1a9e6b2020d5535a784314434d7a7 /net-im/bitlbee/bitlbee-9999.ebuild
parent38423c67c8a23f6a1bc42038193182e2da3116eb (diff)
gentoo resync : 14.05.2020
Diffstat (limited to 'net-im/bitlbee/bitlbee-9999.ebuild')
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild35
1 files changed, 17 insertions, 18 deletions
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index 9df170295b6b..b76660b5f28b 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -1,9 +1,11 @@
-# Copyright 1999-2019 Gentoo Authors
+# Copyright 1999-2020 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
-inherit user systemd toolchain-funcs
+PYTHON_COMPAT=( python3_{6..8} )
+
+inherit python-any-r1 systemd toolchain-funcs
if [[ ${PV} == "9999" ]]; then
EGIT_REPO_URI="https://github.com/bitlbee/bitlbee.git"
@@ -30,7 +32,9 @@ REQUIRED_USE="
"
COMMON_DEPEND="
- >=dev-libs/glib-2.16
+ acct-group/bitlbee
+ acct-user/bitlbee
+ dev-libs/glib:2
purple? ( net-im/pidgin )
libevent? ( dev-libs/libevent:= )
otr? ( >=net-libs/libotr-4 )
@@ -44,22 +48,21 @@ COMMON_DEPEND="
)
"
DEPEND="${COMMON_DEPEND}
- virtual/pkgconfig
selinux? ( sec-policy/selinux-bitlbee )
- test? ( dev-libs/check )"
+ test? ( dev-libs/check )
+"
RDEPEND="${COMMON_DEPEND}
- xinetd? ( sys-apps/xinetd )"
+ xinetd? ( sys-apps/xinetd )
+"
-pkg_setup() {
- enewgroup bitlbee
- enewuser bitlbee -1 -1 /var/lib/bitlbee bitlbee
-}
+BDEPEND="${PYTHON_DEPS}
+ virtual/pkgconfig
+"
-src_prepare() {
- [[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${PN}-3.5-systemd-user.patch
- eapply_user
-}
+PATCHES=(
+ "${FILESDIR}"/${PN}-3.5-systemd-user.patch
+)
src_configure() {
local myconf
@@ -145,7 +148,3 @@ src_install() {
exeinto /usr/share/bitlbee
doexe utils/{convert_purple.py,bitlbee-ctl.pl}
}
-
-pkg_postinst() {
- chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
-}