summaryrefslogtreecommitdiff
path: root/net-im/bitlbee/bitlbee-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /net-im/bitlbee/bitlbee-9999.ebuild
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'net-im/bitlbee/bitlbee-9999.ebuild')
-rw-r--r--net-im/bitlbee/bitlbee-9999.ebuild29
1 files changed, 5 insertions, 24 deletions
diff --git a/net-im/bitlbee/bitlbee-9999.ebuild b/net-im/bitlbee/bitlbee-9999.ebuild
index ba55773394df..703647ae05d3 100644
--- a/net-im/bitlbee/bitlbee-9999.ebuild
+++ b/net-im/bitlbee/bitlbee-9999.ebuild
@@ -1,7 +1,7 @@
-# Copyright 1999-2017 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit user systemd toolchain-funcs
@@ -48,7 +48,6 @@ DEPEND="${COMMON_DEPEND}
test? ( dev-libs/check )"
RDEPEND="${COMMON_DEPEND}
- virtual/logger
xinetd? ( sys-apps/xinetd )"
pkg_setup() {
@@ -57,12 +56,7 @@ pkg_setup() {
}
src_prepare() {
- if [[ ${PV} != "9999" ]]; then
- eapply \
- "${FILESDIR}"/${P}-systemd-user.patch \
- "${FILESDIR}"/${P}-verbose-build.patch
- fi
-
+ [[ ${PV} != "9999" ]] && eapply "${FILESDIR}"/${PN}-3.5-systemd-user.patch
eapply_user
}
@@ -143,8 +137,8 @@ src_install() {
newins doc/bitlbee.xinetd bitlbee
fi
- newinitd "${FILESDIR}"/bitlbee.initd-r1 bitlbee
- newconfd "${FILESDIR}"/bitlbee.confd-r1 bitlbee
+ newinitd "${FILESDIR}"/bitlbee.initd-r2 bitlbee
+ newconfd "${FILESDIR}"/bitlbee.confd-r2 bitlbee
exeinto /usr/share/bitlbee
doexe utils/{convert_purple.py,bitlbee-ctl.pl}
@@ -152,17 +146,4 @@ src_install() {
pkg_postinst() {
chown -R bitlbee:bitlbee "${ROOT}"/var/lib/bitlbee
- [[ -d "${ROOT}"/var/run/bitlbee ]] &&
- chown -R bitlbee:bitlbee "${ROOT}"/var/run/bitlbee
-
- if [[ -z ${REPLACING_VERSIONS} ]]; then
- einfo
- elog "The bitlbee init script will now attempt to stop all processes owned by the"
- elog "bitlbee user, including per-client forks."
- elog
- elog "Tell the init script not to touch anything besides the main bitlbee process"
- elog "by changing the BITLBEE_STOP_ALL variable in"
- elog " /etc/conf.d/bitlbee"
- einfo
- fi
}