summaryrefslogtreecommitdiff
path: root/net-ftp/uftpd/uftpd-2.15.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-04 01:27:12 +0000
commit3517852e3b8a68d1e997770fc0650c5053bafc6c (patch)
tree44068672445b1418489aed82de58df3c470289e7 /net-ftp/uftpd/uftpd-2.15.ebuild
parent0f15659d48c193027158492acb726297501202c5 (diff)
gentoo resync : 04.01.2022
Diffstat (limited to 'net-ftp/uftpd/uftpd-2.15.ebuild')
-rw-r--r--net-ftp/uftpd/uftpd-2.15.ebuild34
1 files changed, 34 insertions, 0 deletions
diff --git a/net-ftp/uftpd/uftpd-2.15.ebuild b/net-ftp/uftpd/uftpd-2.15.ebuild
new file mode 100644
index 000000000000..abc498a16b38
--- /dev/null
+++ b/net-ftp/uftpd/uftpd-2.15.ebuild
@@ -0,0 +1,34 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="The no nonsense TFTP/FTP server"
+HOMEPAGE="https://github.com/troglobit/uftpd"
+SRC_URI="https://github.com/troglobit/${PN}/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="MIT"
+SLOT="0"
+KEYWORDS="~amd64"
+IUSE="test"
+RESTRICT="!test? ( test )"
+
+RDEPEND="
+ >=dev-libs/libite-1.5
+ >=dev-libs/libuev-2.2"
+
+DEPEND="
+ ${RDEPEND}
+ !net-misc/uftp
+ !net-ftp/atftp
+ !net-ftp/tftp-hpa[server(+)]
+ test? (
+ net-ftp/ftp
+ net-ftp/tnftp
+ >=net-ftp/tftp-hpa-5.2-r2[client]
+ )"
+
+src_test() {
+ # can't run the tests in parallel since the order matters
+ emake -j 1 check
+}