summaryrefslogtreecommitdiff
path: root/net-ftp/tnftp/tnftp-20230507.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-07-05 10:11:02 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-07-05 10:11:02 +0100
commit20deac35b03e3e15d55e2cfd0236308f20bead59 (patch)
tree025d381424ca1c394c0f8e538633cd942f5ee490 /net-ftp/tnftp/tnftp-20230507.ebuild
parentfc3556aa4466d278bff2aef2f88113089def0bab (diff)
gentoo auto-resync : 05:07:2023 - 10:11:01
Diffstat (limited to 'net-ftp/tnftp/tnftp-20230507.ebuild')
-rw-r--r--net-ftp/tnftp/tnftp-20230507.ebuild31
1 files changed, 31 insertions, 0 deletions
diff --git a/net-ftp/tnftp/tnftp-20230507.ebuild b/net-ftp/tnftp/tnftp-20230507.ebuild
new file mode 100644
index 000000000000..596d018dbd6d
--- /dev/null
+++ b/net-ftp/tnftp/tnftp-20230507.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI="8"
+
+DESCRIPTION="NetBSD FTP client with several advanced features"
+SRC_URI="ftp://ftp.netbsd.org/pub/NetBSD/misc/${PN}/${P}.tar.gz"
+HOMEPAGE="ftp://ftp.netbsd.org/pub/NetBSD/misc/tnftp/"
+
+SLOT="0"
+LICENSE="BSD-4 BSD ISC"
+KEYWORDS="~amd64 ~arm64 ~ppc ~x86 ~amd64-linux ~x86-linux ~ppc-macos"
+IUSE="ipv6 socks5 ssl"
+REQUIRED_USE="socks5? ( !ipv6 )"
+
+DEPEND=">=sys-libs/ncurses-5.1
+ dev-libs/libedit
+ socks5? ( net-proxy/dante )
+ ssl? ( dev-libs/openssl:= )"
+RDEPEND="${DEPEND}"
+
+DOCS=( ChangeLog README THANKS )
+
+src_configure() {
+ econf \
+ --enable-editcomplete \
+ --without-local-libedit \
+ $(use_enable ipv6) \
+ $(use_enable ssl) \
+ $(use_with socks5 socks)
+}