summaryrefslogtreecommitdiff
path: root/net-ftp/tlswrap/tlswrap-1.04-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-ftp/tlswrap/tlswrap-1.04-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-ftp/tlswrap/tlswrap-1.04-r3.ebuild')
-rw-r--r--net-ftp/tlswrap/tlswrap-1.04-r3.ebuild38
1 files changed, 38 insertions, 0 deletions
diff --git a/net-ftp/tlswrap/tlswrap-1.04-r3.ebuild b/net-ftp/tlswrap/tlswrap-1.04-r3.ebuild
new file mode 100644
index 000000000000..f560a6c65370
--- /dev/null
+++ b/net-ftp/tlswrap/tlswrap-1.04-r3.ebuild
@@ -0,0 +1,38 @@
+# Copyright 1999-2016 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="FTP wrapper which supports TLS with every FTP client"
+HOMEPAGE="http://www.tlswrap.com/"
+SRC_URI="http://www.tlswrap.com/${P}.tar.gz"
+
+# GPL-2 for Gentoo init script
+LICENSE="BSD GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="libressl"
+
+DEPEND="!libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )"
+RDEPEND="${DEPEND}"
+
+PATCHES=(
+ "${FILESDIR}/${P}-libressl.patch"
+ "${FILESDIR}/respect-cflags.patch"
+ "${FILESDIR}/modernize-am_init_automake.patch"
+ "${FILESDIR}/fix-Wformat-security-warnings.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_install() {
+ emake prefix="${D}/usr" install
+ dodoc ChangeLog README
+ newinitd "${FILESDIR}/tlswrap.init" tlswrap
+}