summaryrefslogtreecommitdiff
path: root/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-ftp/pureadmin/pureadmin-0.4-r1.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-ftp/pureadmin/pureadmin-0.4-r1.ebuild')
-rw-r--r--net-ftp/pureadmin/pureadmin-0.4-r1.ebuild62
1 files changed, 62 insertions, 0 deletions
diff --git a/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild b/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild
new file mode 100644
index 000000000000..815d949ac40e
--- /dev/null
+++ b/net-ftp/pureadmin/pureadmin-0.4-r1.ebuild
@@ -0,0 +1,62 @@
+# Copyright 1999-2012 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=4
+
+inherit eutils
+
+DESCRIPTION="GUI tool used to make the management of Pure-FTPd a little easier"
+HOMEPAGE="http://purify.sourceforge.net/"
+SRC_URI="mirror://sourceforge/purify/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE="debug doc"
+
+RDEPEND="
+ gnome-base/libglade:2.0
+ sys-libs/zlib
+ virtual/fam
+ x11-libs/gtk+:2"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+src_prepare() {
+ cat >> po/POTFILES.skip <<- EOF
+ src/eggstatusicon.c
+ src/eggtrayicon.c
+ src/prereq_usrmanager.c
+ EOF
+ epatch "${FILESDIR}"/${P}-gold.patch
+}
+
+src_configure() {
+ local myconf=""
+
+ use debug && myconf="${myconf} --enable-debug"
+
+ econf ${myconf}
+}
+
+src_install() {
+ default
+
+ # Move the docs to the correct location, if we want the docs
+ if use doc ; then
+ dodoc "${ED}"usr/share/pureadmin/docs/*
+ fi
+ rm -Rfv "${ED}"usr/share/pureadmin/docs || die
+
+ make_desktop_entry pureadmin "Pure-FTPd menu config" pureadmin
+}
+
+pkg_postinst() {
+ ewarn "PureAdmin is at a beta-stage right now and it may break your"
+ ewarn "configuration. DO NOT use it for safety critical system"
+ ewarn "or production use!"
+ echo
+ elog "You need root-privileges to be able to use PureAdmin."
+ elog "This will probably change in the future."
+ echo
+}