summaryrefslogtreecommitdiff
path: root/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r3.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
committerV3n3RiX <venerix@redcorelinux.org>2017-10-09 18:53:29 +0100
commit4f2d7949f03e1c198bc888f2d05f421d35c57e21 (patch)
treeba5f07bf3f9d22d82e54a462313f5d244036c768 /net-ftp/linksys-tftp/linksys-tftp-1.2.1-r3.ebuild
reinit the tree, so we can have metadata
Diffstat (limited to 'net-ftp/linksys-tftp/linksys-tftp-1.2.1-r3.ebuild')
-rw-r--r--net-ftp/linksys-tftp/linksys-tftp-1.2.1-r3.ebuild29
1 files changed, 29 insertions, 0 deletions
diff --git a/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r3.ebuild b/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r3.ebuild
new file mode 100644
index 000000000000..b265bc6ee05c
--- /dev/null
+++ b/net-ftp/linksys-tftp/linksys-tftp-1.2.1-r3.ebuild
@@ -0,0 +1,29 @@
+# Copyright 1999-2015 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=5
+
+inherit eutils toolchain-funcs
+
+DESCRIPTION="TFTP client suitable for uploading to the Linksys WRT54G Wireless Router"
+HOMEPAGE="https://www.redsand.net/solutions/linksys_tftp.html"
+SRC_URI="https://www.redsand.net/solutions/${P}.tar.bz2"
+
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="amd64 ~ppc x86"
+IUSE=""
+
+src_prepare() {
+ epatch "${FILESDIR}"/${P}-r1-header.patch
+ epatch "${FILESDIR}"/${P}-r1-Makefile.patch
+}
+
+src_compile() {
+ emake CC="$(tc-getCC)"
+}
+
+src_install() {
+ dobin linksys-tftp
+ dodoc README
+}