summaryrefslogtreecommitdiff
path: root/net-ftp/ftpbase/ftpbase-0.01-r5.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-07-24 02:11:45 +0100
commitb49088575eb777ced2551f484da86317332d6087 (patch)
treebf9a151cf2d61956340d555659ffc098ee1da466 /net-ftp/ftpbase/ftpbase-0.01-r5.ebuild
parent514d1bbe260df2521fe60f1a3ec87cfcfde1a829 (diff)
gentoo resync : 24.07.2021
Diffstat (limited to 'net-ftp/ftpbase/ftpbase-0.01-r5.ebuild')
-rw-r--r--net-ftp/ftpbase/ftpbase-0.01-r5.ebuild39
1 files changed, 39 insertions, 0 deletions
diff --git a/net-ftp/ftpbase/ftpbase-0.01-r5.ebuild b/net-ftp/ftpbase/ftpbase-0.01-r5.ebuild
new file mode 100644
index 000000000000..526756b0ee02
--- /dev/null
+++ b/net-ftp/ftpbase/ftpbase-0.01-r5.ebuild
@@ -0,0 +1,39 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit pam
+
+DESCRIPTION="File Transfer Protocol (FTP) base layout"
+HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+S="${WORKDIR}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86"
+IUSE="pam zeroconf"
+
+DEPEND="
+ pam? ( sys-libs/pam )
+ zeroconf? ( net-dns/avahi )
+"
+
+RDEPEND="
+ acct-group/ftp
+ acct-user/ftp
+"
+
+src_install() {
+ # The ftpusers file is a list of people who are NOT allowed
+ # to use the ftp service.
+ insinto /etc
+ doins "${FILESDIR}/ftpusers"
+
+ use pam && newpamd "${FILESDIR}"/ftp-pamd-include ftp
+
+ if use zeroconf; then
+ insinto /etc/avahi/services
+ doins "${FILESDIR}/ftp.service"
+ fi
+}