summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-08-12 20:22:37 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-08-12 20:22:37 +0100
commitf8ca23f9f6e4a55e4195e553ca2f3e7dd425f51c (patch)
tree8268a378f27e1940a5a76b3c55abf6e4ee0fc256 /net-fs
parent7c68db06bb531670c1261374c0133d652b476bd7 (diff)
gentoo auto-resync : 12:08:2022 - 20:22:37
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/Manifest.gzbin3517 -> 3517 bytes
-rw-r--r--net-fs/nfs-utils/Manifest2
-rw-r--r--net-fs/nfs-utils/nfs-utils-2.6.2.ebuild228
3 files changed, 230 insertions, 0 deletions
diff --git a/net-fs/Manifest.gz b/net-fs/Manifest.gz
index 1a43421549c4..7acf6e28652e 100644
--- a/net-fs/Manifest.gz
+++ b/net-fs/Manifest.gz
Binary files differ
diff --git a/net-fs/nfs-utils/Manifest b/net-fs/nfs-utils/Manifest
index c7e852cd0462..48e173b84768 100644
--- a/net-fs/nfs-utils/Manifest
+++ b/net-fs/nfs-utils/Manifest
@@ -11,5 +11,7 @@ AUX rpc.pipefs.initd 760 BLAKE2B 4c05275e59d7d19d80779964a3631096258704cec2097f1
AUX rpc.statd.initd 706 BLAKE2B 6c175729706d298307deea1d190703e67edb671a6b2c86216658fc89dafff1ae9f85a25b5386e4c89b86ca1b7b1fce7bb3045f944b7a1aee5b6544594d753cf8 SHA512 7f6baea852fff91b88e15e432ba19f9da0a3e3510b6f550b553912cf3887ce176280367b62bcce2a044730a075e4c1f6d7df1a669556d42725dea6e6e8e967ac
AUX rpc.svcgssd.initd 470 BLAKE2B c610a7abc44b86ca242d59f833ffa6e42f48d1c3bf93420988c6c6dfcd5cc4d8e02eaf2f3a86bb8bca7c8952e05017f887e6c4f4290085c41cc095a580e04235 SHA512 819cce4ae0a0f26bc74ce546e149b98420584240a594c9bb4a0a49413750320bde050866f3753c499425ea8d8df094211fb1f7e020ce281791e1933e1bc6a47f
DIST nfs-utils-2.6.1.tar.bz2 946432 BLAKE2B fe6ec58b4c0def75a43f40a581a9d67d25ee2e6979f41da87453661b33460b99744e1799d6b1a3ef026027cafb1aae8a954cc6449d3eb77eee494fe72804751d SHA512 5b8949b3d30ccd33c9bc68875ba0993a22e490234d5eeebc189b3da2b1df0c290cd27d58226ffa5f4fe8b9548234fadb1c432b9c7d9b297c10a39fd2887d2f7f
+DIST nfs-utils-2.6.2.tar.bz2 969689 BLAKE2B 8e0a3b309223779824276acd3ede13cfc161b955dc9376cc9426ffe9c604b111f7405088fe8e5a88a2d2ac1413d2742fbdf166a5b04c975e51a9e384e071fa60 SHA512 6e5dcc5147ad551b2ecbf0304e1b0e0713d1eff32c5a511562a6d03660589e027364e38fc9f6de1b06d32d8907d502f63c564a6e56171f58823b0ea68dd3a6b8
EBUILD nfs-utils-2.6.1.ebuild 6052 BLAKE2B 6300335bff0c8714b88f68379fdf8f71c6d92f413452e0df1417f9ab99114adfc4619a28ebaafb0b99bb7c1fd6a162e50e3418feb966302a4643d97ea4c0d07b SHA512 2667edceb1d4bce5413da011e6169b652229722a95a1d24a58e788cf6c74fb20ace6ceed066e07e09449a3b5ab5543929a9d51c3e3aeb5c3d66f2662833324f6
+EBUILD nfs-utils-2.6.2.ebuild 6097 BLAKE2B 14c561596ecb167f2f2af87a1f61bfb64379ee2767b5d19438c8a60db38980da9b2adad11fd4d43d06b1cc541c36afbe53deff01763e196b088c5fe4726a249b SHA512 23dd2e493ddd42310a937c103c7ed683850b6e7f1bafea805d1bca96dc038da05a005360dbcde9d35711f5ab01c949a4f10c8b8e0d59664873ad7e81ee8b15a8
MISC metadata.xml 866 BLAKE2B 9bed3ad112962947235d7b03372ab0d0d8a35d57fee9500cc4cfe56dc4182634752878767a03760e06880862910b9c5e6abb91b174a624d1e72682bd6515abd3 SHA512 e7797d23c963836eb16bbea897c9ca761794308bb57e23dd10513e009a36d0ed6bf7e095975cf4f68c7f91ea5b6e9a89c1df1d301613383ef799c545e0c9ff3b
diff --git a/net-fs/nfs-utils/nfs-utils-2.6.2.ebuild b/net-fs/nfs-utils/nfs-utils-2.6.2.ebuild
new file mode 100644
index 000000000000..6a6968c458fd
--- /dev/null
+++ b/net-fs/nfs-utils/nfs-utils-2.6.2.ebuild
@@ -0,0 +1,228 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit autotools linux-info systemd
+
+DESCRIPTION="NFS client and server daemons"
+HOMEPAGE="http://linux-nfs.org/ https://git.linux-nfs.org/?p=steved/nfs-utils.git"
+
+if [[ ${PV} == *_rc* ]] ; then
+ MY_PV="$(ver_rs 1- -)"
+ SRC_URI="http://git.linux-nfs.org/?p=steved/nfs-utils.git;a=snapshot;h=refs/tags/${PN}-${MY_PV};sf=tgz -> ${P}.tar.gz"
+ S="${WORKDIR}/${PN}-${PN}-${MY_PV}"
+else
+ SRC_URI="mirror://sourceforge/nfs/${P}.tar.bz2"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+fi
+
+LICENSE="GPL-2"
+SLOT="0"
+IUSE="caps junction kerberos ldap +libmount nfsdcld +nfsidmap +nfsv4 nfsv41 sasl selinux tcpd +uuid"
+REQUIRED_USE="kerberos? ( nfsv4 )"
+# bug #315573
+RESTRICT="test"
+
+# kth-krb doesn't provide the right include
+# files, and nfs-utils doesn't build against heimdal either,
+# so don't depend on virtual/krb.
+# (04 Feb 2005 agriffis)
+COMMON_DEPEND="
+ dev-libs/libxml2
+ net-libs/libtirpc:=
+ >=net-nds/rpcbind-0.2.4
+ sys-fs/e2fsprogs
+ caps? ( sys-libs/libcap )
+ ldap? (
+ net-nds/openldap:=
+ sasl? (
+ app-crypt/mit-krb5
+ dev-libs/cyrus-sasl:2
+ )
+ )
+ libmount? ( sys-apps/util-linux )
+ nfsv4? (
+ dev-db/sqlite:3
+ dev-libs/libevent:=
+ >=sys-apps/keyutils-1.5.9:=
+ kerberos? (
+ >=net-libs/libtirpc-0.2.4-r1[kerberos]
+ app-crypt/mit-krb5
+ )
+ )
+ nfsv41? (
+ sys-fs/lvm2
+ )
+ tcpd? ( sys-apps/tcp-wrappers )
+ uuid? ( sys-apps/util-linux )"
+DEPEND="${COMMON_DEPEND}
+ elibc_musl? ( sys-libs/queue-standalone )
+"
+RDEPEND="${COMMON_DEPEND}
+ !net-libs/libnfsidmap
+ selinux? (
+ sec-policy/selinux-rpc
+ sec-policy/selinux-rpcbind
+ )
+"
+BDEPEND="
+ net-libs/rpcsvc-proto
+ virtual/pkgconfig
+"
+
+PATCHES=(
+ "${FILESDIR}"/${PN}-2.5.2-no-werror.patch
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if use nfsv4 && ! use nfsdcld && linux_config_exists && ! linux_chkconfig_present CRYPTO_MD5 ; then
+ ewarn "Your NFS server will be unable to track clients across server restarts!"
+ ewarn "Please enable the \"${HILITE}nfsdcld${NORMAL}\" USE flag to install the nfsdcltrack usermode"
+ ewarn "helper upcall program, or enable ${HILITE}CONFIG_CRYPTO_MD5${NORMAL} in your kernel to"
+ ewarn "support the legacy, in-kernel client tracker."
+ fi
+}
+
+src_prepare() {
+ default
+
+ sed \
+ -e "/^sbindir/s:= := \"${EPREFIX}\":g" \
+ -i utils/*/Makefile.am || die
+
+ eautoreconf
+}
+
+src_configure() {
+ # Our DEPEND forces this.
+ export libsqlite3_cv_is_recent=yes
+ export ac_cv_header_keyutils_h=$(usex nfsidmap)
+
+ # SASL is consumed in a purely automagic way
+ export ac_cv_header_sasl_h=no
+ export ac_cv_header_sasl_sasl_h=$(usex sasl)
+
+ local myeconfargs=(
+ --disable-static
+ --with-statedir="${EPREFIX}"/var/lib/nfs
+ --enable-tirpc
+ --with-tirpcinclude="${ESYSROOT}"/usr/include/tirpc/
+ --with-pluginpath="${EPREFIX}"/usr/$(get_libdir)/libnfsidmap
+ --with-rpcgen
+ --with-systemd="$(systemd_get_systemunitdir)"
+ --without-gssglue
+ $(use_enable caps)
+ --enable-ipv6
+ $(use_enable junction)
+ $(use_enable kerberos gss)
+ $(use_enable kerberos svcgss)
+ $(use_enable ldap)
+ $(use_enable libmount libmount-mount)
+ $(use_enable nfsdcld nfsdcltrack)
+ $(use_enable nfsv4)
+ $(use_enable nfsv41)
+ $(use_enable uuid)
+ $(use_with tcpd tcp-wrappers)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_compile() {
+ # Remove compiled files bundled in the tarball
+ emake clean
+
+ default
+}
+
+src_install() {
+ default
+ rm linux-nfs/Makefile* || die
+ dodoc -r linux-nfs README
+
+ # Don't overwrite existing xtab/etab, install the original
+ # versions somewhere safe... more info in pkg_postinst
+ keepdir /var/lib/nfs/{,sm,sm.bak}
+ mv "${ED}"/var/lib/nfs "${ED}"/usr/$(get_libdir)/ || die
+
+ # Install some client-side binaries in /sbin
+ dodir /sbin
+ mv "${ED}"/usr/sbin/rpc.statd "${ED}"/sbin/ || die
+
+ if use nfsv4 && use nfsidmap ; then
+ insinto /etc
+ doins support/nfsidmap/idmapd.conf
+
+ # Install a config file for idmappers in newer kernels. bug #415625
+ insinto /etc/request-key.d
+ echo 'create id_resolver * * /usr/sbin/nfsidmap -t 600 %k %d' > id_resolver.conf
+ doins id_resolver.conf
+ fi
+
+ insinto /etc
+ doins "${FILESDIR}"/exports
+ keepdir /etc/exports.d
+
+ local f list=() opt_need=""
+ if use nfsv4 ; then
+ opt_need="rpc.idmapd"
+ list+=( rpc.idmapd rpc.pipefs )
+ use kerberos && list+=( rpc.gssd rpc.svcgssd )
+ fi
+ for f in nfs nfsclient rpc.statd "${list[@]}" ; do
+ newinitd "${FILESDIR}"/${f}.initd ${f}
+ done
+
+ # Nuke after 2015/08/01
+ newinitd "${FILESDIR}"/nfsmount.initd-1.3.1 nfsmount
+ for f in nfs nfsclient ; do
+ newconfd "${FILESDIR}"/${f}.confd ${f}
+ done
+
+ # bug #234132
+ sed -i \
+ -e "/^NFS_NEEDED_SERVICES=/s:=.*:=\"${opt_need}\":" \
+ "${ED}"/etc/conf.d/nfs || die
+
+ local systemd_systemunitdir="$(systemd_get_systemunitdir)"
+ sed -i \
+ -e 's:/usr/sbin/rpc.statd:/sbin/rpc.statd:' \
+ "${ED}${systemd_systemunitdir}"/* || die
+
+ # bug #368505
+ keepdir /var/lib/nfs
+ # bug #603628
+ keepdir /var/lib/nfs/v4recovery
+
+ # No static archives
+ find "${ED}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ # Install default xtab and friends if there's none existing. In
+ # src_install we put them in /usr/lib/nfs for safe-keeping, but
+ # the daemons actually use the files in /var/lib/nfs. #30486
+ local f
+ for f in "${EROOT}"/usr/$(get_libdir)/nfs/*; do
+ [[ -e ${EROOT}/var/lib/nfs/${f##*/} ]] && continue
+ einfo "Copying default ${f##*/} from ${EPREFIX}/usr/$(get_libdir)/nfs to ${EPREFIX}/var/lib/nfs"
+ cp -pPR "${f}" "${EROOT}"/var/lib/nfs/
+ done
+
+ if systemd_is_booted; then
+ for v in ${REPLACING_VERSIONS}; do
+ if ver_test "${v}" -lt 1.3.0; then
+ ewarn "We have switched to upstream systemd unit files. Since"
+ ewarn "they got renamed, you should probably enable the new ones."
+ ewarn "You can run 'equery files nfs-utils | grep systemd'"
+ ewarn "to know what services you need to enable now."
+ fi
+ done
+ else
+ ewarn "If you use OpenRC, the nfsmount service has been replaced with nfsclient."
+ ewarn "If you were using nfsmount, please add nfsclient and netmount to the"
+ ewarn "same runlevel as nfsmount."
+ fi
+}