summaryrefslogtreecommitdiff
path: root/net-fs
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-29 03:06:05 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-29 03:06:05 +0100
commit66cd90d4284850abdf808a598a77040bcda88bd8 (patch)
tree3b4bd42297b8217b23f041cb09d7fe3832537e6c /net-fs
parent9403c20e10161812ed5231e7fd14464ca484aa09 (diff)
gentoo auto-resync : 29:07:2022 - 03:06:05
Diffstat (limited to 'net-fs')
-rw-r--r--net-fs/Manifest.gzbin3524 -> 3519 bytes
-rw-r--r--net-fs/cifs-utils/Manifest1
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild142
3 files changed, 143 insertions, 0 deletions
diff --git a/net-fs/Manifest.gz b/net-fs/Manifest.gz
index abae1c753eb8..2ed49ef073df 100644
--- a/net-fs/Manifest.gz
+++ b/net-fs/Manifest.gz
Binary files differ
diff --git a/net-fs/cifs-utils/Manifest b/net-fs/cifs-utils/Manifest
index 24a9f555f5d1..7a86a12c32cf 100644
--- a/net-fs/cifs-utils/Manifest
+++ b/net-fs/cifs-utils/Manifest
@@ -5,5 +5,6 @@ DIST cifs-utils-6.13-kerberos_mount_regression_fix.patch.xz 4336 BLAKE2B de268f8
DIST cifs-utils-6.13.tar.bz2 414584 BLAKE2B 5133ea39fc65acaf2a9791f8ac97dee681dd12f509e0abd095542ce663e7c62002b033dcf35f0a8eec214cb9940597fb568fd50d4cfe5271ca4e433afbe1a7bc SHA512 1337ac4b69f0c3e8d0241eb608207ba81dfa35f84c661649d25da78637882c4d73467b0f632be0bd120362e0b786e40eb340bffcf21c8a09629c441100fd10de
DIST cifs-utils-6.15.tar.bz2 416592 BLAKE2B 8af926bf255c5b3a66bf52ccca99632aacb9ed1c83ad7db5543b32df2f3bcd4be9a9cd17b744ec115d1568d07084e2bd2d03849aa9ab97cff2862f39bcf137b8 SHA512 eedb8066563db584595a8ba7cb7a603e6b763ac2c1261430d605c327fcc5a831acd48b58ea55dd243af778dfdc827ab8c6daf4015764ff550dcffc2182773510
EBUILD cifs-utils-6.13-r1.ebuild 3634 BLAKE2B 306cfc34bd2e8bab67f221bac8abcac52d5b57556f1e10ed3a9248ce83345d2269276e5727cc5f134af13431ff61b95ba9a3637dd4d91cb7ee2e51a8a0541223 SHA512 50d15605ff770799c16d8c0acc9b55199620f89ed1a62d7056e59da7359989174ccccca4fa18169219dd3dd72ecd1b429b733030245758232aec1c8b6e87655f
+EBUILD cifs-utils-6.15-r1.ebuild 3548 BLAKE2B 1f0eb28db9e991bc2bf810cd0f236ea2980593c48a2a3da2117524638e5c8c1828f710f1cec86ea242ae4fa2aaffdb701cb573940bbf027ffaab35685372c073 SHA512 4d01dd68cb3ce99e979fb313e892ab8bbf5400e6327ac5064a432e43ba04c71dafb9848b4717b76e72437b317a9eec9f20cba079f6ad972873e1927bb238082e
EBUILD cifs-utils-6.15.ebuild 3485 BLAKE2B 691f8b6be41701110de819a67f9fa064e693757bcb9ad99d17b0da7dae4ee2e176455da08f16adc324c11d3eb9ea2dba5aab077049d42832db85b9532e2ba59c SHA512 5381c672478fd3bf506272f1cda66b5bf0a8bb1fec2435c1f84bb74fc56a67f909dfcbd9fba8415e166a6f73edadbfc6c6c6afdcf774238e15d26adf4348af6c
MISC metadata.xml 967 BLAKE2B dc6654b412c77f2e95cad9cfa2d4e4465d3292b546d55ddc04ad1b3d5b8220bbe4ef0b0d1409fb2f5da99851d45567667935057f5d5c15dad4e2cf26e3ce0e00 SHA512 c6b0fbdd9d776695032cd4a3e109717dfa7cd07b1456da8264dc0688fcfa158d1f4a73758ee24ba318f14e7a321811bd24f688ca3c39156b304028566315b650
diff --git a/net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild b/net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild
new file mode 100644
index 000000000000..cb09a6056c8e
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-6.15-r1.ebuild
@@ -0,0 +1,142 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{8..11} )
+
+inherit autotools bash-completion-r1 linux-info pam python-single-r1
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="https://wiki.samba.org/index.php/LinuxCIFS_utils"
+SRC_URI="https://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="+acl +ads +caps creds pam +python systemd"
+
+RDEPEND="
+ ads? (
+ sys-apps/keyutils:=
+ sys-libs/talloc
+ virtual/krb5
+ )
+ caps? ( sys-libs/libcap-ng )
+ creds? ( sys-apps/keyutils:= )
+ pam? (
+ sys-apps/keyutils:=
+ sys-libs/pam
+ )
+ python? ( ${PYTHON_DEPS} )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/docutils"
+PDEPEND="
+ acl? ( >=net-fs/samba-4.0.0_alpha1 )
+"
+
+REQUIRED_USE="
+ acl? ( ads )
+ python? ( ${PYTHON_REQUIRED_USE} )
+"
+
+DOCS="doc/linux-cifs-client-guide.odt"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-6.12-ln_in_destdir.patch" #766594
+ "${FILESDIR}/${PN}-6.15-musl.patch"
+)
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+
+ use python && python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if has_version app-crypt/heimdal ; then
+ # https://bugs.gentoo.org/612584
+ eapply "${FILESDIR}/${PN}-6.7-heimdal.patch"
+ fi
+
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-man
+ --enable-smbinfo
+ $(use_enable acl cifsacl cifsidmap)
+ $(use_enable ads cifsupcall)
+ $(use_with caps libcap)
+ $(use_enable creds cifscreds)
+ $(use_enable pam)
+ $(use_with pam pamdir $(getpam_mod_dir))
+ $(use_enable python pythontools)
+ # mount.cifs can get passwords from systemd
+ $(use_enable systemd)
+ )
+ ROOTSBINDIR="${EPREFIX}"/sbin \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # remove empty directories
+ find "${ED}" -type d -empty -delete || die
+
+ if use acl ; then
+ dodir /etc/cifs-utils
+ dosym ../../usr/$(get_libdir)/cifs-utils/idmapwb.so \
+ /etc/cifs-utils/idmap-plugin
+ dodir /etc/request-key.d
+ echo 'create cifs.idmap * * /usr/sbin/cifs.idmap %k' \
+ > "${ED}/etc/request-key.d/cifs.idmap.conf"
+ fi
+
+ if use ads ; then
+ dodir /etc/request-key.d
+ echo 'create dns_resolver * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.upcall.conf"
+ echo 'create cifs.spnego * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.spnego.conf"
+ fi
+
+ dobashcomp bash-completion/smbinfo
+ use python && python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use acl ; then
+ einfo "The cifs.idmap utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.idmap.conf"
+ einfo "This enables you to get and set CIFS acls."
+ fi
+
+ if use ads ; then
+ einfo "The cifs.upcall utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.upcall.conf"
+ einfo "This enables you to mount DFS shares."
+ fi
+}