summaryrefslogtreecommitdiff
path: root/net-fs/s3ql/s3ql-2.32.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
committerV3n3RiX <venerix@redcorelinux.org>2018-12-24 14:11:38 +0000
commitde49812990871e1705b64051c35161d5e6400269 (patch)
tree5e1e8fcb0ff4579dbd22a1bfee28a6b97dc8aaeb /net-fs/s3ql/s3ql-2.32.ebuild
parent536c3711867ec947c1738f2c4b96f22e4863322d (diff)
gentoo resync : 24.12.2018
Diffstat (limited to 'net-fs/s3ql/s3ql-2.32.ebuild')
-rw-r--r--net-fs/s3ql/s3ql-2.32.ebuild55
1 files changed, 55 insertions, 0 deletions
diff --git a/net-fs/s3ql/s3ql-2.32.ebuild b/net-fs/s3ql/s3ql-2.32.ebuild
new file mode 100644
index 000000000000..1465df4ec788
--- /dev/null
+++ b/net-fs/s3ql/s3ql-2.32.ebuild
@@ -0,0 +1,55 @@
+# Copyright 1999-2018 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+PYTHON_COMPAT=( python3_{4,5,6} )
+
+inherit distutils-r1
+
+DESCRIPTION="A full-featured file system for online data storage"
+HOMEPAGE="https://bitbucket.org/nikratio/s3ql/"
+SRC_URI="https://www.bitbucket.org/nikratio/s3ql/downloads/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="contrib doc systemd test"
+
+RDEPEND=">=dev-db/sqlite-3.7.0:3
+ dev-python/defusedxml[${PYTHON_USEDEP}]
+ dev-python/setuptools[${PYTHON_USEDEP}]
+ >=dev-python/apsw-3.7.0[${PYTHON_USEDEP}]
+ >=dev-python/dugong-3.4[${PYTHON_USEDEP}]
+ >=dev-python/llfuse-1.0[${PYTHON_USEDEP}]
+ dev-python/pycrypto[${PYTHON_USEDEP}]
+ dev-python/requests[${PYTHON_USEDEP}]
+ sys-fs/fuse:0
+ systemd? ( dev-python/python-systemd[${PYTHON_USEDEP}] )"
+DEPEND="${RDEPEND}
+ test? (
+ dev-python/pytest[${PYTHON_USEDEP}]
+ net-misc/rsync[xattr]
+ )"
+
+RESTRICT="test"
+
+python_test() {
+ addwrite /dev/fuse
+ py.test -v tests || die "Tests fail with ${EPYTHON}"
+}
+
+python_install_all() {
+ distutils-r1_python_install_all
+
+ if use contrib ; then
+ exeinto /usr/share/doc/${PF}/contrib
+ docompress -x /usr/share/doc/${PF}/contrib
+ doexe contrib/*.{py,sh}
+ doman contrib/*.1
+ fi
+
+ if use doc ; then
+ dodoc doc/manual.pdf
+ dodoc -r doc/html
+ fi
+}