summaryrefslogtreecommitdiff
path: root/net-fs/openafs/openafs-1.8.7.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
committerV3n3RiX <venerix@koprulu.sector>2022-01-07 22:48:01 +0000
commitc3bc61051d7f12b4c682efa7a5460bbc8815649e (patch)
treeb6d19e96ba3c397fb8278eeb9b68170db92630ba /net-fs/openafs/openafs-1.8.7.ebuild
parent3517852e3b8a68d1e997770fc0650c5053bafc6c (diff)
gentoo resync : 07.01.2022
Diffstat (limited to 'net-fs/openafs/openafs-1.8.7.ebuild')
-rw-r--r--net-fs/openafs/openafs-1.8.7.ebuild9
1 files changed, 1 insertions, 8 deletions
diff --git a/net-fs/openafs/openafs-1.8.7.ebuild b/net-fs/openafs/openafs-1.8.7.ebuild
index f2f6237fddcc..8d42811d43cf 100644
--- a/net-fs/openafs/openafs-1.8.7.ebuild
+++ b/net-fs/openafs/openafs-1.8.7.ebuild
@@ -1,4 +1,4 @@
-# Copyright 1999-2021 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
EAPI=7
@@ -127,8 +127,6 @@ src_configure() {
fi
myconf+=( --with-linux-kernel-headers="${KV_DIR}" \
--with-linux-kernel-build="${KV_OUT_DIR}" )
- elif use kernel_FreeBSD; then
- myconf+=( --with-bsd-kernel-build="${BSD_BUILD_DIR}" )
fi
fi
@@ -187,9 +185,6 @@ src_install() {
MODULE_NAMES="libafs(fs/openafs:${srcdir})"
linux-mod_src_install
- elif use kernel_FreeBSD; then
- insinto /boot/modules
- doins "${S}"/src/libafs/MODLOAD/libafs.ko
fi
fi
@@ -286,7 +281,6 @@ pkg_preinst() {
pkg_postinst() {
if use modules; then
# Update linker.hints file
- use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
use kernel_linux && linux-mod_pkg_postinst
fi
@@ -309,7 +303,6 @@ pkg_postinst() {
pkg_postrm() {
if use modules; then
# Update linker.hints file
- use kernel_FreeBSD && /usr/sbin/kldxref "${EPREFIX}/boot/modules"
use kernel_linux && linux-mod_pkg_postrm
fi
}