summaryrefslogtreecommitdiff
path: root/net-fs/libnfs/libnfs-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /net-fs/libnfs/libnfs-9999.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'net-fs/libnfs/libnfs-9999.ebuild')
-rw-r--r--net-fs/libnfs/libnfs-9999.ebuild20
1 files changed, 12 insertions, 8 deletions
diff --git a/net-fs/libnfs/libnfs-9999.ebuild b/net-fs/libnfs/libnfs-9999.ebuild
index 2736936d4bfc..c586e1123012 100644
--- a/net-fs/libnfs/libnfs-9999.ebuild
+++ b/net-fs/libnfs/libnfs-9999.ebuild
@@ -1,31 +1,32 @@
-# Copyright 1999-2020 Gentoo Authors
+# Copyright 1999-2022 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=6
+EAPI=7
inherit autotools
-if [[ ${PV} == "9999" ]] ; then
+if [[ ${PV} == 9999 ]] ; then
inherit git-r3
EGIT_REPO_URI="https://github.com/sahlberg/${PN}.git"
else
SRC_URI="https://github.com/sahlberg/${PN}/archive/${P}.tar.gz"
- KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~x86"
- S="${WORKDIR}/${PN}-${P}"
+ KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~x86"
+ S="${WORKDIR}"/${PN}-${P}
fi
DESCRIPTION="Client library for accessing NFS shares over a network"
HOMEPAGE="https://github.com/sahlberg/libnfs"
LICENSE="LGPL-2.1 GPL-3"
-SLOT="0/13" # sub-slot matches SONAME major
+SLOT="0/14" # sub-slot matches SONAME major
IUSE="examples static-libs utils"
-RDEPEND=""
-DEPEND="${RDEPEND}
+# net-libs/rpcsvc-proto for rpcgen called in build system
+BDEPEND="net-libs/rpcsvc-proto
virtual/pkgconfig"
src_prepare() {
default
+
eautoreconf
}
@@ -35,11 +36,13 @@ src_configure() {
$(use_enable static-libs static)
$(use_enable utils)
)
+
econf "${myeconfargs[@]}"
}
src_install() {
default
+
if use examples; then
# --enable-examples configure switch just compiles them
# better install sources instead
@@ -48,5 +51,6 @@ src_install() {
doexe examples/${program}.c
done
fi
+
find "${ED}" -name "*.la" -delete || die
}