summaryrefslogtreecommitdiff
path: root/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-10-13 22:19:36 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-10-14 23:22:23 +0100
commit4b19be30aa626b327c885dae62c559ec0e9fb935 (patch)
tree76e74807bc479502e13866b581b6bf86734ec634 /net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
parent30d6f67c98d149508509d5e86f176d558793acc0 (diff)
gentoo resync : 13.10.2019
Diffstat (limited to 'net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild')
-rw-r--r--net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild44
1 files changed, 44 insertions, 0 deletions
diff --git a/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild b/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
new file mode 100644
index 000000000000..04a3efebf10f
--- /dev/null
+++ b/net-fs/curlftpfs/curlftpfs-0.9.2-r4.ebuild
@@ -0,0 +1,44 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools
+
+DESCRIPTION="File system for accessing ftp hosts based on FUSE"
+HOMEPAGE="http://curlftpfs.sourceforge.net/"
+SRC_URI="mirror://sourceforge/${PN}/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~x86 ~amd64-linux ~x86-linux ~x86-macos"
+IUSE=""
+RESTRICT="test" # bug 258460
+
+RDEPEND=">=net-misc/curl-7.17.0
+ >=sys-fs/fuse-2.2:0=
+ >=dev-libs/glib-2.0"
+DEPEND="${RDEPEND}
+ virtual/pkgconfig"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-64bit_filesize.patch
+ "${FILESDIR}"/${PN}-0.9.2-darwin.patch
+ "${FILESDIR}"/${PN}-0.9.2-memleak.patch
+ "${FILESDIR}"/${PN}-0.9.2-memleak-nocache.patch
+ "${FILESDIR}"/${PN}-0.9.2-fix-escaping.patch
+)
+
+src_prepare() {
+ default
+
+ # automake-1.13.1 obsoletes AM_* bit #469818
+ sed -i -e 's/AM_CONFIG_HEADER/AC_CONFIG_HEADERS/' configure.ac || die
+
+ eautoreconf
+}
+
+src_install() {
+ default
+ dodoc README
+}