summaryrefslogtreecommitdiff
path: root/net-fs/cifs-utils
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-22 20:28:19 +0000
commitabaa75b10f899ada8dd05b23cc03205064394bc6 (patch)
treeeca3dd248b73b92013cba00a0fcc1edf2696e19a /net-fs/cifs-utils
parent24fd814c326e282c4321965c31f341dad77e270d (diff)
gentoo resync : 22.01.2021
Diffstat (limited to 'net-fs/cifs-utils')
-rw-r--r--net-fs/cifs-utils/Manifest2
-rw-r--r--net-fs/cifs-utils/cifs-utils-6.12.ebuild131
2 files changed, 133 insertions, 0 deletions
diff --git a/net-fs/cifs-utils/Manifest b/net-fs/cifs-utils/Manifest
index e19667521b9a..0d3ac8392dd0 100644
--- a/net-fs/cifs-utils/Manifest
+++ b/net-fs/cifs-utils/Manifest
@@ -1,5 +1,7 @@
AUX cifs-utils-6.10-ln_in_destdir.patch 813 BLAKE2B 71ac0215407a2350c19a15545d96f77115357c04bbcae2d1e09b7fbe54fd344d40638d3778195865eff3f9686b1fa9a0a13e188fdd4cc3d25c7a100fc5c376a1 SHA512 f9ccbd0d4d14cde1d07cc165533c51cc2876ed65e651a797a8b7c69958f6ee827090731888cbc425aecbb879b41e87a0e9ed1fce6817e1907cc7b114c53b8fc9
AUX cifs-utils-6.7-heimdal.patch 904 BLAKE2B de816117010e71ced5ad094e8ed3537b672b37a0e8ac0b999aa7aaf180ac051f6745ee68373948b266ad359e1ba3b58552eda6314b5a4339673bd04656ab6090 SHA512 e3364e05fba6aff57ea2f09b530692f4f5ec95213e91794388fff9382d210db9bacb28dae1440d3b35a570c0b3bc21084a067e0ce8333febd5246c52aa9260ae
DIST cifs-utils-6.11.tar.bz2 408903 BLAKE2B 5ee7cd87b54a266750bf938396ee90b3f20c2a3446aca295ccb58cb667fbfb68be9aa0e2bbc20aa5e18ffd7f1fcd5fbb0aef3bc25fd13bb96abc5a57a0b45b4b SHA512 064c0ac75572fb44908390508462e4fdfe0686751149fd8b656a209dd961a5a24a7d9774c38c0e72fa5f9875b43aea7bf2de038c4e4a63a11664e71d9003100e
+DIST cifs-utils-6.12.tar.bz2 413393 BLAKE2B 54d9f8cc5c7aac8157baac4bd0f742fea27f7141adc183a99ba276888b6aa8ec87150983cfa677ebd96bcfe8a019038199fef8dfe464c82bbdbaf07c0a7b35dd SHA512 2f2e1cba8d56c9039fc28236fa63812a09f07f14931c3bd7bd5ae3e6aeb372130c5a059569d8714fb973bea87eba394fd30228fbaeabe700961bba400dd01ca6
EBUILD cifs-utils-6.11.ebuild 3212 BLAKE2B a87a72d144e834998197802c23e3ad2c8f94f10fb54adc5654b1cde63d0a13104e3993ff250df710c710e5b0873a55fa823b7baa75f3f0fc04871ee32a56b50c SHA512 a4a06f59ae9f0c37c0084df205345647d1e9803e5973b54922803c5c8016607940669ed5a23ca11ae52fcef01a08d6da9c53bd809c2bc29807a357e4962941b3
+EBUILD cifs-utils-6.12.ebuild 3288 BLAKE2B 9c9f48ab61545db5621b85b258470a984af9a09026032f4fb574dd5a5ed9f6b1a9b730ae718c4d329ae6de5a1e2d336e464fd1a17ab16b99ba39596511c8e10c SHA512 f862cbe67782e187b2a2db57a1554cde4aad2ec288ac5fb49f682f891f50285e958a8598e90f6b77f01345f4a72f517cdf6d407faeda4010a28880e637600305
MISC metadata.xml 886 BLAKE2B 2ddb0ff3b0da3392b23743f3804c1d63651904c05a17e69f105c7b062d33befca62a13a1a93f631b314143a60bca8e2b20ec9b331646f0e6804a2f8cfce3bb81 SHA512 36019a5885034309e16198a154fc0fc16de2ff507eec81f4d63840bf56e9f67cf67dbf4ba7662a6f64daeb17541604d5f588ec67cca134b7ff07e0612817072b
diff --git a/net-fs/cifs-utils/cifs-utils-6.12.ebuild b/net-fs/cifs-utils/cifs-utils-6.12.ebuild
new file mode 100644
index 000000000000..f7fa30ad0e46
--- /dev/null
+++ b/net-fs/cifs-utils/cifs-utils-6.12.ebuild
@@ -0,0 +1,131 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+PYTHON_COMPAT=( python3_{6..9} )
+
+inherit bash-completion-r1 linux-info multilib pam python-single-r1
+
+DESCRIPTION="Tools for Managing Linux CIFS Client Filesystems"
+HOMEPAGE="https://wiki.samba.org/index.php/LinuxCIFS_utils"
+SRC_URI="https://ftp.samba.org/pub/linux-cifs/${PN}/${P}.tar.bz2"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~s390 ~sparc ~x86 ~x86-linux"
+IUSE="+acl +ads +caps creds pam systemd"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ !net-fs/mount-cifs
+ sys-apps/keyutils:=
+ ads? (
+ sys-libs/talloc
+ virtual/krb5
+ )
+ caps? ( sys-libs/libcap-ng )
+ pam? ( sys-libs/pam )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="dev-python/docutils"
+PDEPEND="
+ acl? ( >=net-fs/samba-4.0.0_alpha1 )
+"
+
+REQUIRED_USE="
+ acl? ( ads )
+ ${PYTHON_REQUIRED_USE}
+"
+
+DOCS="doc/linux-cifs-client-guide.odt"
+
+pkg_setup() {
+ linux-info_pkg_setup
+
+ if ! linux_config_exists || ! linux_chkconfig_present CIFS; then
+ ewarn "You must enable CIFS support in your kernel config, "
+ ewarn "to be able to mount samba shares. You can find it at"
+ ewarn
+ ewarn " File systems"
+ ewarn " Network File Systems"
+ ewarn " CIFS support"
+ ewarn
+ ewarn "and recompile your kernel ..."
+ fi
+
+ python-single-r1_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ if has_version app-crypt/heimdal ; then
+ # https://bugs.gentoo.org/612584
+ eapply "${FILESDIR}/${PN}-6.7-heimdal.patch"
+ fi
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-man
+ --enable-smbinfo
+ $(use_enable acl cifsacl cifsidmap)
+ $(use_enable ads cifsupcall)
+ $(use_with caps libcap)
+ $(use_enable creds cifscreds)
+ $(use_enable pam)
+ $(use_with pam pamdir $(getpam_mod_dir))
+ # mount.cifs can get passwords from systemd
+ $(use_enable systemd)
+ )
+ ROOTSBINDIR="${EPREFIX}"/sbin \
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+
+ # remove empty directories
+ find "${ED}" -type d -empty -delete || die
+
+ if use acl ; then
+ dodir /etc/cifs-utils
+ dosym ../../usr/$(get_libdir)/cifs-utils/idmapwb.so \
+ /etc/cifs-utils/idmap-plugin
+ dodir /etc/request-key.d
+ echo 'create cifs.idmap * * /usr/sbin/cifs.idmap %k' \
+ > "${ED}/etc/request-key.d/cifs.idmap.conf"
+ fi
+
+ if use ads ; then
+ dodir /etc/request-key.d
+ echo 'create dns_resolver * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.upcall.conf"
+ echo 'create cifs.spnego * * /usr/sbin/cifs.upcall %k' \
+ > "${ED}/etc/request-key.d/cifs.spnego.conf"
+ fi
+
+ dobashcomp bash-completion/smbinfo
+ python_fix_shebang "${ED}"
+}
+
+pkg_postinst() {
+ # Inform about set-user-ID bit of mount.cifs
+ ewarn "setuid use flag was dropped due to multiple security implications"
+ ewarn "such as CVE-2009-2948, CVE-2011-3585 and CVE-2012-1586"
+ ewarn "You are free to set setuid flags by yourself"
+
+ # Inform about upcall usage
+ if use acl ; then
+ einfo "The cifs.idmap utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.idmap.conf"
+ einfo "This enables you to get and set CIFS acls."
+ fi
+
+ if use ads ; then
+ einfo "The cifs.upcall utility has been enabled by creating the"
+ einfo "configuration file /etc/request-key.d/cifs.upcall.conf"
+ einfo "This enables you to mount DFS shares."
+ fi
+}