summaryrefslogtreecommitdiff
path: root/net-firewall
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-02-19 23:39:38 +0000
committerV3n3RiX <venerix@koprulu.sector>2024-02-19 23:39:38 +0000
commitcc5ddec0bbae3bf2151f62ef22d19b5e85cb8f35 (patch)
tree0ecbd113fafef1c07a494eb72954a4768ea4040a /net-firewall
parent9aa795a0179b29f7489bd04584bc8d2914da467b (diff)
gentoo auto-resync : 19:02:2024 - 23:39:38
Diffstat (limited to 'net-firewall')
-rw-r--r--net-firewall/Manifest.gzbin4227 -> 4232 bytes
-rw-r--r--net-firewall/firewalld/Manifest1
-rw-r--r--net-firewall/firewalld/firewalld-2.1.1-r1.ebuild226
3 files changed, 227 insertions, 0 deletions
diff --git a/net-firewall/Manifest.gz b/net-firewall/Manifest.gz
index 3a9780f45011..7a57335c55a8 100644
--- a/net-firewall/Manifest.gz
+++ b/net-firewall/Manifest.gz
Binary files differ
diff --git a/net-firewall/firewalld/Manifest b/net-firewall/firewalld/Manifest
index 88d24c091650..5a4f567b8d14 100644
--- a/net-firewall/firewalld/Manifest
+++ b/net-firewall/firewalld/Manifest
@@ -7,5 +7,6 @@ DIST firewalld-2.1.1.tar.bz2 1315222 BLAKE2B 064abfae1f2f1c5a63bbbbbec3357aa6e63
EBUILD firewalld-2.0.1.ebuild 5302 BLAKE2B fdf5cc70bfa92850dc4cd9c50e58d4788dd9a3eb8a4b16640692bc2ecb4d3def741b694fb29bf60eb825c895b2bdc210e26475bf2cca4bbfe26f949d4b091c40 SHA512 70f80a9ee29a2470433734e21aa92f3713fe4eacc978f4d43d86810f09ec0494c21611d2a0dbeb113fa59026796f0709f1c0ca269d0c937ae4466a71cf1d282b
EBUILD firewalld-2.0.2.ebuild 5300 BLAKE2B ebbbf837a1ae24aed8b6096061167c14253a8f66a56b68356959a09d733659f128d29c76b475b08531fb2dd04dc8d7dfa13b7ad006f90794efd4974892664391 SHA512 b71fe161461fc6ff2985659d8fc576d510fc644a873e0a91951cc38fbee6849b8e37907ebd9cb1eb3a899bdceb922941528608f3e5dc2d760c77e947515ab1fc
EBUILD firewalld-2.1.0.ebuild 5308 BLAKE2B a61bd2c9f71a13bca32e1f4d5dca2f237127764e718ace67a25511b8d1e3816f0b53193c01943af49d74d6d48dd3df2ca1f228a84d0da885a2b1710d011facc5 SHA512 709018d8666f2872b62488a2526831a0589a9a3bb093acc3aac03fb3f879513673c7387151a9578ceb2cd6ab80273a6aed45b06e11759d8f8a89a6b41b6cad80
+EBUILD firewalld-2.1.1-r1.ebuild 5469 BLAKE2B efee69322f4703fa0d1383dab865a769a4be0ab9b5d2f40df42f10acdda69d082a9196d58a2482c4326f852bef56f61a33bbaba9105597aa3d8b74d3337c7f11 SHA512 865c6b1c8d3aa7d33962353d5db77216a47b08f4fd4b06f282bebf2e79f1c18cfb8f1a37c7c70d5531e86b7dc037e0f8180721e1b2ab193c10195f1dbbeaf477
EBUILD firewalld-2.1.1.ebuild 5311 BLAKE2B eb44f2244e6354caef54101355396cb082578105cb1c7c6b16f05db2064ada650858b46c55f9ee36ed36fec78a6406bc7a7a732e64a363300fcb231e8b75ca0b SHA512 3c4eee1ccb09207b9c338d2973cdce4e3e6d3e99dfb9b3d187e53760a9ba585fe9a72f15a7d9f8c73c24a74b60ab5ce3bec62691f5e6401eabba336c2976595d
MISC metadata.xml 671 BLAKE2B 69c4bda7cc74a243aa1738bed90d16a3bc2c2085f6c0718becc7797a68da63035ef4d4f5e59c0583987d54032c163df6052d012fb7ca49026ca7259088793d33 SHA512 dd2d482251a4e33cb12ba324e1a21b4758f82de83c0cf83d5fa6259444c272360b47c5666e596103eba4703183fc9864a6bbb07a254aba67146b89d9870e9bbe
diff --git a/net-firewall/firewalld/firewalld-2.1.1-r1.ebuild b/net-firewall/firewalld/firewalld-2.1.1-r1.ebuild
new file mode 100644
index 000000000000..3470957cccc8
--- /dev/null
+++ b/net-firewall/firewalld/firewalld-2.1.1-r1.ebuild
@@ -0,0 +1,226 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+PYTHON_COMPAT=( python3_{10..11} )
+inherit bash-completion-r1 gnome2-utils linux-info optfeature
+inherit plocale python-single-r1 systemd xdg-utils
+
+DESCRIPTION="Firewall daemon with D-Bus interface providing a dynamic firewall"
+HOMEPAGE="https://firewalld.org/"
+SRC_URI="https://github.com/firewalld/firewalld/releases/download/v${PV}/${P}.tar.bz2"
+
+LICENSE="GPL-2+"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc64 ~riscv ~x86"
+IUSE="gui +nftables +iptables test"
+# Tests are too unreliable in sandbox environment
+RESTRICT="!test? ( test ) test"
+REQUIRED_USE="${PYTHON_REQUIRED_USE}"
+
+RDEPEND="
+ ${PYTHON_DEPS}
+ || ( >=sys-apps/openrc-0.11.5 sys-apps/systemd )
+ $(python_gen_cond_dep '
+ dev-python/dbus-python[${PYTHON_USEDEP}]
+ dev-python/pygobject:3[${PYTHON_USEDEP}]
+ gui? (
+ x11-libs/gtk+:3
+ dev-python/PyQt5[gui,widgets,${PYTHON_USEDEP}]
+ )
+ nftables? ( >=net-firewall/nftables-0.9.4[python,json] )
+ ')
+ iptables? (
+ net-firewall/iptables[ipv6(+)]
+ net-firewall/ebtables
+ net-firewall/ipset
+ nftables? ( net-firewall/nftables[xtables(+)] )
+ )
+"
+DEPEND="
+ ${RDEPEND}
+ dev-libs/glib:2
+"
+BDEPEND="
+ app-text/docbook-xml-dtd
+ >=dev-util/intltool-0.35
+ sys-devel/gettext
+"
+
+# Testsuite's Makefile.am calls missing(!)
+# ... but this seems to be consistent with the autoconf docs?
+# Needs more investigation: https://www.gnu.org/software/autoconf/manual/autoconf-2.67/html_node/autom4te-Invocation.html
+QA_AM_MAINTAINER_MODE=".*--run autom4te --language=autotest.*"
+
+PLOCALES="ar as ast bg bn_IN ca cs da de el en_GB en_US es et eu fa fi fr gl gu hi hr hu ia id it ja ka kn ko lt ml mr nl or pa pl pt pt_BR ro ru si sk sl sq sr sr@latin sv ta te tr uk zh_CN zh_TW"
+
+pkg_setup() {
+ # See bug #830132 for the huge list
+ # We can probably narrow it down a bit but it's rather fragile
+ local CONFIG_CHECK="~NF_CONNTRACK ~NETFILTER_XT_MATCH_CONNTRACK
+ ~NETFILTER
+ ~NETFILTER_ADVANCED
+ ~NETFILTER_INGRESS
+ ~NF_NAT_MASQUERADE
+ ~NF_NAT_REDIRECT
+ ~NF_TABLES_INET
+ ~NF_TABLES_IPV4
+ ~NF_TABLES_IPV6
+ ~NF_CONNTRACK
+ ~NF_CONNTRACK_BROADCAST
+ ~NF_CONNTRACK_NETBIOS_NS
+ ~NF_CONNTRACK_TFTP
+ ~NF_CT_NETLINK
+ ~NF_CT_NETLINK_HELPER
+ ~NF_DEFRAG_IPV4
+ ~NF_DEFRAG_IPV6
+ ~NF_NAT
+ ~NF_NAT_TFTP
+ ~NF_REJECT_IPV4
+ ~NF_REJECT_IPV6
+ ~NF_SOCKET_IPV4
+ ~NF_SOCKET_IPV6
+ ~NF_TABLES
+ ~NF_TPROXY_IPV4
+ ~NF_TPROXY_IPV6
+ ~IP_NF_FILTER
+ ~IP_NF_IPTABLES
+ ~IP_NF_MANGLE
+ ~IP_NF_NAT
+ ~IP_NF_RAW
+ ~IP_NF_SECURITY
+ ~IP_NF_TARGET_MASQUERADE
+ ~IP_NF_TARGET_REJECT
+ ~IP6_NF_FILTER
+ ~IP6_NF_IPTABLES
+ ~IP6_NF_MANGLE
+ ~IP6_NF_NAT
+ ~IP6_NF_RAW
+ ~IP6_NF_SECURITY
+ ~IP6_NF_TARGET_MASQUERADE
+ ~IP6_NF_TARGET_REJECT
+ ~IP_SET
+ ~NETFILTER_CONNCOUNT
+ ~NETFILTER_NETLINK
+ ~NETFILTER_NETLINK_OSF
+ ~NETFILTER_NETLINK_QUEUE
+ ~NETFILTER_SYNPROXY
+ ~NETFILTER_XTABLES
+ ~NETFILTER_XT_CONNMARK
+ ~NETFILTER_XT_MATCH_CONNTRACK
+ ~NETFILTER_XT_MATCH_MULTIPORT
+ ~NETFILTER_XT_MATCH_STATE
+ ~NETFILTER_XT_NAT
+ ~NETFILTER_XT_TARGET_MASQUERADE
+ ~NFT_COMPAT
+ ~NFT_CT
+ ~NFT_FIB
+ ~NFT_FIB_INET
+ ~NFT_FIB_IPV4
+ ~NFT_FIB_IPV6
+ ~NFT_HASH
+ ~NFT_LIMIT
+ ~NFT_LOG
+ ~NFT_MASQ
+ ~NFT_NAT
+ ~NFT_OBJREF
+ ~NFT_QUEUE
+ ~NFT_QUOTA
+ ~NFT_REDIR
+ ~NFT_REJECT
+ ~NFT_REJECT_INET
+ ~NFT_REJECT_IPV4
+ ~NFT_REJECT_IPV6
+ ~NFT_SOCKET
+ ~NFT_SYNPROXY
+ ~NFT_TPROXY
+ ~NFT_TUNNEL
+ ~NFT_XFRM"
+
+ # kernel >= 4.19 has unified a NF_CONNTRACK module, bug #692944
+ if kernel_is -lt 4 19; then
+ CONFIG_CHECK+=" ~NF_CONNTRACK_IPV4 ~NF_CONNTRACK_IPV6"
+ fi
+
+ # bug #831259
+ if kernel_is -le 5 4 ; then
+ CONFIG_CHECK+=" ~NF_TABLES_SET"
+ fi
+
+ # bug #853055
+ if kernel_is -lt 5 18 ; then
+ CONFIG_CHECK+=" ~NFT_COUNTER"
+ fi
+
+ linux-info_pkg_setup
+}
+
+src_prepare() {
+ default
+
+ plocale_find_changes "po" "" ".po" || die
+ plocale_get_locales | sed -e 's/ /\n/g' > po/LINGUAS
+
+ # Our version drops the/an obsolete 'conflicts' line with old iptables services
+ # bug #833506
+ sed -i \
+ -e "/Conflicts=iptables.service ip6tables.service ebtables.service ipset.service nftables.service/d" \
+ -e "/EnvironmentFile=-\/etc\/sysconfig\/firewalld/d" \
+ config/firewalld.service.in || die
+}
+
+src_configure() {
+ python_setup
+
+ local myeconfargs=(
+ --enable-systemd
+ $(use_with iptables iptables "${EPREFIX}/sbin/iptables")
+ $(use_with iptables iptables_restore "${EPREFIX}/sbin/iptables-restore")
+ $(use_with iptables ip6tables "${EPREFIX}/sbin/ip6tables")
+ $(use_with iptables ip6tables_restore "${EPREFIX}/sbin/ip6tables-restore")
+ $(use_with iptables ebtables "${EPREFIX}/sbin/ebtables")
+ $(use_with iptables ebtables_restore "${EPREFIX}/sbin/ebtables-restore")
+ $(use_with iptables ipset "${EPREFIX}/usr/sbin/ipset")
+ --with-systemd-unitdir="$(systemd_get_systemunitdir)"
+ --with-bashcompletiondir="$(get_bashcompdir)"
+ )
+
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ default
+ python_optimize
+
+ # Get rid of junk
+ rm -rf "${D}/etc/sysconfig/" || die
+
+ # For non-gui installs we need to remove GUI bits
+ if ! use gui; then
+ rm -rf "${D}/etc/xdg/autostart" || die
+ rm -f "${D}/usr/bin/firewall-applet" || die
+ rm -f "${D}/usr/bin/firewall-config" || die
+ rm -rf "${D}/usr/share/applications" || die
+ rm -rf "${D}/usr/share/icons" || die
+ fi
+
+ newinitd "${FILESDIR}"/firewalld.init firewalld
+}
+
+pkg_preinst() {
+ gnome2_schemas_savelist
+}
+
+pkg_postinst() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+
+ # bug #833569
+ optfeature "changing zones with NetworkManager" gnome-extra/nm-applet
+}
+
+pkg_postrm() {
+ xdg_icon_cache_update
+ gnome2_schemas_update
+}