summaryrefslogtreecommitdiff
path: root/net-firewall/rtsp-conntrack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
committerV3n3RiX <venerix@koprulu.sector>2024-06-03 00:07:26 +0100
commita3bb28551df94028000fb72308a9e9baa01458b0 (patch)
tree33b14c7bf0dffbd5bb04dbd5b395514ebdda4896 /net-firewall/rtsp-conntrack
parent6657c680376cedf378fcf328e5fa03ed3b41d580 (diff)
gentoo auto-resync : 03:06:2024 - 00:07:25
Diffstat (limited to 'net-firewall/rtsp-conntrack')
-rw-r--r--net-firewall/rtsp-conntrack/Manifest2
-rw-r--r--net-firewall/rtsp-conntrack/files/rtsp-conntrack-5.3-strlcpy.patch29
-rw-r--r--net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r2.ebuild31
3 files changed, 62 insertions, 0 deletions
diff --git a/net-firewall/rtsp-conntrack/Manifest b/net-firewall/rtsp-conntrack/Manifest
index 7e8ed4f113bb..10f46d4c487f 100644
--- a/net-firewall/rtsp-conntrack/Manifest
+++ b/net-firewall/rtsp-conntrack/Manifest
@@ -1,4 +1,6 @@
+AUX rtsp-conntrack-5.3-strlcpy.patch 888 BLAKE2B 2b106270b7ab915624ddb2dc2677f382b7514665015d65359c7db2ddb99370d7a9a43ce90ab7c728bbdda39e060b8028d2dfede0feba150f80c7561b53d758e9 SHA512 704fc37e3f477819a63832298300ab085eeca53009c29296cd10a014196b218e4973d8cc5c64956e2af55112eded101e19870f381181f9378f73d3a515e93a41
DIST rtsp-conntrack-5.3.tar.gz 12409 BLAKE2B 91bc82f404c3d5b32100684625f5fc9641d60df457c25b2bf93988bad7acd76fdc46e2e76d12dccf42eb61bd3f724752a974728a8b229bb59df6bec545e22151 SHA512 660cf212cb5802f0d9a02c45948d02729e686fe96e12d5e2294f5d9a588d872677d4f8ef39f4abac6ec3adb2ef5e1c884858e63275a84e1035d13c21537530ab
EBUILD rtsp-conntrack-5.3-r1.ebuild 598 BLAKE2B c6fcfc39d717fc8f7750e931e401f88de295123e64912acd39cc9483ba6114f6cc6f27e3f374046abd5077e2322372a32e83ae7e0cd104c24f1b3c39ef14a94f SHA512 97e48aee8ee73d2e4270bbe8fb448f69c2c8982fc2502a0c8630707481e4cd2f63c10506e2a846be27a0f36263868535b7a1d2a5abe6b1b81c6af853a76299f0
+EBUILD rtsp-conntrack-5.3-r2.ebuild 648 BLAKE2B 163761ab81a4f75fa9f5a04a2436dddb97cdd16fbcd8415efb104462cba1b699ac6f58f0067fcffbd4171aeec26fb590f3cccb56d919dbea71e4066418a018e2 SHA512 6733fc0f9587572faf190ab038a5467d8c1967e7813f9fe5eff5018ab4e7520ddd2549015ed738c4777145fb96974c3195da507ff32f05949fe4833ff702d1d3
EBUILD rtsp-conntrack-5.3.ebuild 713 BLAKE2B 8559fc61f630373fe571805219ac94de0de02b6e9061b52f508f6e986da3a0c8b9c1a9c4bf688d4f5e2ad373825e72ccabeb99676afa97b66e868122694674f9 SHA512 edab69d7b9bf2cd6936831f12a6d2582a64b088a24573955eac978c6e255904570de16a052c3bab9f76df06fa68e83269060c5de8ec52c1e41ad1fd2f048885d
MISC metadata.xml 253 BLAKE2B 6c0ff48fb0bc43e945ed68a2f4a5f067ecef5c84a32c013616037dd8de51b7ce80bbe6560800bb16c4c24e0318a592bbf943c4182b826d694780b46e0d8dd95e SHA512 8487052b487f4d0aea42dcddcbb32e1c55ed9da79074c12971b9f31f84acc3df9d67735e247a55057312840ffc7e1ea1fa54a5fd5bb1638ca20924cb04d60919
diff --git a/net-firewall/rtsp-conntrack/files/rtsp-conntrack-5.3-strlcpy.patch b/net-firewall/rtsp-conntrack/files/rtsp-conntrack-5.3-strlcpy.patch
new file mode 100644
index 000000000000..4051421a0f84
--- /dev/null
+++ b/net-firewall/rtsp-conntrack/files/rtsp-conntrack-5.3-strlcpy.patch
@@ -0,0 +1,29 @@
+https://patch-diff.githubusercontent.com/raw/maru-sama/rtsp-linux/pull/12.patch
+From: Brahmajit Das <brahmajit.xyz@gmail.com>
+Date: Sun, 28 Apr 2024 01:48:03 +0530
+Subject: [PATCH 1/1] Fix build with Linux 6.8
+
+With commit
+https://github.com/torvalds/linux/commit/57f22c8dab6b266ae36b89b073a4a33dea71e762
+strlcpy has been removed in favor of strscpy. Thus giving us build error
+such as nf_conntrack_rtsp.c: error: implicit declaration of function
+strlcpy.
+
+First reported on Gentoo Linux, please reffer:
+https://bugs.gentoo.org/928590
+
+Signed-off-by: Brahmajit Das <brahmajit.xyz@gmail.com>
+--- a/nf_conntrack_rtsp.c
++++ b/nf_conntrack_rtsp.c
+@@ -550,7 +550,7 @@ init(void)
+ }
+
+ #if LINUX_VERSION_CODE >= KERNEL_VERSION(3,6,0)
+- strlcpy(hlpr->name, tmpname, sizeof(hlpr->name));
++ strscpy(hlpr->name, tmpname, sizeof(hlpr->name));
+ #else
+ hlpr->name = tmpname;
+ #endif
+--
+2.44.0
+
diff --git a/net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r2.ebuild b/net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r2.ebuild
new file mode 100644
index 000000000000..b53a2b6b90ce
--- /dev/null
+++ b/net-firewall/rtsp-conntrack/rtsp-conntrack-5.3-r2.ebuild
@@ -0,0 +1,31 @@
+# Copyright 1999-2024 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit linux-mod-r1
+
+DESCRIPTION="RTSP conntrack module for Netfilter"
+HOMEPAGE="https://mike.it-loops.com/rtsp"
+SRC_URI="https://github.com/maru-sama/rtsp-linux/archive/${PV}.tar.gz -> ${P}.tar.gz"
+S="${WORKDIR}/rtsp-linux-${PV}"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+CONFIG_CHECK="NF_CONNTRACK"
+
+PATCHES=(
+ "${FILESDIR}"/${P}-strlcpy.patch
+)
+
+src_compile() {
+ local modlist=(
+ nf_conntrack_rtsp=net/netfilter
+ nf_nat_rtsp=net/ipv4/netfilter
+ )
+ local modargs=( KERNELDIR="${KV_OUT_DIR}" )
+
+ linux-mod-r1_src_compile
+}