summaryrefslogtreecommitdiff
path: root/net-firewall/rtsp-conntrack
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-29 20:19:23 +0100
commit12bb627384ddfd47382b9f1b6464481a58d01ebb (patch)
treef9760c04ccd4fcd7de214e2acd5b0e43fb530aa9 /net-firewall/rtsp-conntrack
parent5fdd950c7ae03e12746a45c86d85861beaacc846 (diff)
gentoo resync : 29.08.2018
Diffstat (limited to 'net-firewall/rtsp-conntrack')
-rw-r--r--net-firewall/rtsp-conntrack/Manifest3
-rw-r--r--net-firewall/rtsp-conntrack/files/rtsp-conntrack-3.7-linux-4.18.patch28
-rw-r--r--net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild17
3 files changed, 35 insertions, 13 deletions
diff --git a/net-firewall/rtsp-conntrack/Manifest b/net-firewall/rtsp-conntrack/Manifest
index 272083b39a61..15530cb35bb8 100644
--- a/net-firewall/rtsp-conntrack/Manifest
+++ b/net-firewall/rtsp-conntrack/Manifest
@@ -1,3 +1,4 @@
+AUX rtsp-conntrack-3.7-linux-4.18.patch 877 BLAKE2B 34ba5cc162a03cded37f5b030508307dbd032eda1cb8f83ac21ec326413bb6b6a8f8c646e97db66203adbdd235bc3c4ae5340a8de179ed73c7a22034bb9b5fea SHA512 99ee1f8722e168161a0a9f91e1b04577f4f282e1519336e3e2372c885cabf62fa57e83a1d1ea926d01c15d9a7946e96c7237b1c715f3bb6b8c150b8abbc2cbd1
DIST rtsp-module-3.7.tar.gz 11474 BLAKE2B feb6f925c779ada01ef305ee91e4c805816bc3a62316ec4e89d8599f5e995f2d07a0de8ad76763eb9de9b4a24c065bd63b50e2f1eb2ef9959495baf2e3794920 SHA512 480316f41f7e9a2a75b73b3edcbbdc98bf293f013a5549c6829659e601d2d1ec0ac94f7a2519cd6e40d41cbd02cf64f81fe2a371c703c3b0ba36d200fe29a3c1
-EBUILD rtsp-conntrack-3.7.ebuild 879 BLAKE2B 2638c5f30b3a97cd49cc082ba8cb5a4ebb091f144cbb9cbaba0ec452204f7bdec4ee3860e6ae817cde2500b9ecd8ad024d635beb8e4eefd0d561141b438d8e52 SHA512 0c13d2e618b37c9ec7d0712f8ff7d18bbcb6a9fcc8e9b29fdfe980f18b2fcf4961a5f336d7dae9975557e597de59302b0b5da3818a5d360d8ec6c22ffc611b58
+EBUILD rtsp-conntrack-3.7.ebuild 732 BLAKE2B 99c78c703681496685aff7a85283fb21bae40ff145cd6e5375ba48ae52edc1e0bbe27d13097618b85732925fd0d0382271c89d7ee56dd79ed6ddc0a5d0e735f9 SHA512 a3125a39dc49503536e718a09a35f6bb8c4a3936389115619cb5b3d1f4b281fdda06df5ca491e5fca7ddfa49d2869207272d977e2b55f220e17f2283d5c12439
MISC metadata.xml 247 BLAKE2B 61049845c1ffb66aea9959f984983735ad8d7d9d37aab6da3a19951bbf8d67af657cacde1701da8a3dd93b0704c10430d511bea11d56bf98702950f0707436ec SHA512 96c55c2979dd6a4c4761fce9b5a0be387b11fcf197ef903d8680ae82f01a2caea93b1238bed1ac96d3eb250744e2149a507e0424ac017b4324f0806a54e72c4a
diff --git a/net-firewall/rtsp-conntrack/files/rtsp-conntrack-3.7-linux-4.18.patch b/net-firewall/rtsp-conntrack/files/rtsp-conntrack-3.7-linux-4.18.patch
new file mode 100644
index 000000000000..a10d994099fd
--- /dev/null
+++ b/net-firewall/rtsp-conntrack/files/rtsp-conntrack-3.7-linux-4.18.patch
@@ -0,0 +1,28 @@
+Port of 4.18 patch[1] to version 3.7 of rtsp-conntrack
+
+[1] - https://github.com/maru-sama/rtsp-linux/pull/7
+
+--- a/nf_nat_rtsp.c 2018-08-27 12:53:39.991467210 +0300
++++ b/nf_nat_rtsp.c 2018-08-27 12:53:56.087466258 +0300
+@@ -31,6 +31,7 @@
+ */
+
+ #include <linux/module.h>
++#include <linux/version.h>
+ #include <net/tcp.h>
+ #include <net/netfilter/nf_nat.h>
+ #include <net/netfilter/nf_nat_helper.h>
+@@ -430,7 +431,13 @@
+
+ static void expected(struct nf_conn* ct, struct nf_conntrack_expect *exp)
+ {
++ #if LINUX_VERSION_CODE >= KERNEL_VERSION(4,18,0)
++ struct nf_nat_range2 range;
++ #elif LINUX_VERSION_CODE < KERNEL_VERSION(3,3,0) || LINUX_VERSION_CODE >= KERNEL_VERSION(3,7,0)
+ struct nf_nat_range range;
++ #else
++ struct nf_nat_ipv4_range range;
++ #endif
+ union nf_inet_addr newdstip, newsrcip, newip;
+
+ struct nf_conn *master = ct->master;
diff --git a/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild b/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild
index 51d0c0cf892b..14fb40edd823 100644
--- a/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild
+++ b/net-firewall/rtsp-conntrack/rtsp-conntrack-3.7.ebuild
@@ -1,8 +1,8 @@
-# Copyright 1999-2013 Gentoo Foundation
+# Copyright 1999-2018 Gentoo Foundation
# Distributed under the terms of the GNU General Public License v2
-EAPI=5
-inherit eutils linux-mod versionator
+EAPI=7
+inherit linux-mod
DESCRIPTION="RTSP conntrack module for Netfilter"
HOMEPAGE="http://mike.it-loops.com/rtsp"
@@ -14,6 +14,8 @@ KEYWORDS="amd64 x86"
S="${WORKDIR}/rtsp"
+PATCHES=( "${FILESDIR}/${P}-linux-4.18.patch" )
+
BUILD_TARGETS="all"
MODULE_NAMES="
nf_conntrack_rtsp(net/netfilter::)
@@ -24,12 +26,3 @@ CONFIG_CHECK="NF_CONNTRACK"
WARNING_NF_CONNTRACK="You must enable NF_CONNTRACK in your kernel, otherwise ${PN} would not work"
BUILD_PARAMS="KERNELDIR=${KERNEL_DIR} V=1"
-
-pkg_setup() {
- linux-mod_pkg_setup
- kernel_is -lt $(get_version_components) && die "This version of ${PN} would not work on kernels <= ${PV}"
-}
-
-src_prepare() {
- epatch_user
-}