summaryrefslogtreecommitdiff
path: root/net-firewall/nftables/nftables-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-04-06 22:33:41 +0100
commite68d405c5d712af4387159df07e226217bdda049 (patch)
tree009ab0f3d427f0813e62930d71802cb054c07e30 /net-firewall/nftables/nftables-9999.ebuild
parent401101f9c8077911929d3f2b60a37098460a5d89 (diff)
gentoo resync : 06.04.2022
Diffstat (limited to 'net-firewall/nftables/nftables-9999.ebuild')
-rw-r--r--net-firewall/nftables/nftables-9999.ebuild16
1 files changed, 8 insertions, 8 deletions
diff --git a/net-firewall/nftables/nftables-9999.ebuild b/net-firewall/nftables/nftables-9999.ebuild
index d6697d8a7eef..fa427dadfaab 100644
--- a/net-firewall/nftables/nftables-9999.ebuild
+++ b/net-firewall/nftables/nftables-9999.ebuild
@@ -3,9 +3,9 @@
EAPI=7
-PYTHON_COMPAT=( python3_{7..10} )
+PYTHON_COMPAT=( python3_{8..10} )
DISTUTILS_OPTIONAL=1
-inherit autotools linux-info distutils-r1 systemd
+inherit autotools linux-info distutils-r1 systemd verify-sig
DESCRIPTION="Linux kernel (3.13+) firewall, NAT and packet mangling tools"
HOMEPAGE="https://netfilter.org/projects/nftables/"
@@ -19,8 +19,11 @@ if [[ ${PV} =~ ^[9]{4,}$ ]]; then
sys-devel/flex
"
else
- SRC_URI="https://netfilter.org/projects/nftables/files/${P}.tar.bz2"
- KEYWORDS="~amd64 ~arm ~arm64 ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ SRC_URI="https://netfilter.org/projects/nftables/files/${P}.tar.bz2
+ verify-sig? ( https://netfilter.org/projects/nftables/files/${P}.tar.bz2.sig )"
+ KEYWORDS="~amd64 ~arm ~arm64 ~hppa ~ia64 ~mips ~ppc ~ppc64 ~riscv ~sparc ~x86"
+ VERIFY_SIG_OPENPGP_KEY_PATH="${BROOT}"/usr/share/openpgp-keys/netfilter.org.asc
+ BDEPEND+="verify-sig? ( sec-keys/openpgp-keys-netfilter )"
fi
LICENSE="GPL-2"
@@ -52,10 +55,6 @@ REQUIRED_USE="
libedit? ( !readline )
"
-PATCHES=(
- "${FILESDIR}/${PN}-0.9.8-slibtool.patch"
-)
-
pkg_setup() {
if kernel_is ge 3 13; then
if use modern-kernel && kernel_is lt 3 18; then
@@ -90,6 +89,7 @@ src_configure() {
local myeconfargs=(
# We handle python separately
--disable-python
+ --disable-static
--sbindir="${EPREFIX}"/sbin
$(use_enable debug)
$(use_enable doc man-doc)