summaryrefslogtreecommitdiff
path: root/net-firewall/nftables/nftables-9999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-14 11:10:11 +0100
commit81b8f20732954c4508baf2f77472b5435e3f851f (patch)
tree4180177cb7ba85eab50159ce96218c2419fb24a6 /net-firewall/nftables/nftables-9999.ebuild
parent946859e0e36904cffb3e0ccbccb6b7b1347c1cc8 (diff)
gentoo auto-resync : 14:09:2022 - 11:10:10
Diffstat (limited to 'net-firewall/nftables/nftables-9999.ebuild')
-rw-r--r--net-firewall/nftables/nftables-9999.ebuild8
1 files changed, 6 insertions, 2 deletions
diff --git a/net-firewall/nftables/nftables-9999.ebuild b/net-firewall/nftables/nftables-9999.ebuild
index 24d357de9872..b6fdb61bd493 100644
--- a/net-firewall/nftables/nftables-9999.ebuild
+++ b/net-firewall/nftables/nftables-9999.ebuild
@@ -29,7 +29,7 @@ fi
LICENSE="GPL-2"
SLOT="0/1"
IUSE="debug doc +gmp json libedit +modern-kernel python +readline static-libs test xtables"
-RESTRICT="test? ( userpriv ) !test? ( test )"
+RESTRICT="!test? ( test )"
RDEPEND="
>=net-libs/libmnl-1.0.4:0=
@@ -120,7 +120,11 @@ src_compile() {
src_test() {
emake check
- edo tests/shell/run-tests.sh -v
+ if [[ ${EUID} == 0 ]]; then
+ edo tests/shell/run-tests.sh -v
+ else
+ ewarn "Skipping shell tests (requires root)"
+ fi
# Need to rig up Python eclass if using this, but it doesn't seem to work
# for me anyway.