summaryrefslogtreecommitdiff
path: root/net-firewall/ipset
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-11-25 16:31:33 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-11-25 16:31:33 +0000
commit8cd3c41aa0ccead302235680b9e2fa9903d7548e (patch)
treeb6f2658c42bd34d0f1dc8b5f572aa5f5886c3d5d /net-firewall/ipset
parent2900e684ae4bdce1f20652587728095cd01a30a1 (diff)
gentoo auto-resync : 25:11:2023 - 16:31:33
Diffstat (limited to 'net-firewall/ipset')
-rw-r--r--net-firewall/ipset/Manifest3
-rw-r--r--net-firewall/ipset/ipset-7.19-r1.ebuild114
-rw-r--r--net-firewall/ipset/metadata.xml4
3 files changed, 120 insertions, 1 deletions
diff --git a/net-firewall/ipset/Manifest b/net-firewall/ipset/Manifest
index 3fbd2230c5ab..a3195d4b2512 100644
--- a/net-firewall/ipset/Manifest
+++ b/net-firewall/ipset/Manifest
@@ -9,5 +9,6 @@ DIST ipset-7.17.tar.bz2 684983 BLAKE2B 43b74ab7caf5a963787184aa75b6c071388c8d289
DIST ipset-7.19.tar.bz2 686712 BLAKE2B 04290b94be471aedd732601e1dc147a066933606152beb76ba1a21283aa2e3f8b891fd9575db73f2af67b446fb77a0ca6b2432ae606440ac9e9bf80e41d1f640 SHA512 0f4252e6d967b0f130a2c7a0307b17c6b7d48336e86b2f838ea176f5faaa0c9bbbf273060906b43d91e9b38a9f33c18918e33d02292839a6bc321181d5d7f84e
EBUILD ipset-7.17-r1.ebuild 3511 BLAKE2B 4b7547736bf7665d96d5907d1b9c1ac1f53485533db548e29a91544cba794efe5e276c540a4f4493de96105a932cdc885595e6fcaf7f8b82aee8f6f9e80827bb SHA512 2f298e598775e2b53baff13335b13630545d1c9e3f278a082fb7be3acf1c544a0e0a04beedf1c16c57525d770c7514c76b61230383bc134785c542288bbeeb95
EBUILD ipset-7.17.ebuild 3507 BLAKE2B 830f9465dda941460c1b4148989fb0aa79f2c500ac6daea948eac6609d50778bd2716e9cad2248b6bad1e80c73e1612188000b0ecb3f6bdd5cadac279fcd6aa2 SHA512 117834d3727b3dd50112c2f53734753ccfb8a21c71d98892e7a5c706ca0dcc98ddc4e4b43c51a1f9ad68bc3b09ab9871b4d625923ed041e0b51e8ea4b881bb12
+EBUILD ipset-7.19-r1.ebuild 3385 BLAKE2B 8cf5e0db9751fe80573077dc4b0a904f34338945142da4d136ec7ae2cf9c92ea1d86fef04766d7e8ea9724ac3eb9c314f1f49aa11c0073ed7f3d281e370a55d0 SHA512 8de3cefdc63a9495e3d546cc009c3e14147048f6a8f8615bc0f5bc2f635503f906d05a69f168d699e162bf33c423eb0e83a60c148daa41eae3aa87600d021653
EBUILD ipset-7.19.ebuild 1707 BLAKE2B 88b972913daa212a6596543ed971ffd37ca5bfe6f5d9f8eb5476e847c5df2bfa968d589bd09e2118ba9a2465bce20149e01d5039199e0afb57329661c52b6de1 SHA512 968652a40abb9cff26e6157e4d95cda9585cf24ab3ea69d271c2c8ba46b5ec48fb88dcdd51d5d19406d9c4e82542aa531d3267b8ea9c56637cdc6ecf34ebaf0e
-MISC metadata.xml 369 BLAKE2B f41c3bdbd41f5cd6ae9451f00d80d3ca0e17343f45c37f88ab6e34dda8fce78e4d9b4d670385b3f8d9025f6065f1911d1815b610bbbbbfeb364942b8512ccc7b SHA512 f359ed08f769da53de8c31350f48b7fd0504c863fb29664ce40eac4e56f2cca842d9dc8de350fd4790a3a143ed4db6ed3df3419cc9daad4403078039ced52d3e
+MISC metadata.xml 475 BLAKE2B e1e06003a410249ed76d39b74ccbcd64b8572ff05f1c818729d787cecfb19cfa9c7e3463473688abc7a398efb908b0c7145bad88bbb7259e69f1b7d985584bcc SHA512 d0a3dca6593e8a62cbf5c325eb59b620137af8d8f5a463702c4d6ec102fd03b8adbbdcd9358777d0461f57a98d892d359d80b8f722d3f322f3d4766d762f6585
diff --git a/net-firewall/ipset/ipset-7.19-r1.ebuild b/net-firewall/ipset/ipset-7.19-r1.ebuild
new file mode 100644
index 000000000000..15cdfadce814
--- /dev/null
+++ b/net-firewall/ipset/ipset-7.19-r1.ebuild
@@ -0,0 +1,114 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+MODULES_OPTIONAL_IUSE=modules
+inherit autotools bash-completion-r1 linux-mod-r1 systemd
+
+DESCRIPTION="IPset tool for iptables, successor to ippool"
+HOMEPAGE="https://ipset.netfilter.org/ https://git.netfilter.org/ipset/"
+SRC_URI="https://ipset.netfilter.org/${P}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~arm64 ~loong ~ppc ~ppc64 ~riscv ~x86"
+
+RDEPEND="
+ net-firewall/iptables
+ net-libs/libmnl:=
+"
+DEPEND="${RDEPEND}"
+BDEPEND="virtual/pkgconfig"
+
+DOCS=( ChangeLog INSTALL README UPGRADE )
+
+# configurable from outside, e.g. /etc/portage/make.conf
+IP_NF_SET_MAX=${IP_NF_SET_MAX:-256}
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+pkg_setup() {
+ get_version
+ CONFIG_CHECK="NETFILTER"
+ ERROR_NETFILTER="ipset requires NETFILTER support in your kernel."
+ CONFIG_CHECK+=" NETFILTER_NETLINK"
+ ERROR_NETFILTER_NETLINK="ipset requires NETFILTER_NETLINK support in your kernel."
+ # It does still build without NET_NS, but it may be needed in future.
+ #CONFIG_CHECK="${CONFIG_CHECK} NET_NS"
+ #ERROR_NET_NS="ipset requires NET_NS (network namespace) support in your kernel."
+ CONFIG_CHECK+=" !PAX_CONSTIFY_PLUGIN"
+ ERROR_PAX_CONSTIFY_PLUGIN="ipset contains constified variables (#614896)"
+
+ build_modules=0
+ if use modules; then
+ if linux_config_src_exists && linux_chkconfig_builtin "MODULES" ; then
+ if linux_chkconfig_present "IP_NF_SET" || \
+ linux_chkconfig_present "IP_SET"; then #274577
+ eerror "There is IP{,_NF}_SET or NETFILTER_XT_SET support in your kernel."
+ eerror "Please either build ipset with modules USE flag disabled"
+ eerror "or rebuild kernel without IP_SET support and make sure"
+ eerror "there is NO kernel ip_set* modules in /lib/modules/<your_kernel>/... ."
+ die "USE=modules and in-kernel ipset support detected."
+ else
+ einfo "Modular kernel detected. Gonna build kernel modules..."
+ build_modules=1
+ fi
+ else
+ eerror "Nonmodular kernel detected, but USE=modules. Either build"
+ eerror "modular kernel (without IP_SET) or disable USE=modules"
+ die "Nonmodular kernel detected, will not build kernel modules"
+ fi
+ fi
+
+ [[ ${build_modules} -eq 1 ]] && linux-mod-r1_pkg_setup
+}
+
+src_configure() {
+ export bashcompdir="$(get_bashcompdir)"
+
+ econf \
+ --enable-bashcompl \
+ $(use_with modules kmod) \
+ --with-maxsets=${IP_NF_SET_MAX} \
+ --with-ksource="${KV_DIR}" \
+ --with-kbuild="${KV_OUT_DIR}"
+}
+
+src_compile() {
+ einfo "Building userspace"
+
+ local modlist=( xt_set=kernel/net/netfilter/ipset/:"${S}":kernel/net/netfilter/:
+ em_ipset=kernel/net/sched:"${S}":kernel/net/sched/:modules )
+
+ for i in ip_set{,_bitmap_{ip{,mac},port},_hash_{ip{,mac,mark,port{,ip,net}},mac,net{,port{,net},iface,net}},_list_set}; do
+ modlist+=( ${i}=kernel/net/netfilter/ipset/:"${S}":kernel/net/netfilter/ipset )
+ done
+
+ emake
+
+ if [[ ${build_modules} -eq 1 ]]; then
+ einfo "Building kernel modules"
+ linux-mod-r1_src_compile
+ fi
+}
+
+src_install() {
+ einfo "Installing userspace"
+ default
+
+ find "${ED}" -name '*.la' -delete || die
+
+ newinitd "${FILESDIR}"/ipset.initd-r5 ${PN}
+ newconfd "${FILESDIR}"/ipset.confd-r1 ${PN}
+ systemd_newunit "${FILESDIR}"/ipset.systemd-r1 ${PN}.service
+ keepdir /var/lib/ipset
+
+ if [[ ${build_modules} -eq 1 ]]; then
+ einfo "Installing kernel modules"
+ linux-mod-r1_src_install
+ fi
+}
diff --git a/net-firewall/ipset/metadata.xml b/net-firewall/ipset/metadata.xml
index 64616aa9d16b..2538887d06a7 100644
--- a/net-firewall/ipset/metadata.xml
+++ b/net-firewall/ipset/metadata.xml
@@ -9,4 +9,8 @@
<email>robbat2@gentoo.org</email>
<name>Robin H. Johnson</name>
</maintainer>
+ <maintainer type="person">
+ <email>mpagano@gentoo.org</email>
+ <name>Mike Pagano</name>
+ </maintainer>
</pkgmetadata>