summaryrefslogtreecommitdiff
path: root/net-dns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-07-16 01:44:25 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-07-16 01:44:25 +0100
commitd8616435f08981d5bc3df9f348190309a7bdbbc0 (patch)
tree6c51fc295fb9c2f5511a7ebb14fab377a5f8e171 /net-dns
parentfa1962ff69701bd9c0f15fb225cdbfb487125e0e (diff)
gentoo auto-resync : 16:07:2022 - 01:44:25
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/Manifest.gzbin8695 -> 8694 bytes
-rw-r--r--net-dns/pdns/Manifest2
-rw-r--r--net-dns/pdns/pdns-4.6.3.ebuild170
3 files changed, 172 insertions, 0 deletions
diff --git a/net-dns/Manifest.gz b/net-dns/Manifest.gz
index c38e1e759da2..a5d3629106e8 100644
--- a/net-dns/Manifest.gz
+++ b/net-dns/Manifest.gz
Binary files differ
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index fd5aff33a29b..e18ce838f274 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -1,5 +1,7 @@
AUX dnsdomain2.schema 6640 BLAKE2B d3efc6bc16390f35979f1184632e7184cf403453422888e2cb44fa4fed7891241919a39c8c6f539a61de032654650a45ea548a6983777ea1bfe029e817f2c315 SHA512 ac16f8d528d6138d3c2cbf997fd8fbb467d388aa63eb6ed4e7780a3dad11ea885b91252ff0809b1d2cf7d5200814b8963aab890af84741ea86d35b2f5955a7ea
AUX pdns-r1 2815 BLAKE2B cd607cb30a94540eca9cfa2defb7c996f6e151875fcaad8ad3357261937868bc346962f1080ad45a0ef38c2dfc126eb11e41837ee0784f677d1e7c071589a057 SHA512 4c0442d8d92d95268d4971f80782d2772e2a22c43da00566a9328c79a834e4355b2610d133034351d7137ed6cd7fda300f3db8093b09d5852cea44d983de1e39
DIST pdns-4.6.2.tar.bz2 1302527 BLAKE2B ff4e7f5ab0d0cd176e6c714d5bdf0b231ee05f092c91b19309b62b4d638d2fd1149e426ae98e153b1f64aca1f972f69c3475ee672936b85cc810f305ce899f90 SHA512 10e7f4338f99f063ca8d694c148d468e66dd1b9feb2cf8dba04861396addb138b9335908d666e7e2701424d1fdb3c29e40b596098f19b1443643b9e6ab356c0a
+DIST pdns-4.6.3.tar.bz2 1302651 BLAKE2B 58a66952293bd5caf7b03d114e11f4d6774f5f2aab969b33c1c510b745790f7276b9913cc03e3e4565e5b1de6f61decf338a3b6430d0429c2b87cc9690d9388d SHA512 ea44a0c929e36bf9002d8db7bf1e06ec372a08b31b60c74bbc3ea5600073fb745151f33798a0a4bd151ce17ad7efb07be30f7ddcf620d5bdaab6de4f37f4296f
EBUILD pdns-4.6.2-r1.ebuild 4490 BLAKE2B 37b6f170b2d5c318ba767846fb86a3d0664dc09bacfbaeac520c3a27d7525a9261a266dcdf8eda4f64743e44043141dd8e988bf043c72fdf8244548892380fbe SHA512 9db486084857a7c94d412721a01946f53d540d461aad5135e196e86971162ef81cb081b1c27b6dc006fd8f739a9bbdb0ebc4008687fe94025e1b9734d42ed882
+EBUILD pdns-4.6.3.ebuild 4492 BLAKE2B 132886602c1452baa51d42101165e7e9b3e44990724f11bbeb51f72d6f794ff034627afcadd0f1cb55594ee543b9d6e5d34024fe64000d70def5e70d35f53a97 SHA512 ff28891dca3cf06a95be03b3f207b7ca4701deac266e209b54aab20b0aec80f250a39786008381dc6542fec5f824db9551408acefd077f4e04ca8dbe152a3f96
MISC metadata.xml 1080 BLAKE2B 536be9df9d0d9f8ec3f267740ad37da3bcd854ffe12582d9355bf04a75e5620eaf87483d4bed61bee8c20fd1ac2a8a7fa280585f94400472c5b374c84042dc1a SHA512 437aa6d097f9adce27acd8ae5b1a49ed048d58fd49ca9203d6d73df4728448b2d00299ce0d9e98656dca64b1f70f124c811cd435461e65dbeb1ff23fca00ae19
diff --git a/net-dns/pdns/pdns-4.6.3.ebuild b/net-dns/pdns/pdns-4.6.3.ebuild
new file mode 100644
index 000000000000..a33ae91689aa
--- /dev/null
+++ b/net-dns/pdns/pdns-4.6.3.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# other possible flags:
+# db2: we lack the dep
+# oracle: dito (need Oracle Client Libraries)
+# xdb: (almost) dead, surely not supported
+
+IUSE="debug doc geoip ldap lmdb lua-records mydns mysql postgres remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ mydns? ( mysql )"
+
+DEPEND="${LUA_DEPS}
+ dev-libs/openssl:=
+ >=dev-libs/boost-1.35:=
+ lmdb? ( >=dev-db/lmdb-0.9.29 )
+ lua-records? ( >=net-misc/curl-7.21.3 )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( >=net-nds/openldap-2.0.27-r4:= app-crypt/mit-krb5 )
+ sqlite? ( dev-db/sqlite:3 )
+ geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
+ sodium? ( dev-libs/libsodium:= )
+ tinydns? ( >=dev-db/tinycdb-0.77 )
+ elibc_glibc? ( x86? ( >=sys-libs/glibc-2.34 ) )"
+RDEPEND="${DEPEND}
+ acct-user/pdns
+ acct-group/pdns"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ local dynmodules="pipe bind" # the default backends, always enabled
+
+ #use db2 && dynmodules+=" db2"
+ use ldap && dynmodules+=" ldap"
+ use lmdb && dynmodules+=" lmdb"
+ use mydns && dynmodules+=" mydns"
+ use mysql && dynmodules+=" gmysql"
+ #use oracle && dynmodules+=" goracle oracle"
+ use postgres && dynmodules+=" gpgsql"
+ use remote && dynmodules+=" remote"
+ use sqlite && dynmodules+=" gsqlite3"
+ use tinydns && dynmodules+=" tinydns"
+ use geoip && dynmodules+=" geoip"
+ #use xdb && dynmodules+=" xdb"
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-modules= \
+ --with-dynmodules="${dynmodules}" \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable lua-records) \
+ $(use_enable test unit-tests) \
+ $(use_enable tools) \
+ $(use_enable systemd) \
+ $(use_with sodium libsodium) \
+ ${myconf}
+}
+
+src_compile() {
+ default
+ use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ fperms 0700 /etc/powerdns
+ fperms 0600 /etc/powerdns/pdns.conf
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ newinitd "${FILESDIR}"/pdns-r1 pdns
+
+ keepdir /var/empty
+
+ if use doc; then
+ docinto html
+ dodoc -r codedocs/html/.
+ fi
+
+ # Install development headers
+ insinto /usr/include/pdns
+ doins pdns/*.hh
+ insinto /usr/include/pdns/backends/gsql
+ doins pdns/backends/gsql/*.hh
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/dnsdomain2.schema
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "PowerDNS provides multiple instances support. You can create more instances"
+ elog "by symlinking the pdns init script to another name."
+ elog
+ elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+ elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+ local old
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 3.2 || continue
+
+ echo
+ ewarn "To fix a security bug (bug #458018) had the following"
+ ewarn "files/directories the world-readable bit removed (if set):"
+ ewarn " ${EPREFIX}/etc/powerdns"
+ ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
+ ewarn "Check if this is correct for your setup"
+ ewarn "This is a one-time change and will not happen on subsequent updates."
+ chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+ break
+ done
+
+ if use postgres; then
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.1.11-r1 || continue
+
+ echo
+ ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+ ewarn "This security fix needs to be applied manually to the database schema."
+ ewarn "Please refer to the official security advisory for more information:"
+ ewarn
+ ewarn " https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+ break
+ done
+ fi
+}