summaryrefslogtreecommitdiff
path: root/net-dns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2022-09-20 23:24:40 +0100
committerV3n3RiX <venerix@koprulu.sector>2022-09-20 23:24:40 +0100
commit3f9a144d38a57497a44a583d11a6e3dfbe8319d5 (patch)
treecb0e6beb4b79e1f7ccd95c75c9f434fdad11a071 /net-dns
parent800c4c398cad9dd837da33062e71ccc84114fe05 (diff)
gentoo auto-resync : 20:09:2022 - 23:24:40
Diffstat (limited to 'net-dns')
-rw-r--r--net-dns/Manifest.gzbin8690 -> 8690 bytes
-rw-r--r--net-dns/pdns-recursor/Manifest2
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.7.3.ebuild88
3 files changed, 90 insertions, 0 deletions
diff --git a/net-dns/Manifest.gz b/net-dns/Manifest.gz
index fc712b112b13..e417f69a06fb 100644
--- a/net-dns/Manifest.gz
+++ b/net-dns/Manifest.gz
Binary files differ
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 0e47ddec02d9..a2c5f36f3c18 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,4 +1,6 @@
AUX pdns-recursor-r2 1426 BLAKE2B 4407525f88d6e4299acdaa015e13866b70b2f697493218953c515e00af1476df7b8dbc87f6a39c50743d78b7f8efd2d3446e1a387f98ac4191cea2c04e10c175 SHA512 2f4d8458f6224a42103d28937d69228092c74c9c8c958833b292acf8959df1e617eafc13b65b95cf6eb4e06fb4fa7f23906c28b583865b6885949daaac12799e
DIST pdns-recursor-4.7.2.tar.bz2 1580602 BLAKE2B 2d32d553629f665f9060e58f994a0256adc936f6fdb32ecd236ba202731342fe7e17db6678649292b4d1dd97e8579851e38fe41fd4f122dbf3d63f3d71c5de13 SHA512 b80fb1f403d5b81cf7500f6fce64914ab858b7bd7f617265db9a11ea78786de702563482c5b9daa5c9da1c19a0d02d90fd1f4f14b740d2fd492def7f4b1a7def
+DIST pdns-recursor-4.7.3.tar.bz2 1597064 BLAKE2B e5732c20f18b6711b854a2bcce36705f0f5fbf106e615a646b0a823e0eb4be8ff315f28ebbae77b67935c77255108b92f4ee6515f61019729f5191dfe147ade9 SHA512 e7d9fa32dd53e9b382689e6e735f35b12dbd9f2bb0e8b3031ab58f53a61b5cdc947cb5e857a991768afd1b403bc02d20d434dded5800be450ad45368c9d1dc0e
EBUILD pdns-recursor-4.7.2.ebuild 2029 BLAKE2B c4ba893123a434d8f322b97e42aefb2be0fdc20a75ea295578f4a65aa7bb4036445001594057a6a58a0c077713b7677cd31cf8ef01fdeed890bf0cbd5fb55df4 SHA512 579ce51506f57adde7f349920c7132c71dfea3da863e7f316341db52244d4d1f5a9dce27f4529ff28223fe0bccde21eb43653ea433f6080511a673596cef7ebf
+EBUILD pdns-recursor-4.7.3.ebuild 2031 BLAKE2B b4b7c64ae31ac08e78f8c5515a00cfca29178b4eb2c6321285ab26865bec32fbb3f31fa08f76e44bd2fc92bd241833b2de72280129eaf4b3e49f0fb83f762c34 SHA512 d56abd948f796694d72f537e5c72a6daa14ae5518c72f82048094625c987796c82d741de59c82aeb809b85a9cc805fc64be0a78bd17f52ac22fb041ceb35eaaa
MISC metadata.xml 930 BLAKE2B 997ed7f557ddae9d8a5b3f92396cb5acb9cde67de5cc750c4c3b051635557ff22fcdd94400a95cc7e5328ccca9786fe3b780c81d57f785865a18e68701916d00 SHA512 3415ed721ad143cae712ee309ba9f3057273b8e594617fe12382bd316cad7dc6e2ed66d660d9c13fa3db993852c85f21d1ea1c0367e595dd5bbf782add225cd1
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.7.3.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.7.3.ebuild
new file mode 100644
index 000000000000..c8d6a1da1b22
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.7.3.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2022 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ elibc_glibc? (
+ arm? ( >=sys-libs/glibc-2.34 )
+ x86? ( >=sys-libs/glibc-2.34 )
+ )
+ dev-libs/openssl:=
+ dev-libs/boost:=[context]"
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}