summaryrefslogtreecommitdiff
path: root/net-dns/smartdns/smartdns-41.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-03-20 18:37:48 +0000
committerV3n3RiX <venerix@koprulu.sector>2023-03-20 18:37:48 +0000
commita075e288474a3a53905a044068223546c5360298 (patch)
tree1c098c5d1bc3bc29ed1fd6df8a9a6d700df3f946 /net-dns/smartdns/smartdns-41.ebuild
parentbf091a83ac5cdd060495df0aef0aeab9066672a1 (diff)
gentoo auto-resync : 20:03:2023 - 18:37:48
Diffstat (limited to 'net-dns/smartdns/smartdns-41.ebuild')
-rw-r--r--net-dns/smartdns/smartdns-41.ebuild33
1 files changed, 33 insertions, 0 deletions
diff --git a/net-dns/smartdns/smartdns-41.ebuild b/net-dns/smartdns/smartdns-41.ebuild
new file mode 100644
index 000000000000..96243a40fbf5
--- /dev/null
+++ b/net-dns/smartdns/smartdns-41.ebuild
@@ -0,0 +1,33 @@
+# Copyright 2022-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=8
+
+inherit systemd
+DESCRIPTION="A local DNS server returns the fastest access results"
+HOMEPAGE="https://github.com/pymumu/smartdns"
+SRC_URI="https://github.com/pymumu/smartdns/archive/refs/tags/Release${PV}.tar.gz -> ${P}.tar.gz"
+
+LICENSE="GPL-3"
+SLOT="0"
+KEYWORDS="~amd64"
+
+DEPEND="dev-libs/openssl:0="
+RDEPEND="${DEPEND}"
+BDEPEND=""
+
+S="${WORKDIR}/${PN}-Release${PV}"
+
+src_prepare() {
+ default
+ sed -i -e "/install .*default /d" \
+ -e "/install .*init.d /d" Makefile || die
+}
+
+src_install() {
+ emake DESTDIR="${D}" \
+ SYSTEMDSYSTEMUNITDIR="$(systemd_get_systemunitdir)" install
+
+ newconfd "${FILESDIR}"/smartdns.confd smartdns
+ newinitd "${FILESDIR}"/smartdns.initd smartdns
+}