summaryrefslogtreecommitdiff
path: root/net-dns/pdns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-04-17 23:53:43 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-04-17 23:53:43 +0100
commit3a8423ee2874c2fd96358b28af08d38d83e9bdc0 (patch)
tree4cb2ff2a0a12a3c5013370cccd6697938b087225 /net-dns/pdns
parent6fe0a08604ce763398dcbeb5fc63d814110f0748 (diff)
gentoo auto-resync : 17:04:2023 - 23:53:43
Diffstat (limited to 'net-dns/pdns')
-rw-r--r--net-dns/pdns/Manifest2
-rw-r--r--net-dns/pdns/pdns-4.7.4.ebuild170
2 files changed, 172 insertions, 0 deletions
diff --git a/net-dns/pdns/Manifest b/net-dns/pdns/Manifest
index 70f1fabb21f9..2ccf1c7296df 100644
--- a/net-dns/pdns/Manifest
+++ b/net-dns/pdns/Manifest
@@ -2,5 +2,7 @@ AUX dnsdomain2.schema 6640 BLAKE2B d3efc6bc16390f35979f1184632e7184cf40345342288
AUX pdns-4.7.3-gcc-13.patch 444 BLAKE2B 525793a557cf860cbb8e5e99284511496b667d05d84e3ac632b126a255e91fae818f6beccc775747f5df90e62ccb0e24224053e963813b44e6a182b66800ad06 SHA512 28b0cd0920c561467eeb3a27c53fbe88dd439edd59759015e6a0fbc36f1df13077de7bb1ae463eccf2ece7bb14fbde06b3162c5a812d00808f78165852980e33
AUX pdns-r1 2815 BLAKE2B cd607cb30a94540eca9cfa2defb7c996f6e151875fcaad8ad3357261937868bc346962f1080ad45a0ef38c2dfc126eb11e41837ee0784f677d1e7c071589a057 SHA512 4c0442d8d92d95268d4971f80782d2772e2a22c43da00566a9328c79a834e4355b2610d133034351d7137ed6cd7fda300f3db8093b09d5852cea44d983de1e39
DIST pdns-4.7.3.tar.bz2 1353333 BLAKE2B 9dc693c940af08755dcf2c77d103bf219e453684f1714eb0790bc06b68ee01872fafc29ab7ba62a8d2cde9dc0035c527d9f241afe7fb170821dfeb5b6c32242d SHA512 25ca5ef04297efc56f6b88e06177d0db5ed390844225dbc53bff6a9299ba3f711aa27642adca31df0f04e6af7059280690a3793458090cd6b2703cbc4fc9072a
+DIST pdns-4.7.4.tar.bz2 1339609 BLAKE2B b5aebad86cf43d87939dcaf1f31cf95969ce3fe5cf55237117eb455c980f6b617ad2d4769d002698b87161a04c5c9e9cefad709cdae703756d6660aef82af6de SHA512 7b666bba72adb2058aa28cff9962bbbf5ddc77860e5f55f74629e2ba27787595347584b7881a846d6c7a698221de785a9dce45992b80313977bbe1e5e5d0d05c
EBUILD pdns-4.7.3.ebuild 4585 BLAKE2B 550672eafbb8bc54d85dbcc2de3799ed825d583ca770098ba505801cca2d19b2fa7a08c46075cae697265727475f114fbf3447d9173d19d397a25cd225e887ca SHA512 c4799edca20c789255fa2f9f2e38a186e604210a960d54ea7dccd9330579e9d72ad4302657ddb1203dcd936cc9e95d36ae57479b1e79505e977f7688b7e92079
+EBUILD pdns-4.7.4.ebuild 4541 BLAKE2B 1434306933f3712133ed6c0af2033f76d1ae42ff0bc3715e8d4b555e653e4d34be85a4eb4c3fe59bc0cb7e46f21bd574c91a24f95601d163dcb688638d716d77 SHA512 27a86f6ddb3d1c4b26e9d49ee038ee43dcb379de473c1edbf14d2fb0d86e2ef0a6c5d78ddba254ee22b4920b22b39804dd33d9070ab8223ed9497556e006664b
MISC metadata.xml 1080 BLAKE2B 536be9df9d0d9f8ec3f267740ad37da3bcd854ffe12582d9355bf04a75e5620eaf87483d4bed61bee8c20fd1ac2a8a7fa280585f94400472c5b374c84042dc1a SHA512 437aa6d097f9adce27acd8ae5b1a49ed048d58fd49ca9203d6d73df4728448b2d00299ce0d9e98656dca64b1f70f124c811cd435461e65dbeb1ff23fca00ae19
diff --git a/net-dns/pdns/pdns-4.7.4.ebuild b/net-dns/pdns/pdns-4.7.4.ebuild
new file mode 100644
index 000000000000..06946373e433
--- /dev/null
+++ b/net-dns/pdns/pdns-4.7.4.ebuild
@@ -0,0 +1,170 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Daemon"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+
+# other possible flags:
+# db2: we lack the dep
+# oracle: dito (need Oracle Client Libraries)
+# xdb: (almost) dead, surely not supported
+
+IUSE="debug doc geoip ldap lmdb lua-records mydns mysql postgres remote sodium sqlite systemd tools tinydns test"
+RESTRICT="!test? ( test )"
+
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ mydns? ( mysql )"
+
+DEPEND="${LUA_DEPS}
+ dev-libs/openssl:=
+ dev-libs/boost:=
+ lmdb? ( >=dev-db/lmdb-0.9.29 )
+ lua-records? ( >=net-misc/curl-7.21.3 )
+ mysql? ( dev-db/mysql-connector-c:= )
+ postgres? ( dev-db/postgresql:= )
+ ldap? ( >=net-nds/openldap-2.0.27-r4:= app-crypt/mit-krb5 )
+ sqlite? ( dev-db/sqlite:3 )
+ geoip? ( >=dev-cpp/yaml-cpp-0.5.1:= dev-libs/geoip )
+ sodium? ( dev-libs/libsodium:= )
+ tinydns? ( >=dev-db/tinycdb-0.77 )
+ elibc_glibc? ( x86? ( >=sys-libs/glibc-2.34 ) )"
+RDEPEND="${DEPEND}
+ acct-user/pdns
+ acct-group/pdns"
+
+BDEPEND="virtual/pkgconfig
+ doc? ( app-doc/doxygen[dot] )"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ append-lfs-flags
+ append-cppflags -D_TIME_BITS=64
+}
+
+src_configure() {
+ local cnf_dynmodules="pipe bind" # the default backends, always enabled
+
+ #use db2 && cnf_dynmodules+=" db2"
+ use ldap && cnf_dynmodules+=" ldap"
+ use lmdb && cnf_dynmodules+=" lmdb"
+ use mydns && cnf_dynmodules+=" mydns"
+ use mysql && cnf_dynmodules+=" gmysql"
+ #use oracle && cnf_dynmodules+=" goracle oracle"
+ use postgres && cnf_dynmodules+=" gpgsql"
+ use remote && cnf_dynmodules+=" remote"
+ use sqlite && cnf_dynmodules+=" gsqlite3"
+ use tinydns && cnf_dynmodules+=" tinydns"
+ use geoip && cnf_dynmodules+=" geoip"
+ #use xdb && cnf_dynmodules+=" xdb"
+
+ econf \
+ --disable-static \
+ --sysconfdir=/etc/powerdns \
+ --libdir=/usr/$(get_libdir)/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-modules= \
+ --with-dynmodules="${cnf_dynmodules}" \
+ --with-mysql-lib=/usr/$(get_libdir) \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable lua-records) \
+ $(use_enable test unit-tests) \
+ $(use_enable tools) \
+ $(use_enable systemd) \
+ $(use_with sodium libsodium) \
+ ${myconf}
+}
+
+src_compile() {
+ default
+ use doc && emake -C codedocs codedocs
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/pdns.conf{-dist,}
+
+ fperms 0700 /etc/powerdns
+ fperms 0600 /etc/powerdns/pdns.conf
+
+ # set defaults: setuid=pdns, setgid=pdns
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/g' \
+ "${D}"/etc/powerdns/pdns.conf
+
+ newinitd "${FILESDIR}"/pdns-r1 pdns
+
+ keepdir /var/empty
+
+ if use doc; then
+ docinto html
+ dodoc -r codedocs/html/.
+ fi
+
+ # Install development headers
+ insinto /usr/include/pdns
+ doins pdns/*.hh
+ insinto /usr/include/pdns/backends/gsql
+ doins pdns/backends/gsql/*.hh
+
+ if use ldap ; then
+ insinto /etc/openldap/schema
+ doins "${FILESDIR}"/dnsdomain2.schema
+ fi
+
+ find "${D}" -name '*.la' -delete || die
+}
+
+pkg_postinst() {
+ elog "PowerDNS provides multiple instances support. You can create more instances"
+ elog "by symlinking the pdns init script to another name."
+ elog
+ elog "The name must be in the format pdns.<suffix> and PowerDNS will use the"
+ elog "/etc/powerdns/pdns-<suffix>.conf configuration file instead of the default."
+
+ local old
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 3.2 || continue
+
+ echo
+ ewarn "To fix a security bug (bug #458018) had the following"
+ ewarn "files/directories the world-readable bit removed (if set):"
+ ewarn " ${EPREFIX}/etc/powerdns"
+ ewarn " ${EPREFIX}/etc/powerdns/pdns.conf"
+ ewarn "Check if this is correct for your setup"
+ ewarn "This is a one-time change and will not happen on subsequent updates."
+ chmod o-rwx "${EPREFIX}"/etc/powerdns/{,pdns.conf}
+
+ break
+ done
+
+ if use postgres; then
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.1.11-r1 || continue
+
+ echo
+ ewarn "PowerDNS 4.1.11 contains a security fix for the PostgreSQL backend."
+ ewarn "This security fix needs to be applied manually to the database schema."
+ ewarn "Please refer to the official security advisory for more information:"
+ ewarn
+ ewarn " https://doc.powerdns.com/authoritative/security-advisories/powerdns-advisory-2019-06.html"
+
+ break
+ done
+ fi
+}