summaryrefslogtreecommitdiff
path: root/net-dns/pdns-recursor
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
committerV3n3RiX <venerix@redcorelinux.org>2021-04-28 20:21:43 +0100
commit40aaaa64e86ba6710bbeb31c4615a6ce80e75e11 (patch)
tree758c221bad35c9288d0bd6df9c7dfc226728e52c /net-dns/pdns-recursor
parent8d5dbd847cbc704a6a06405856e94b461011afe3 (diff)
gentoo resync : 28.04.2021
Diffstat (limited to 'net-dns/pdns-recursor')
-rw-r--r--net-dns/pdns-recursor/Manifest2
-rw-r--r--net-dns/pdns-recursor/pdns-recursor-4.4.3.ebuild89
2 files changed, 91 insertions, 0 deletions
diff --git a/net-dns/pdns-recursor/Manifest b/net-dns/pdns-recursor/Manifest
index 4c58acf81e96..95bdedc96374 100644
--- a/net-dns/pdns-recursor/Manifest
+++ b/net-dns/pdns-recursor/Manifest
@@ -1,4 +1,6 @@
AUX pdns-recursor-r2 1251 BLAKE2B 391f52b9c9b8ee1d01ca57b5e73106f350f474e12c5ca957cfe857a0a8f672a1347393d15c343601769ce58fc12034833fb5f012f7ae7b1d41d76d493be5ca71 SHA512 a607ac4e6edb095d7d097e255779ea574191793bbbdce1df7113e17dc777dfd8929a9332fc6cd4e98b59fe826e020efcf35a011ff4cef70433117fab4998584c
DIST pdns-recursor-4.4.2.tar.bz2 1396763 BLAKE2B f8dad7694ac13ed8d824ddaf613d1a001452ab2c08fcbb0e00d2b2258464b754809746b89998b818c44866f9e4b22c87c1cebf2da852fb7b6247ac6b9fd4b99d SHA512 31fdf62d87e5ee8f9570c6b738339bc8cc65c43800f18c7fb49aa5c53fc9ad76a1ddf02cc44f7129e06b41700b5cb3768ff8f81cc521c28147ea6538c73f8781
+DIST pdns-recursor-4.4.3.tar.bz2 1398743 BLAKE2B d9429ef22bb2b196e42da91332332b38dee9220d490c8adda686b0bc144e0981ea4418973f4304d6d964ef8f6ac4adcde4bd3e6d6b208c620440eab1b11a7fc0 SHA512 bac69cbaabc1b0de0def681e07f7e77954e0d487732cb46dc722f7869576a8a477a4011f78c9cc66b5e9b45455eb81534602b2834dc1ad42b85f5f2801915cbb
EBUILD pdns-recursor-4.4.2-r100.ebuild 2002 BLAKE2B 9edb0aa92f545c91b1eadf5426ad3652e522b0b7e35a9ae5ea22c4632fa5907a475b873c6caa99b9beede497b298709c5fbebc4c5c6e68841c140ed719729497 SHA512 f9bb8eba62146a30e0bb8b2abdddfcfac9cc4766f3009686f56fc978dd625cda49ea4d5b1e294a1a20b82ceb4d64ee68542aea2daa98305c2c4328700f0d1f72
+EBUILD pdns-recursor-4.4.3.ebuild 2070 BLAKE2B cd2177eac66fda358eb0af7179ebd4eff4c5073045cc89eeb8cfe66784c53bfa7d49e4c99e61dd4f11950fbaa4897f126f3e8f15c0f2692419a67f7da01a36ff SHA512 3838a0f71be851a32fb608dfb501f5f07b91b66b4dfdb9e17a94316cc2cb46809de91406178509a19442f8ae921dccac19f0e5db1e54436425d51a5af3401121
MISC metadata.xml 1008 BLAKE2B 1c82fd9262358bcf1ff0f8503bc8dfe9b640023133ca48711bc576df00312312b5e37a36ff10aac561ef1c71e20f64c5f0a4c431c60ca029220732fba0ee1bf9 SHA512 2deab5a88c42d3416b3da5b6d9d3ed9b2db0a5dcb3d8b7fc4c7a13b2219fd7df786bfef42ff5e3d7c2b40058592e892f380d126a0254013534e66e65499e7105
diff --git a/net-dns/pdns-recursor/pdns-recursor-4.4.3.ebuild b/net-dns/pdns-recursor/pdns-recursor-4.4.3.ebuild
new file mode 100644
index 000000000000..312ff4250bd2
--- /dev/null
+++ b/net-dns/pdns-recursor/pdns-recursor-4.4.3.ebuild
@@ -0,0 +1,89 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+LUA_COMPAT=( lua5-{1..4} luajit )
+
+inherit flag-o-matic lua-single
+
+DESCRIPTION="The PowerDNS Recursor"
+HOMEPAGE="https://www.powerdns.com/"
+SRC_URI="https://downloads.powerdns.com/releases/${P/_/-}.tar.bz2"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~amd64 ~arm ~x86"
+IUSE="debug dnstap libressl protobuf snmp sodium systemd test"
+REQUIRED_USE="${LUA_REQUIRED_USE}
+ dnstap? ( protobuf )"
+RESTRICT="!test? ( test )"
+
+DEPEND="${LUA_DEPS}
+ protobuf? (
+ dev-libs/protobuf
+ >=dev-libs/boost-1.42:=
+ )
+ dnstap? ( dev-libs/fstrm )
+ systemd? ( sys-apps/systemd:0= )
+ snmp? ( net-analyzer/net-snmp )
+ sodium? ( dev-libs/libsodium:= )
+ libressl? ( dev-libs/libressl:= )
+ !libressl? ( dev-libs/openssl:= )
+ >=dev-libs/boost-1.35:="
+RDEPEND="${DEPEND}
+ !<net-dns/pdns-2.9.20-r1
+ acct-user/pdns
+ acct-group/pdns"
+BDEPEND="virtual/pkgconfig"
+
+S="${WORKDIR}"/${P/_/-}
+
+pkg_setup() {
+ lua-single_pkg_setup
+ filter-flags -ftree-vectorize
+}
+
+src_configure() {
+ econf \
+ --sysconfdir=/etc/powerdns \
+ --with-nod-cache-dir=/var/lib/powerdns \
+ --with-service-user=pdns \
+ --with-service-group=pdns \
+ --with-lua="${ELUA}" \
+ $(use_enable debug verbose-logging) \
+ $(use_enable systemd) \
+ $(use_enable dnstap dnstap) \
+ $(use_enable test unit-tests) \
+ $(use_with sodium libsodium) \
+ $(use_with protobuf) \
+ $(use_with snmp net-snmp)
+}
+
+src_install() {
+ default
+
+ mv "${D}"/etc/powerdns/recursor.conf{-dist,}
+
+ # set defaults: setuid=nobody, setgid=nobody
+ sed -i \
+ -e 's/^# set\([ug]\)id=$/set\1id=pdns/' \
+ -e 's/^# quiet=$/quiet=on/' \
+ -e 's/^# chroot=$/chroot=\/var\/lib\/powerdns/' \
+ "${D}"/etc/powerdns/recursor.conf
+
+ newinitd "${FILESDIR}"/pdns-recursor-r2 pdns-recursor
+}
+
+pkg_postinst() {
+ local old
+
+ for old in ${REPLACING_VERSIONS}; do
+ ver_test ${old} -lt 4.0.0-r1 || continue
+
+ ewarn "Starting with 4.0.0-r1 the init script has been renamed from precursor"
+ ewarn "to pdns-recursor, please update your runlevels accordingly."
+
+ break
+ done
+}