summaryrefslogtreecommitdiff
path: root/net-dns/openresolv/openresolv-3.13.2.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@koprulu.sector>2023-06-30 01:41:48 +0100
committerV3n3RiX <venerix@koprulu.sector>2023-06-30 01:41:48 +0100
commit38c20fb51b0482ec1b2c2a34ed16227718eac4b2 (patch)
tree18555c0f1f2d21b225fb67bd5408127b8aaadef2 /net-dns/openresolv/openresolv-3.13.2.ebuild
parent2831634aa8213b30f404da1f64644d94dc66a6d0 (diff)
gentoo auto-resync : 30:06:2023 - 01:41:48
Diffstat (limited to 'net-dns/openresolv/openresolv-3.13.2.ebuild')
-rw-r--r--net-dns/openresolv/openresolv-3.13.2.ebuild45
1 files changed, 45 insertions, 0 deletions
diff --git a/net-dns/openresolv/openresolv-3.13.2.ebuild b/net-dns/openresolv/openresolv-3.13.2.ebuild
new file mode 100644
index 000000000000..da057b7d5a47
--- /dev/null
+++ b/net-dns/openresolv/openresolv-3.13.2.ebuild
@@ -0,0 +1,45 @@
+# Copyright 1999-2023 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+DESCRIPTION="A framework for managing DNS information"
+HOMEPAGE="https://roy.marples.name/projects/openresolv"
+SRC_URI="https://github.com/NetworkConfiguration/openresolv/releases/download/v${PV}/${P}.tar.xz"
+
+LICENSE="BSD-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~loong ~m68k ~mips ~ppc ~ppc64 ~riscv ~s390 ~sparc ~x86"
+IUSE="selinux"
+
+RDEPEND="!sys-apps/systemd[resolvconf]
+ selinux? ( sec-policy/selinux-resolvconf )"
+
+PDEPEND="net-dns/resolvconf-symlink"
+
+src_configure() {
+ local myeconfargs=(
+ --prefix="${EPREFIX}"
+ --rundir="${EPREFIX}"/var/run
+ --libexecdir="${EPREFIX}"/lib/resolvconf
+ )
+ econf "${myeconfargs[@]}"
+}
+
+pkg_config() {
+ if [[ -n ${ROOT} ]]; then
+ eerror "We cannot configure unless \$ROOT is empty"
+ return 1
+ fi
+
+ if [[ -n "$(resolvconf -l)" ]]; then
+ einfo "${PN} already has DNS information"
+ else
+ ebegin "Copying /etc/resolv.conf to resolvconf -a dummy"
+ resolvconf -a dummy </etc/resolv.conf
+ eend $? || return $?
+ einfo "The dummy interface will disappear when you next reboot"
+ fi
+}
+
+DOCS=( LICENSE README.md )