summaryrefslogtreecommitdiff
path: root/net-dns/nsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
committerV3n3RiX <venerix@redcorelinux.org>2021-01-29 18:03:51 +0000
commitd7ed2b01311f15ba54fe8ea872aab7d59ab2b193 (patch)
tree1814dd2b5bbf2e7639fdafbeef48d228cfaf5e9b /net-dns/nsd
parentabaa75b10f899ada8dd05b23cc03205064394bc6 (diff)
gentoo resync : 29.01.2021
Diffstat (limited to 'net-dns/nsd')
-rw-r--r--net-dns/nsd/Manifest2
-rw-r--r--net-dns/nsd/nsd-4.3.5.ebuild118
2 files changed, 120 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 73e2510088e8..374e53dd1148 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -3,5 +3,7 @@ AUX nsd.munin-conf 23 BLAKE2B 0b08804b2218d77ea925d4c9e26e73649b453b923d6d7b1e1d
AUX nsd.service 272 BLAKE2B 66a7d4132246589f71341afd98361f6b02082be3d4e230c86ae690876a797ea0a4580b29892d91feba2785ea933a053f862e0d00f2c8a8c09ab907386c39a03c SHA512 fbca86887bfc36d61af06992cc98b3f3cb33c39274fbdc1e53d489bdcc767993911fab27a20244c3878b36bacbd1644a552364b2f7bf4d48e6eb247d0eecdf0f
AUX nsd_munin_.patch 542 BLAKE2B 13ff49c41683d5bf505e257cd17bf5f3ad06662c00032d79b36be3f96486eb89fdd62a42b5ed4816ad99835366864603568613e27504894340ebb64057e2b2c3 SHA512 6034086d6b6f6980468766c901e92291fea8a32df179561ede2add5918c37bfe3aabf122735d4ae2e28efece394fd3398f9a0cc4d8fdcc1e5da1ca709d2ba6ae
DIST nsd-4.3.4.tar.gz 1182467 BLAKE2B 10c06be9df393774627a42a7cf254202fe9800e7cd5048d392fbf90a65321a4596e742165b1157b3a0ce0645a80ae5425f7d43eb0a453077e45bff06d52347d4 SHA512 fe332caecfd3c6bb8ae1a92fec26984a7953e5e462515e8622c1079b217c962728e841826cdf7899f47f9ac24af1dd383f8ba7981541b05a2338cd288c40b0a7
+DIST nsd-4.3.5.tar.gz 1184220 BLAKE2B 0ded84d9a0c25b86af6c05a7ab3ffb680177142b79a96f952cdeb92d87d9d0f306fb3c864b8f3cb769b05b0a863a7470df9407e6f3f5f0bc9a32891185d32b6f SHA512 bd031da779ff7b9b53fb4ea4d038a51f3b8f7b59a2927f674def46ca775f30afa059b471fed7d8ebcd2b7d02968945972b98856198eafbc4263d3064dae01029
EBUILD nsd-4.3.4.ebuild 3109 BLAKE2B 7af915c66086aefe78f666fc2aaa4df0bc8dfd99e58f1290baff441348cd69ef7fb377c0dc4ab0b1d1b9f456bf8eef2aff1813570affc3d4b6d2b833d904d294 SHA512 1db683c09d190c652c9ca9435e19d72f0ea881929b905938d54a8972da4c2584f19759a484fe0d6355be6c5428a4a1c387de902f562c5b9106908f06f97dff51
+EBUILD nsd-4.3.5.ebuild 3111 BLAKE2B 06f6a907ef17566e5150bb3362da143a3ffdf4b1b0df1f2494319ebc5ce5f02acc6e14c6494530af1e7b0ba31533b788dd7a8c4cb4529e35e2c8044f1d8edb30 SHA512 a9f62f66876f39265cacb807674a896797a2d505b660fb20af4755cde445d81edcb34263e4afbc778a5d57c36a3d5169162084f182809795892d706465dc3d07
MISC metadata.xml 1082 BLAKE2B c44a5b7b9cb5ad52ebc55dd52a584cd8b0700977a19d541df1b415164250e390941ef35a0e8633a975e6cbae402719d8c5fe7d452dde5623223b01a7ec4320ac SHA512 a66e71346c6742c77ce38ca73f600dde471f3256928bab79f2015cb88c2f3237a4d69f7b9127ea90c58f584b60b8b676416b0704761ee1455479644fd2cd5a8d
diff --git a/net-dns/nsd/nsd-4.3.5.ebuild b/net-dns/nsd/nsd-4.3.5.ebuild
new file mode 100644
index 000000000000..4ec0d9ca8c8b
--- /dev/null
+++ b/net-dns/nsd/nsd-4.3.5.ebuild
@@ -0,0 +1,118 @@
+# Copyright 1999-2021 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats dnstap ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ acct-group/nsd
+ acct-user/nsd
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ libevent? ( dev-libs/libevent )
+ munin? ( net-analyzer/munin )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ systemd? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_prepare() {
+ default
+ # Required to get correct pkg-config macros with USE="systemd"
+ # see bugs #663618 and #758050
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --enable-tcp-fastopen
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable dnstap)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_enable systemd)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
+}