summaryrefslogtreecommitdiff
path: root/net-dns/nsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-08-25 07:36:27 +0100
commit43793fab84041cfc5c60c0151d1591b8a69fb24a (patch)
tree6208a7f4fc744684fce0f55acbb47511acace498 /net-dns/nsd
parent28e3d252dc8ac8a5635206dfefe1cfe05058d1db (diff)
gentoo resync : 25.08.2018
Diffstat (limited to 'net-dns/nsd')
-rw-r--r--net-dns/nsd/Manifest2
-rw-r--r--net-dns/nsd/nsd-4.1.24.ebuild111
2 files changed, 113 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index d282e5bad84e..66018008dd74 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -3,5 +3,7 @@ AUX nsd.munin-conf 23 BLAKE2B 0b08804b2218d77ea925d4c9e26e73649b453b923d6d7b1e1d
AUX nsd.service 272 BLAKE2B 66a7d4132246589f71341afd98361f6b02082be3d4e230c86ae690876a797ea0a4580b29892d91feba2785ea933a053f862e0d00f2c8a8c09ab907386c39a03c SHA512 fbca86887bfc36d61af06992cc98b3f3cb33c39274fbdc1e53d489bdcc767993911fab27a20244c3878b36bacbd1644a552364b2f7bf4d48e6eb247d0eecdf0f
AUX nsd_munin_.patch 542 BLAKE2B 13ff49c41683d5bf505e257cd17bf5f3ad06662c00032d79b36be3f96486eb89fdd62a42b5ed4816ad99835366864603568613e27504894340ebb64057e2b2c3 SHA512 6034086d6b6f6980468766c901e92291fea8a32df179561ede2add5918c37bfe3aabf122735d4ae2e28efece394fd3398f9a0cc4d8fdcc1e5da1ca709d2ba6ae
DIST nsd-4.1.23.tar.gz 1102038 BLAKE2B 673146931421ba7be5e90b6f60db23f9e61f42687e4f0aac2d6624125f09067dab535a3badfd00d795a3948319467f3924ca24cc0697b0c203591c2d6efb1834 SHA512 7eb44658be6a3b94855d1a84201e5f20a02c8d85786ac0b1f82a3a67e6bc3c22602d03a8976c2bcb68ea68f0bcf72f1d9fe688e1fd1f9fbe6a774c97bdcf7939
+DIST nsd-4.1.24.tar.gz 1107574 BLAKE2B 9e22d6a07bc7c63efb41b0b4e1a0e1e36d94db9bf79f31a704bd1ec7ba371b059669feebca4b6ed9427ba41017f661ebd8a30a26ee433b45374df75d2c182cb2 SHA512 68f7f62c740e5a73d1b9da4b6d593ff1b728bc398ad126a75febaa523a2117c80315bf90ca6a60aabf38539181e00524cedb106a32b4883aa8ed021462d47762
EBUILD nsd-4.1.23.ebuild 2792 BLAKE2B 5e7cbb5049ef66385ced5235c952e96f25e30c86c3536a8c2f6814a3066de8a8c3b019b6ca026ea70a563d86b9340e695cf2884b84f30e262ce316ff1780719c SHA512 788158e409868361e00791bfed6652c58c7c44791cc33a475aef433abcc104810c864de0aeb40bec22a7f6015213ddfd7fb5f2fc5a4376e14a08f1d4a1908bae
+EBUILD nsd-4.1.24.ebuild 2940 BLAKE2B 7ee9ab031d999185636c740144546d8783d68c081ffefc832af33fef4e81d56ea0cdb5da37e554a9e1115b8e61da7d6ada5e2833fa16bb05aa2bc66e615c1f05 SHA512 e6af515d20dd8ddb13e56142e894c5c4f6c6d243d57ec0a849180c29e4f249c9a7658469fc871a9eef7873d67d90206752d03c9571c351f1d6a5f375e0668585
MISC metadata.xml 1013 BLAKE2B b989a1ccafac96d48d6f1b72bace164fcb1c04885ec9436e37fb29d94bf8c5feb4a02a1b4fc04241b6fa3c9d6d89ec993e3a06b6efc7ccd45d4ace3fad16cb18 SHA512 e7c0d6a267fd06546ac58278ffb75280aa0c0ed55ddf0097614906c1863e55cf572ff7660e021ac8861c506ed0de126c0c5e68dd2d88aea1a395be3234607ce5
diff --git a/net-dns/nsd/nsd-4.1.24.ebuild b/net-dns/nsd/nsd-4.1.24.ebuild
new file mode 100644
index 000000000000..4ba2bdca0910
--- /dev/null
+++ b/net-dns/nsd/nsd-4.1.24.ebuild
@@ -0,0 +1,111 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools user systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ libevent? ( dev-libs/libevent )
+ munin? ( net-analyzer/munin )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="
+ ${RDEPEND}
+ sys-devel/flex
+ virtual/yacc
+ systemd? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_enable systemd)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED%/}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # Do this in postinst to ensure the uid/gid is consistent for binpkgs
+ enewgroup nsd
+ enewuser nsd -1 -1 -1 nsd
+
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT%/}"/var/lib/nsd
+}