summaryrefslogtreecommitdiff
path: root/net-dns/nsd
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
committerV3n3RiX <venerix@redcorelinux.org>2020-04-25 11:37:10 +0100
commit38423c67c8a23f6a1bc42038193182e2da3116eb (patch)
tree04e2cf4bd43601b77daa79fe654e409187093c5e /net-dns/nsd
parent623ee73d661e5ed8475cb264511f683407d87365 (diff)
gentoo resync : 25.04.2020
Diffstat (limited to 'net-dns/nsd')
-rw-r--r--net-dns/nsd/Manifest2
-rw-r--r--net-dns/nsd/nsd-4.3.1.ebuild116
2 files changed, 118 insertions, 0 deletions
diff --git a/net-dns/nsd/Manifest b/net-dns/nsd/Manifest
index 7258edfdf851..b7e5d8a9fecd 100644
--- a/net-dns/nsd/Manifest
+++ b/net-dns/nsd/Manifest
@@ -4,6 +4,8 @@ AUX nsd.service 272 BLAKE2B 66a7d4132246589f71341afd98361f6b02082be3d4e230c86ae6
AUX nsd_munin_.patch 542 BLAKE2B 13ff49c41683d5bf505e257cd17bf5f3ad06662c00032d79b36be3f96486eb89fdd62a42b5ed4816ad99835366864603568613e27504894340ebb64057e2b2c3 SHA512 6034086d6b6f6980468766c901e92291fea8a32df179561ede2add5918c37bfe3aabf122735d4ae2e28efece394fd3398f9a0cc4d8fdcc1e5da1ca709d2ba6ae
DIST nsd-4.2.4.tar.gz 1148826 BLAKE2B e2508c225d0bebeb9134c6eb3f00dfaf00d2de1a545cf9719b3bf04de8cf4a173ed744ebe5ff50a7062f5fb3135f4e476b9111736442fa358eb6ce20faac8406 SHA512 5d4f546a2a4484b182c65d3337d44596e935bca074c0eda2947b9d128a56db08a00240c6ec9ce22bc9a436e009c00c3283c4a5cbd1163ca4a429eaa92ec54208
DIST nsd-4.3.0.tar.gz 1168198 BLAKE2B 87eb68987dfff84f7ab3038e8c563724d2859e61d28238967d5db272f6783f026eaa3729b73bd16761b8218110bdac7d636307babdaf67b9d35ddeb013ab5ae8 SHA512 8724fdfe9ca07dce6cf73bd0441a5d6b6e8a37f31744aca185e8cff2bde66ba677c189bb0b5bd8c8ec5682cd623bf24c0087ae47630615292b96d89f1d4134c5
+DIST nsd-4.3.1.tar.gz 1173582 BLAKE2B 4766beefa9578bf11de9c8aeb4d0729b248893f36ffa72c699a134d0dcf758a247f8a9e31e8da182db982a8717f6cd737e95dac236420b18d34d7dc38bff0e57 SHA512 58b6e964795d6c796b547e1134cef954e5f4adf4e976db830ff7900892327154dab2a607ceadbb99072d6e5495d62c808c8fb8c94359ae93f636d11925c0d261
EBUILD nsd-4.2.4.ebuild 3013 BLAKE2B ea358a487f8e18f40a6d5018c04994607c9f7a66e53b31ea70eb24e0386ae15d8e7ac7c0c7196980241420a5de90fd30c980b03f30914febbe725608341fde6a SHA512 52b615e9b4676a35ebf0d3b413ed703c10b65f860adbdc490f9624d31e898dcee34fd01efc8d294b83a517ac54ddd713ab010fb296ade398a1ce4257f0054d01
EBUILD nsd-4.3.0.ebuild 3015 BLAKE2B e9be556ca875cf52a3f01887d5468388625378356d93ae3a94008d39fb0b8ae68fb06bbe5b328511ff5d633b6130a733bdec8ba6ded8c022f6cc75e8c8393499 SHA512 eda0d29c58cc70eb019767431ec3d32f6e663a0029b02bf4bbabf9b45168f6bfb1620f96e2d23c750760355a95b512afac338d705ab7c11df0b1bfab958c9139
+EBUILD nsd-4.3.1.ebuild 3015 BLAKE2B e9be556ca875cf52a3f01887d5468388625378356d93ae3a94008d39fb0b8ae68fb06bbe5b328511ff5d633b6130a733bdec8ba6ded8c022f6cc75e8c8393499 SHA512 eda0d29c58cc70eb019767431ec3d32f6e663a0029b02bf4bbabf9b45168f6bfb1620f96e2d23c750760355a95b512afac338d705ab7c11df0b1bfab958c9139
MISC metadata.xml 1082 BLAKE2B c44a5b7b9cb5ad52ebc55dd52a584cd8b0700977a19d541df1b415164250e390941ef35a0e8633a975e6cbae402719d8c5fe7d452dde5623223b01a7ec4320ac SHA512 a66e71346c6742c77ce38ca73f600dde471f3256928bab79f2015cb88c2f3237a4d69f7b9127ea90c58f584b60b8b676416b0704761ee1455479644fd2cd5a8d
diff --git a/net-dns/nsd/nsd-4.3.1.ebuild b/net-dns/nsd/nsd-4.3.1.ebuild
new file mode 100644
index 000000000000..b6ca20a489b4
--- /dev/null
+++ b/net-dns/nsd/nsd-4.3.1.ebuild
@@ -0,0 +1,116 @@
+# Copyright 1999-2020 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+
+inherit autotools systemd
+
+# version voodoo needed only for non-release tarballs: 4.0.0_rc1 => 4.0.0rc1
+MY_PV="${PV/_beta/b}"
+MY_PV="${MY_PV/_rc/rc}"
+MY_P="${PN}-${MY_PV}"
+
+DESCRIPTION="An authoritative only, high performance, open source name server"
+HOMEPAGE="http://www.nlnetlabs.nl/projects/nsd"
+SRC_URI="http://www.nlnetlabs.nl/downloads/${PN}/${MY_P}.tar.gz"
+LICENSE="BSD"
+SLOT="0"
+[[ "${PV}" == *_beta* ]] || [[ "${PV}" == *_rc* ]] || \
+KEYWORDS="~amd64 ~x86"
+IUSE="bind8-stats dnstap ipv6 libevent minimal-responses mmap munin +nsec3 ratelimit root-server runtime-checks ssl systemd libressl"
+
+S="${WORKDIR}/${MY_P}"
+
+RDEPEND="
+ acct-group/nsd
+ acct-user/nsd
+ dnstap? (
+ dev-libs/fstrm
+ dev-libs/protobuf-c
+ )
+ libevent? ( dev-libs/libevent )
+ munin? ( net-analyzer/munin )
+ ssl? (
+ !libressl? ( dev-libs/openssl:0= )
+ libressl? ( dev-libs/libressl:= )
+ )
+ systemd? ( sys-apps/systemd )
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ sys-devel/flex
+ virtual/yacc
+ systemd? ( virtual/pkgconfig )
+"
+
+PATCHES=(
+ # Fix the paths in the munin plugin to match our install
+ "${FILESDIR}"/nsd_munin_.patch
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ local myeconfargs=(
+ --enable-largefile
+ --enable-pie
+ --enable-relro-now
+ --enable-tcp-fastopen
+ --with-dbfile="${EPREFIX}"/var/db/nsd/nsd.db
+ --with-logfile="${EPREFIX}"/var/log/nsd.log
+ --with-pidfile="${EPREFIX}"/run/nsd/nsd.pid
+ --with-xfrdfile="${EPREFIX}"/var/db/nsd/xfrd.state
+ --with-xfrdir="${EPREFIX}"/var/db/nsd
+ --with-zonelistfile="${EPREFIX}"/var/db/nsd/zone.list
+ --with-zonesdir="${EPREFIX}"/var/lib/nsd
+ $(use_enable bind8-stats)
+ $(use_enable bind8-stats zone-stats)
+ $(use_enable dnstap)
+ $(use_enable ipv6)
+ $(use_enable minimal-responses)
+ $(use_enable mmap)
+ $(use_enable nsec3)
+ $(use_enable ratelimit)
+ $(use_enable root-server)
+ $(use_enable runtime-checks checking)
+ $(use_enable systemd)
+ $(use_with libevent)
+ $(use_with ssl)
+ )
+ econf "${myeconfargs[@]}"
+}
+
+src_install() {
+ emake DESTDIR="${D}" install
+
+ dodoc doc/{ChangeLog,CREDITS,NSD-4-features,NSD-FOR-BIND-USERS,README,RELNOTES,REQUIREMENTS}
+
+ newinitd "${FILESDIR}"/nsd.initd-r1 nsd
+
+ # install munin plugin and config
+ if use munin ; then
+ exeinto /usr/libexec/munin/plugins
+ doexe contrib/nsd_munin_
+ insinto /etc/munin/plugin-conf.d
+ newins "${FILESDIR}"/nsd.munin-conf nsd_munin
+ fi
+
+ systemd_dounit "${FILESDIR}"/nsd.service
+
+ # remove the /run directory that usually resides on tmpfs and is
+ # being taken care of by the nsd init script anyway (checkpath)
+ rm -r "${ED}"/run || die "Failed to remove /run"
+
+ keepdir /var/db/${PN}
+}
+
+pkg_postinst() {
+ # database directory, writable by nsd for database updates and zone transfers
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/db/nsd
+
+ # zones directory, writable by nsd for zone file updates (nsd-control write)
+ install -d -m 750 -o nsd -g nsd "${EROOT}"/var/lib/nsd
+}