summaryrefslogtreecommitdiff
path: root/net-dns/ndu
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-11-10 13:21:36 +0000
commit77398e424e45d9e98c1cef3c43bdadb9d56e81ef (patch)
tree5aeffd3fc7b92fc615bd2c222fa8831aeda1925b /net-dns/ndu
parentbd4aeefe33e63f613512604e47bfca7b2187697d (diff)
gentoo resync : 10.11.2019
Diffstat (limited to 'net-dns/ndu')
-rw-r--r--net-dns/ndu/Manifest2
-rw-r--r--net-dns/ndu/ndu-0.4-r4.ebuild50
2 files changed, 26 insertions, 26 deletions
diff --git a/net-dns/ndu/Manifest b/net-dns/ndu/Manifest
index c633f162c34d..2641e7ecfc51 100644
--- a/net-dns/ndu/Manifest
+++ b/net-dns/ndu/Manifest
@@ -1,4 +1,4 @@
AUX ndu-0.4-binary-locations.patch 426 BLAKE2B 6d8c5648b0c25129c87e73f3ac47f2baf699890fcf0023dbe801e7c3cfb4f32ca15287e5a70b9b7829364956a89ab9d04bc6088291890c1e4e949972823a76ed SHA512 58e248d48491759c33ae2ee2d57fdca38b718104606c05d965bc7b555cfd72388a906efd692d789d999fe782878e173438cc22f1091d278eed8b4322ec6f6294
DIST ndu-0.4.tar.gz 16118 BLAKE2B 7355d1d091f4b0865e3692b80a0dd4734e3e13464757adb1b9d712545ff4f827b828070f0bd027b077acb99c8d4ccd2ed645b3c7f114bfac65707ae7853ea3f2 SHA512 cf401f89f1d6ae66c5440e6ef43f1c78e071d13dd2b1d816f1c3bfd2a0b2d7d7a9d2be9025b3d88f3fbd186ff610ac92858e13b4e47b23b9088f91f3e1a40f39
-EBUILD ndu-0.4-r4.ebuild 1769 BLAKE2B fcda9075a22b4df05ed668a8ddc95a344f7743d537e8d337b4f3568644fc1555ff4bc8218023a8aee755ef09f181b4a913ab4bf316c779af626cc39a3dbacf8b SHA512 12f5f9904133ce3026327f5adf5b8653947d3490625c58d823caaf540bda63067e830725e5938d6997b8bf36c671eef2ef3dcec99cc80c7d457a05b37dbd1469
+EBUILD ndu-0.4-r4.ebuild 1732 BLAKE2B 0d1c5e1e15c84be13a9de9db8e20d495192eb3d945e64a25ce1bf34177d1ea6e77deb72c5b0bf12bf3673903011e9c7f79d138f3c1e18cb0c0770ff278f9e489 SHA512 3725905d057960b88921d6fe111317b1200944505a9646d80ce2fdc8e7857244b68b63d03adff834ef1da0011430b81b99e3eb6d622240c15bc68f3d49553ead
MISC metadata.xml 268 BLAKE2B 914b6995ad966e2b83ec718b2598969b181c119d8805241b0046f69e161ac22a9f769204f4783240056804008475aa406cbd91b9de499ec7840f9595158bd291 SHA512 ffda1db3fd6ac952f41a970e2e496c6a9fd0b12ed11cdf363fd269c3b00f627c6e70421fd545aad61d69594af2e5f43d8ebc197232a39b596d012818fe758850
diff --git a/net-dns/ndu/ndu-0.4-r4.ebuild b/net-dns/ndu/ndu-0.4-r4.ebuild
index b64497eb415c..78c645acef4f 100644
--- a/net-dns/ndu/ndu-0.4-r4.ebuild
+++ b/net-dns/ndu/ndu-0.4-r4.ebuild
@@ -1,54 +1,54 @@
-# Copyright 1999-2018 Gentoo Foundation
+# Copyright 1999-2019 Gentoo Authors
# Distributed under the terms of the GNU General Public License v2
-EAPI=0
+EAPI=7
-inherit eutils toolchain-funcs
+inherit toolchain-funcs
DESCRIPTION="DNS serial number incrementer and reverse zone builder"
SRC_URI="http://uranus.it.swin.edu.au/~jn/linux/${P}.tar.gz"
HOMEPAGE="https://wiki.gentoo.org/wiki/No_homepage"
+
LICENSE="GPL-2"
SLOT="0"
KEYWORDS="amd64 ppc x86"
IUSE=""
-DEPEND="sys-apps/sed"
+
RDEPEND="sys-apps/ed" # dnstouch calls ed to do the dirty work
-src_unpack() {
- unpack ${A}
+src_prepare() {
+ default
+ eapply "${FILESDIR}"/${P}-binary-locations.patch
- epatch "${FILESDIR}"/${P}-binary-locations.patch
+ # match our bind config
+ sed -e 's|0.0.127.in-addr.arpa|127.in-addr.arpa|g' -i ndu.conf || die
+ # document the support for the chrooted BIND setup
+ cat >> ndu.conf <<-EOF || die
+ // if you use a chrooted setup, then you need to uncomment these lines:
+ //process "/chroot/dns/named.conf"
+ //chroot "/chroot/dns"
+ EOF
- cd "${S}"/src
+ cd src || die
# use the correct compiler
- sed -e 's|gcc|$(CXX)|g' -i Makefile
+ sed -e 's|gcc|$(CXX)|g' -i Makefile || die
# set correct config pathes
- sed -e 's|#define CONFIG_PATH "/etc/"|#define CONFIG_PATH "/etc/bind/"|g' -i ndu.cpp
- sed -e 's|"/etc/ndu.conf"|"/etc/bind/ndu.conf"|g' -i dnstouch.cpp
+ sed -e 's|#define CONFIG_PATH "/etc/"|#define CONFIG_PATH "/etc/bind/"|g' \
+ -i ndu.cpp || die
+ sed -e 's|"/etc/ndu.conf"|"/etc/bind/ndu.conf"|g' -i dnstouch.cpp || die
# hack up something to work around bug #73858
- sed -e 's|execlp("ed", "ed", filename, 0);|execlp("ed", "ed", "-s", filename, 0);|g' -i dnstouch.cpp
+ sed -e 's|execlp("ed", "ed", filename, 0);|execlp("ed", "ed", "-s", filename, 0);|g' \
+ -i dnstouch.cpp || die
# use the correct editor
- sed -e 's|VISUAL|EDITOR|g' -i dnsedit
-
- cd "${S}"
- # match our bind config
- sed -e 's|0.0.127.in-addr.arpa|127.in-addr.arpa|g' -i ndu.conf
- # document the support for the chrooted BIND setup
- echo '// if you use a chrooted setup, then you need to uncomment these lines:' >>ndu.conf
- echo '//process "/chroot/dns/named.conf"' >>ndu.conf
- echo '//chroot "/chroot/dns"' >>ndu.conf
+ sed -e 's|VISUAL|EDITOR|g' -i dnsedit || die
}
src_compile() {
- cd "${S}"/src
- emake CFLAGS="${CFLAGS}" CXX="$(tc-getCXX)"
+ emake -C src CFLAGS="${CFLAGS}" CXX="$(tc-getCXX)"
}
src_install () {
- into /usr
dobin src/{dnsedit,ndu,dnstouch}
- into /
insinto /etc/bind
doins ndu.conf
dodoc README INSTALL