summaryrefslogtreecommitdiff
path: root/net-dns/mydns
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
committerV3n3RiX <venerix@redcorelinux.org>2019-02-10 15:40:27 +0000
commit6bc2e4d7c5906e46a8f275a876ead6ec41aca5bb (patch)
treecee0a97398040001220ece3cd48c3d568bcddb4a /net-dns/mydns
parent1db00cc6e94b90c08090bb5b8c406622946c4ae5 (diff)
gentoo resync : 10.02.2019
Diffstat (limited to 'net-dns/mydns')
-rw-r--r--net-dns/mydns/Manifest1
-rw-r--r--net-dns/mydns/mydns-1.2.8.31-r2.ebuild88
2 files changed, 89 insertions, 0 deletions
diff --git a/net-dns/mydns/Manifest b/net-dns/mydns/Manifest
index 89d1b05be876..a7b6b6a710f6 100644
--- a/net-dns/mydns/Manifest
+++ b/net-dns/mydns/Manifest
@@ -4,4 +4,5 @@ AUX mydns.confd 84 BLAKE2B e95e66b464e9f7e7d3742312c9cd9bebc5cedc1f4f49fb4e632ef
AUX mydns.initd 850 BLAKE2B 58275e0415dbf27344045e9cc19037e09a5ee9dd1a52f80b6c05852313b646c7b41a52f1be46ff13629bc0873b2b7fc1db73e0cd45cfc7bb4c6d9a0582524fa1 SHA512 919a7022a350b121c8c0eed962d7a7233dc41f2e4cfda1185d642114719a533cff580367b9302b24e8c9d377c2ccb9b02ad45d638d5b483b7c101405cb9ba1be
DIST mydns-1.2.8.31.tar.gz 958701 BLAKE2B a07ca8314f6f8d3ce6cf88ce3a49238d00f1ed8e2352f3a76a9ffa348711f76e0cf19fa304a92a71b420c39db2795094d42997daddb091c7046e4bf1b61f6fe8 SHA512 471dfed9b4f38b446fd5896939faa4c58f4e1b3a3e6928fa84eddf769eba8f3406ef08c77ab39ee79d2ac85c1e72a499b283c7404a0cae9830ffe0faee9e2737
EBUILD mydns-1.2.8.31-r1.ebuild 2066 BLAKE2B 42e31c747bd2efc110db0f57502987d5d7303248d74a928e896f861ce3b8279f7c51de54fb13ac9b514f801aafaa5a0f21fa2fb6daefcb8edf3655c14ae154b1 SHA512 007e14a8d4616530576173ef53a3e9e6588be18ed132965b265e88cf40874f465e9f391be19cc16d638823a88421718741028c160eb1f047106cc69571509a29
+EBUILD mydns-1.2.8.31-r2.ebuild 2085 BLAKE2B beb1ad22b99450b0606361119b9d9d266195bb085508835076ba1d5315b7abfc78cbba957137b826f74166b4daa413f4bead70942c2511760503be5d63152d86 SHA512 fb6b705de52708b4c0dc4310695dc9da81bdd26102b0f9f82f06fa212f85dd6f0b1bf85f96faad6a00e59c5d1991decb92d783fcfa1d828626f52f8f601e8647
MISC metadata.xml 396 BLAKE2B c343b16b422a587d568b331f868e959348bd12cdb7ee28d6390ebeca8234f1e34ef9efcf7aa70e9b18dac66777ab46763c41f8b68e3f9d96b3863d085ed51066 SHA512 cba5e716877204e00ef18549d35bb39f47921389f8712c69ce81b8dd365505d6ea95fed89976bfc6722343dadd15f914f27d26fe35416c242e7963d467b147d0
diff --git a/net-dns/mydns/mydns-1.2.8.31-r2.ebuild b/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
new file mode 100644
index 000000000000..5f6aeb01f0cb
--- /dev/null
+++ b/net-dns/mydns/mydns-1.2.8.31-r2.ebuild
@@ -0,0 +1,88 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+
+inherit autotools
+
+DESCRIPTION="A DNS-Server which gets its data from a MySQL-/PostgreSQL-database"
+HOMEPAGE="http://www.mydns.pl/"
+SRC_URI="mirror://sourceforge/mydns-ng/${P}.tar.gz"
+
+LICENSE="GPL-2"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~hppa ~ia64 ~ppc ~sparc ~x86"
+IUSE="alias debug nls mysql postgres ssl static status"
+
+RDEPEND="mysql? ( dev-db/mysql-connector-c:= )
+ nls? ( virtual/libintl )
+ postgres? ( dev-db/postgresql )
+ ssl? ( dev-libs/openssl:0= )
+ virtual/libiconv"
+DEPEND="${RDEPEND}
+ nls? ( >=sys-devel/gettext-0.12 )
+ sys-devel/bison"
+
+REQUIRED_USE="^^ ( mysql postgres )"
+
+PATCHES=(
+ "${FILESDIR}/${PN}-1.2.8.27-m4.patch"
+ "${FILESDIR}/${P}-texinfo.patch"
+)
+
+src_prepare() {
+ default
+ eautoreconf
+}
+
+src_configure() {
+ econf \
+ $(use_enable alias) \
+ $(use_enable nls) \
+ $(use_enable debug) \
+ $(use_with mysql) \
+ $(use_with postgres pgsql) \
+ $(use_enable static) \
+ $(use_enable static static-build) \
+ $(use_enable status) \
+ $(use_with ssl openssl) \
+ --without-included-gettext
+}
+
+src_install() {
+ default
+
+ dodoc AUTHORS BUGS ChangeLog QUICKSTART* NEWS README* TODO
+ docinto contrib
+ dodoc contrib/*.php contrib/*.pl contrib/*.pm contrib/README*
+
+ newinitd "${FILESDIR}/mydns.initd" mydns
+ newconfd "${FILESDIR}/mydns.confd" mydns
+
+ ## Avoid file collision
+ rm -f "${ED}/usr/share/locale/locale.alias"
+
+ # Install config file
+ insinto /etc
+ newins mydns.conf mydns.conf
+ fowners root:root /etc/mydns.conf
+ fperms 0600 /etc/mydns.conf
+}
+
+pkg_postinst() {
+ if use postgres; then
+ elog "# createdb mydns"
+ elog "# /usr/sbin/mydns --create-tables | psql mydns"
+ elog
+ elog "to create the tables in the PostgreSQL-Database."
+ elog "For more info see QUICKSTART.postgres."
+ fi
+ if use mysql; then
+ elog "# mysqladmin -u <useruname> -p create mydns"
+ elog "# /usr/sbin/mydns --create-tables | mysql -u <username> -p mydns"
+ elog
+ elog "to create the tables in the MySQL-Database."
+ elog "For more info see QUICKSTART.mysql."
+ fi
+ elog
+}