summaryrefslogtreecommitdiff
path: root/net-dns/libidn2
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2018-05-20 20:14:27 +0100
committerV3n3RiX <venerix@redcorelinux.org>2018-05-20 20:14:27 +0100
commit2bacbb3374587799c77a999f56352233a353b19e (patch)
tree1bcd1ca794782a57f9ab99006e97da5b785e042a /net-dns/libidn2
parent97967bbbae8f43c98315b079178f1717f130e302 (diff)
gentoo resync : 20.05.2018
Diffstat (limited to 'net-dns/libidn2')
-rw-r--r--net-dns/libidn2/Manifest2
-rw-r--r--net-dns/libidn2/libidn2-2.0.5.ebuild51
2 files changed, 53 insertions, 0 deletions
diff --git a/net-dns/libidn2/Manifest b/net-dns/libidn2/Manifest
index 37b4777df0ea..4a764a64f7a0 100644
--- a/net-dns/libidn2/Manifest
+++ b/net-dns/libidn2/Manifest
@@ -1,3 +1,5 @@
DIST libidn2-2.0.4.tar.gz 2008524 BLAKE2B 7163e1eff498031c7433911533b34d993876b55d9b324aaef39c93db2cceee78dec4c8cfbf4d9dabd1dbbb03a8cbd65021f26a94758f57b32ef98dc869f744b6 SHA512 1e51bd4b8f8907531576291f1c2a8865d17429b4105418b4c98754eb982cd1cbb3adbeab4ec0c1c561d2dba11d876c7c09e5dc5b315c55a2c24986d7a2a3b4d2
+DIST libidn2-2.0.5.tar.gz 2091929 BLAKE2B 1eb52ae7c9295bf4b5d6e36e6852ffb54b10663a0e3cea06df110bd7798fcb0d1b8e3b7169e4a11e800a23fc9f606167dcb7fc2d4a684e861d73a236de5c578c SHA512 9d040d60de40316788825d8720d509d5b8a82287415e09e17792c2f32fad99ca77f43e55888b9484db69426eaa0ece59e9671eee9cc46411afbdb0f81af31a79
EBUILD libidn2-2.0.4.ebuild 1237 BLAKE2B d0b1a78213888d195af827682340c16836fab292650cc904554e3bacba9e8b2e751b485ba2a7413b8a638bf64203849a2c49426e388d22eaaabd1db6f7c6cdca SHA512 66e24dc0ae01d8009783c0cc1722bbcbc73baf4a2a4332f35902f75c73bd7b9a3c05c752833b32e5e75ffc2b6c3b923572962b6d22777efdf21a44e66ec693fe
+EBUILD libidn2-2.0.5.ebuild 1250 BLAKE2B e72388c4f68dee0b4fe0d35efe065154fbb84f9f2dbf85c06a59fc29b7e8630faa67db85f10f9789915035402c606b48315e83c37b70301f0da0e31853d5a425 SHA512 b9cc9e347080ea844eeec879c518538726849fd80ff00b8ba5769cbb5696ec59661145f0f215c27b1674cec46c679cc009084a2328a900fe2857d54bd009288a
MISC metadata.xml 210 BLAKE2B bb9591af5406abbf589664053ab6e5cb38933fe6ef97c11609405392b050b26cff8e94e04e85e5798124abd46283bee67b2a74923a5041616df15aaa9cff6da9 SHA512 f7cbe57a24b67a28696f91061ad8bd61d7d4cf3d59d20c3dcc6a4921e29672d00ecf3ece70a8813399d2467ebd626f8f829300e81fc722e9aaa527e213a5fb54
diff --git a/net-dns/libidn2/libidn2-2.0.5.ebuild b/net-dns/libidn2/libidn2-2.0.5.ebuild
new file mode 100644
index 000000000000..ab79a5425424
--- /dev/null
+++ b/net-dns/libidn2/libidn2-2.0.5.ebuild
@@ -0,0 +1,51 @@
+# Copyright 1999-2018 Gentoo Foundation
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=6
+inherit eutils flag-o-matic multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/jas/libidn2"
+SRC_URI="
+ mirror://gnu/libidn/${P}.tar.gz
+"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS="~alpha ~amd64 ~arm ~arm64 ~hppa ~ia64 ~m68k ~mips ~ppc ~ppc64 ~s390 ~sh ~sparc ~x86 ~ppc-aix ~x64-cygwin ~amd64-fbsd ~amd64-linux ~arm-linux ~x86-linux ~ppc-macos ~x64-macos ~x86-macos ~m68k-mint ~sparc-solaris ~sparc64-solaris ~x64-solaris ~x86-solaris"
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/libunistring[${MULTILIB_USEDEP}]
+"
+DEPEND="
+ ${RDEPEND}
+ dev-lang/perl
+ sys-apps/help2man
+"
+
+src_prepare() {
+ default
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # Darwin ar chokes when TMPDIR doesn't exist (as done for some
+ # reason in the Makefile)
+ sed -i -e '/^TMPDIR = /d' Makefile.in || die
+ export TMPDIR="${T}"
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-doc \
+ --disable-gtk-doc
+}
+
+multilib_src_install() {
+ default
+
+ prune_libtool_files
+}