summaryrefslogtreecommitdiff
path: root/net-dns/libidn2/libidn2-99999.ebuild
diff options
context:
space:
mode:
authorV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
committerV3n3RiX <venerix@redcorelinux.org>2019-04-28 09:54:45 +0100
commitb7ebc951da8800f711142f69d9d958bde67a112d (patch)
treee318514216845acb8f2e49fff7a5cba4027e9d91 /net-dns/libidn2/libidn2-99999.ebuild
parentdc7cbdfa65fd814b3b9aa3c56257da201109e807 (diff)
gentoo resync : 28.04.2019
Diffstat (limited to 'net-dns/libidn2/libidn2-99999.ebuild')
-rw-r--r--net-dns/libidn2/libidn2-99999.ebuild64
1 files changed, 64 insertions, 0 deletions
diff --git a/net-dns/libidn2/libidn2-99999.ebuild b/net-dns/libidn2/libidn2-99999.ebuild
new file mode 100644
index 000000000000..5e05d730b6ad
--- /dev/null
+++ b/net-dns/libidn2/libidn2-99999.ebuild
@@ -0,0 +1,64 @@
+# Copyright 1999-2019 Gentoo Authors
+# Distributed under the terms of the GNU General Public License v2
+
+EAPI=7
+inherit autotools git-r3 multilib-minimal
+
+DESCRIPTION="An implementation of the IDNA2008 specifications (RFCs 5890, 5891, 5892, 5893)"
+HOMEPAGE="https://www.gnu.org/software/libidn/#libidn2 https://gitlab.com/libidn/libidn2"
+EGIT_REPO_URI="https://gitlab.com/libidn/libidn2.git/"
+SRC_URI="mirror://gnu/libunistring/libunistring-0.9.10.tar.gz"
+
+LICENSE="GPL-2+ LGPL-3+"
+SLOT="0"
+KEYWORDS=""
+IUSE="static-libs"
+
+RDEPEND="
+ dev-libs/libunistring[${MULTILIB_USEDEP}]
+"
+DEPEND="${RDEPEND}"
+BDEPEND="
+ dev-lang/perl
+ dev-util/gengetopt
+ sys-apps/help2man
+"
+S=${WORKDIR}/${P/a/}
+
+src_unpack() {
+ git-r3_src_unpack
+ unpack ${A}
+}
+
+src_prepare() {
+ mv "${WORKDIR}"/libunistring-0.9.10 unistring || die
+
+ einfo "./bootstrap"
+ ./bootstrap --gnulib-srcdir=gnulib --no-bootstrap-sync --no-git --skip-po || die
+
+ default
+
+ eautoreconf
+
+ if [[ ${CHOST} == *-darwin* ]] ; then
+ # Darwin ar chokes when TMPDIR doesn't exist (as done for some
+ # reason in the Makefile)
+ sed -i -e '/^TMPDIR = /d' Makefile.in || die
+ export TMPDIR="${T}"
+ fi
+
+ multilib_copy_sources
+}
+
+multilib_src_configure() {
+ econf \
+ $(use_enable static-libs static) \
+ --disable-doc \
+ --disable-gtk-doc
+}
+
+multilib_src_install() {
+ default
+
+ find "${D}" -name '*.la' -delete || die
+}